This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 852295 - Rebalance status command does not respond if network is down or power failure on any of the nodes in the cluster
Rebalance status command does not respond if network is down or power failure...
Status: CLOSED DUPLICATE of bug 852147
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs-server (Show other bugs)
2.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
Sudhir D
:
Depends On: 822784
Blocks: 858476
  Show dependency treegraph
 
Reported: 2012-08-28 03:08 EDT by Vidya Sakar
Modified: 2015-11-03 18:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 822784
: 858476 (view as bug list)
Environment:
Last Closed: 2013-01-09 02:55:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-28 03:08:16 EDT
+++ This bug was initially created as a clone of Bug #822784 +++

Created attachment 585348 [details]
fsm logs

Description of problem:
Issuing rebalance status command does not responds if network fails or power failure occurs on any of the node in the cluster.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. created a distributed-replicate volume and fill up with some data
2. add-brick and initiate rebalance .
3. check the status 
4. Now bring down network or reboot any of the machine in the cluster
5. Now check the status
  
Actual results:

status command will not respond anything , it waits for some time and comes back with return value 234.

Expected results:


Additional info:

Attaching the fsm-logs.

--- Additional comment from amarts@redhat.com on 2012-07-11 01:22:22 EDT ---

shylesh, can you check if this happens on master/3.3.0 release?

--- Additional comment from shmohan@redhat.com on 2012-07-11 07:18:39 EDT ---

 (In reply to comment #1)
> shylesh, can you check if this happens on master/3.3.0 release?

Yes amar this issue is still reproducible on latest master.
Comment 2 krishnan parthasarathi 2013-01-09 02:55:48 EST

*** This bug has been marked as a duplicate of bug 852147 ***

Note You need to log in before you can comment on or make changes to this bug.