Bug 858476 - Rebalance status command does not respond if network is down or power failure on any of the nodes in the cluster
Rebalance status command does not respond if network is down or power failure...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Avra Sengupta
shylesh
:
Depends On: 822784 852147 852295
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 18:28 EDT by Scott Haines
Modified: 2015-01-22 10:30 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.3rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 852295
Environment:
Last Closed: 2013-09-23 18:39:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 Amar Tumballi 2013-01-31 01:45:30 EST
Lets target this only on 2.1.0 flag. If anyone has concerns, please re-open the flag for 2.0.z
Comment 3 Amar Tumballi 2013-02-05 23:50:47 EST
Avra, this should be addressed by synctask'izing the rebalance commands.
Comment 4 senaik 2013-06-27 07:55:45 EDT
Verified on version : 3.4.0.12rhs-1.el6rhs.x86_64

Steps : 
========
- created a 2x2 distributed replicate volume 
- filled the mount point with some files 
- added 2 bricks and started rebalance 
- checked rebalance status 
- while rebalance is running , powered off one of the nodes in cluster
- checked rebalance status again . Output was as expected 
 
There was no delay in the output of rebalance status command . 

gluster v rebalance dis_rep1 status

Node   Rebalanced-files  size    scanned   failures     status run time in secs

localhost     26        260.0MB   202       0       in progress    60.00
10.70.34.86   27        260.0MB   74        0       in progress    59.00


Node   Rebalanced-files  size    scanned   failures     status run time in secs

localhost     26        260.0MB   202       0       in progress    61.00
10.70.34.86   27        260.0MB   74        0       in progress    61.00

Could not reproduce the issue . Marking it as Verified .
Comment 5 Scott Haines 2013-09-23 18:39:13 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:43:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.