Bug 852443 - Host fencing: refused to stop host due to its 'wrong' status
Host fencing: refused to stop host due to its 'wrong' status
Status: CLOSED DUPLICATE of bug 852464
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Linux
high Severity urgent
: ---
: ---
Assigned To: Eli Mesika
Larisa Ustalov
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 09:55 EDT by Larisa Ustalov
Modified: 2016-02-10 14:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 13:10:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larisa Ustalov 2012-08-28 09:55:00 EDT
Description of problem:
When vdsmd is stopped on host, we expect the host to be re-started.
But PM stop is failing with the following error: VDS_STATUS_NOT_VALID_FOR_STOP
It leaves host in non-responsive status.


Steps to Reproduce:
1.add host to cluster
2.wait until it turns up
3.stop vdsmd on the host
  
Actual results:
host is 'non-responsive'

Expected results:
should be 'up'


Additional info:

2012-08-28 12:47:48,223 WARN  [org.ovirt.engine.core.vdsbroker.VdsManager] (QuartzScheduler_Worker-10) ResourceManager::refreshVdsRunTimeInfo::Failed to refresh VDS , vds = cac11500-f0f3-11e1-9449-001a4a2312ae : cinteg34.ci.lab.tlv.redhat.com, VDS Network Error, continuing.
VDSNetworkException: 
2012-08-28 12:47:50,249 ERROR [org.ovirt.engine.core.vdsbroker.VdsManager] (QuartzScheduler_Worker-12) VDS::handleNetworkException Server failed to respond,  vds_id = cac11500-f0f3-11e1-9449-001a4a2312ae, vds_name = cinteg34.ci.lab.tlv.redhat.com, error = VDSNetworkException: 
2012-08-28 12:47:50,274 INFO  [org.ovirt.engine.core.bll.VdsEventListener] (pool-7-thread-50) ResourceManager::vdsNotResponding entered for Host cac11500-f0f3-11e1-9449-001a4a2312ae, 10.35.148.106
2012-08-28 12:47:50,320 INFO  [org.ovirt.engine.core.bll.FencingExecutor] (pool-7-thread-50) Executing <Status> Power Management command, Proxy Host:cinteg35.ci.lab.tlv.redhat.com, Agent:ipmilan, Target Host:cinteg34.ci.lab.tlv.redhat.com, Management IP:10.35.148.107, User:admin, Options:
2012-08-28 12:47:50,323 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (pool-7-thread-50) START, FenceVdsVDSCommand(vdsId = cbcf3c10-f0f3-11e1-ac59-001a4a2312ae, targetVdsId = cac11500-f0f3-11e1-9449-001a4a2312ae, action = Status, ip = 10.35.148.107, port = , type = ipmilan, user = admin, password = ******, options = ''), log id: 383cccef
2012-08-28 12:47:50,430 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (pool-7-thread-50) FINISH, FenceVdsVDSCommand, return: Test Succeeded, Host Status is: on, log id: 383cccef
2012-08-28 12:47:50,436 INFO  [org.ovirt.engine.core.bll.VdsNotRespondingTreatmentCommand] (pool-7-thread-50) Running command: VdsNotRespondingTreatmentCommand internal: true. Entities affected :  ID: cac11500-f0f3-11e1-9449-001a4a2312ae Type: VDS
2012-08-28 12:47:50,487 INFO  [org.ovirt.engine.core.bll.FencingExecutor] (pool-7-thread-50) Executing <Status> Power Management command, Proxy Host:cinteg35.ci.lab.tlv.redhat.com, Agent:ipmilan, Target Host:cinteg34.ci.lab.tlv.redhat.com, Management IP:10.35.148.107, User:admin, Options:
2012-08-28 12:47:50,489 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (pool-7-thread-50) START, FenceVdsVDSCommand(vdsId = cbcf3c10-f0f3-11e1-ac59-001a4a2312ae, targetVdsId = cac11500-f0f3-11e1-9449-001a4a2312ae, action = Status, ip = 10.35.148.107, port = , type = ipmilan, user = admin, password = ******, options = ''), log id: 63877381
2012-08-28 12:47:50,640 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (pool-7-thread-50) FINISH, FenceVdsVDSCommand, return: Test Succeeded, Host Status is: on, log id: 63877381
2012-08-28 12:47:50,640 WARN  [org.ovirt.engine.core.bll.StopVdsCommand] (pool-7-thread-50) CanDoAction of action StopVds failed. Reasons:VDS_STATUS_NOT_VALID_FOR_STOP
Comment 1 Itamar Heim 2012-08-28 13:10:09 EDT

*** This bug has been marked as a duplicate of bug 852464 ***

Note You need to log in before you can comment on or make changes to this bug.