Bug 852551 - channel-cert-mapping.txt is missing a mapping for product "Red Hat Developer Toolset"
channel-cert-mapping.txt is missing a mapping for product "Red Hat Developer ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-28 18:16 EDT by John Sefler
Modified: 2013-01-08 02:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 820749
Environment:
Last Closed: 2013-01-08 02:28:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 John Sefler 2012-08-28 18:17:41 EDT
[root@jsefler-59client ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.3-1.git.4.8bd27be.el5

Testing with this continuous integration build, there are still some channels that are not obeying this special rule from comment 4...

rhel-i386-client-dts-5-beta
rhel-i386-client-dts-5-beta-debuginfo
rhel-i386-server-dts-5-beta
rhel-i386-server-dts-5-beta-debuginfo

[root@jsefler-59client ~]# grep rhel-i386-client-dts-5-beta /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-i386-client-dts-5-beta: Client-DTS-i386-f796e566d707-178.pem
rhel-i386-client-dts-5-beta-debuginfo: Client-DTS-i386-f796e566d707-178.pem
[root@jsefler-59client ~]# grep rhel-i386-server-dts-5-beta /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-i386-server-dts-5-beta: Server-DTS-i386-79f8ebcf28ce-176.pem
rhel-i386-server-dts-5-beta-debuginfo: Server-DTS-i386-79f8ebcf28ce-176.pem

^ Those channels should be mapping to 180.pem in channel-cert-mapping.txt
Comment 3 RHEL Product and Program Management 2012-08-28 18:26:54 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Alex Wood 2012-08-29 16:46:51 EDT
Refs: subscription-manager-migration-data-1.11.2.3-1-5-g1ca2bac
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Wed Aug 29 12:41:38 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Wed Aug 29 12:41:38 2012 -0400

    820749: Correct mappings for i386 DTS.
Comment 7 John Sefler 2012-09-07 15:37:56 EDT
Verifying Version...
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.4-1.el5


[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 176.pem
/usr/share/rhsm/product/RHEL-5/Server-DTS-i386-79f8ebcf28ce-176.pem
/usr/share/rhsm/product/RHEL-5/Server-DTS-x86_64-a1d1629fc6f3-176.pem
[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 177.pem
[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 178.pem
/usr/share/rhsm/product/RHEL-5/Client-DTS-i386-f796e566d707-178.pem
/usr/share/rhsm/product/RHEL-5/Client-DTS-x86_64-28b253fcac29-178.pem
[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 179.pem
[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 180.pem
/usr/share/rhsm/product/RHEL-5/RHB-i386-ce28032e05c7-180.pem
/usr/share/rhsm/product/RHEL-5/RHB-x86_64-99c22e1e646f-180.pem


[root@rhsm-accept-rhel5 ~]# grep rhel-i386-client-dts-5 /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-i386-client-dts-5: Client-DTS-i386-f796e566d707-178.pem
rhel-i386-client-dts-5-beta: RHB-i386-ce28032e05c7-180.pem
rhel-i386-client-dts-5-beta-debuginfo: RHB-i386-ce28032e05c7-180.pem
rhel-i386-client-dts-5-debuginfo: Client-DTS-i386-f796e566d707-178.pem
[root@rhsm-accept-rhel5 ~]# grep rhel-x86_64-client-dts-5 /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-x86_64-client-dts-5: Client-DTS-x86_64-28b253fcac29-178.pem
rhel-x86_64-client-dts-5-beta: RHB-x86_64-99c22e1e646f-180.pem
rhel-x86_64-client-dts-5-beta-debuginfo: RHB-x86_64-99c22e1e646f-180.pem
rhel-x86_64-client-dts-5-debuginfo: Client-DTS-x86_64-28b253fcac29-178.pem
[root@rhsm-accept-rhel5 ~]# 
[root@rhsm-accept-rhel5 ~]# 
[root@rhsm-accept-rhel5 ~]# grep rhel-i386-server-dts-5 /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-i386-server-dts-5: Server-DTS-i386-79f8ebcf28ce-176.pem
rhel-i386-server-dts-5-beta: RHB-i386-ce28032e05c7-180.pem
rhel-i386-server-dts-5-beta-debuginfo: RHB-i386-ce28032e05c7-180.pem
rhel-i386-server-dts-5-debuginfo: Server-DTS-i386-79f8ebcf28ce-176.pem
[root@rhsm-accept-rhel5 ~]# grep rhel-x86_64-server-dts-5 /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-x86_64-server-dts-5: Server-DTS-x86_64-a1d1629fc6f3-176.pem
rhel-x86_64-server-dts-5-beta: RHB-x86_64-99c22e1e646f-180.pem
rhel-x86_64-server-dts-5-beta-debuginfo: RHB-x86_64-99c22e1e646f-180.pem
rhel-x86_64-server-dts-5-debuginfo: Server-DTS-x86_64-a1d1629fc6f3-176.pem


^^^ VERIFIED: All of the expected "Red Hat Developer Toolset" and "Red Hat Beta" product certs and mappings for RHEL5 are accounted for in the subscription-manager-migration-data.  Note that product ids 177 and 179 are for RHEL6 variants and therefore not needed in the RHEL5 subscription-manager-migration-data rpm.
Comment 9 errata-xmlrpc 2013-01-08 02:28:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0055.html

Note You need to log in before you can comment on or make changes to this bug.