Bug 820749 - channel-cert-mapping.txt is missing a mapping for product "Red Hat Developer Toolset"
Summary: channel-cert-mapping.txt is missing a mapping for product "Red Hat Developer ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Entitlement Bugs
URL:
Whiteboard:
: 966683 (view as bug list)
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2012-05-10 21:10 UTC by John Sefler
Modified: 2014-10-14 07:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
: 852551 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:45:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2012-05-10 21:10:46 UTC
Description of problem:
Our automated subscription-manager-migration-data test discovered new entries in product-baseline.json...

         "Name": "Red Hat Beta",
         "Product ID": "180",

         "Name": "Red Hat Developer Toolset (for RHEL Workstation)",
         "Product ID": "179",

         "Name": "Red Hat Developer Toolset (for RHEL Client)",
         "Product ID": "178",

         "Name": "Red Hat Developer Toolset (for RHEL HPC Node)",
         "Product ID": "177",

         "Name": "Red Hat Developer Toolset (for RHEL Server)",
         "Product ID": "176",

... and there are no corresponding products [rcm/rhn-definitions.git] / product_ids / 

We will need rel-eng to created the missing product certs for rhel-6.4 

Version-Release number of selected component (if applicable):
[root@qe-blade-13 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.8-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@qe-blade-13 ~]# rpm -ql subscription-manager-migration-data | grep 176.pem
[root@qe-blade-13 ~]# rpm -ql subscription-manager-migration-data | grep 177.pem
[root@qe-blade-13 ~]# rpm -ql subscription-manager-migration-data | grep 178.pem
[root@qe-blade-13 ~]# rpm -ql subscription-manager-migration-data | grep 179.pem
[root@qe-blade-13 ~]# rpm -ql subscription-manager-migration-data | grep 180.pem
[root@qe-blade-13 ~]# 

^^ Expected each of those greps to find a product cert

Comment 2 RHEL Program Management 2012-07-10 08:17:25 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Program Management 2012-07-11 01:50:11 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 4 John Sefler 2012-08-28 17:11:18 UTC
pasting a note from dgregor on example logic needed rhn-migrate-classic-to-rhsm

> if customer subscribed to a channel that maps to both 178 and 180:
>    # example rhel-i386-client-dts-5-beta
>    if customer subscribed to a channel that maps to just 178:
>       #example: rhel-i386-client-dts
>       use 178.pem
>    else:
>       use 180.pem

Comment 7 John Sefler 2012-12-06 15:17:25 UTC
Testing version...
[root@jsefler-6 rhnDefinitionsDir]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.2.6-1.el6.noarch


[root@jsefler-6 rhnDefinitionsDir]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.2.6-1.el6.noarch
[root@jsefler-6 rhnDefinitionsDir]# rpm -ql subscription-manager-migration-data | grep 176.pem
/usr/share/rhsm/product/RHEL-6/Server-DTS-i386-79f8ebcf28ce-176.pem
/usr/share/rhsm/product/RHEL-6/Server-DTS-x86_64-a1d1629fc6f3-176.pem
[root@jsefler-6 rhnDefinitionsDir]# rpm -ql subscription-manager-migration-data | grep 177.pem
[root@jsefler-6 rhnDefinitionsDir]# rpm -ql subscription-manager-migration-data | grep 178.pem
/usr/share/rhsm/product/RHEL-6/Client-DTS-i386-f796e566d707-178.pem
/usr/share/rhsm/product/RHEL-6/Client-DTS-x86_64-28b253fcac29-178.pem
[root@jsefler-6 rhnDefinitionsDir]# rpm -ql subscription-manager-migration-data | grep 179.pem
/usr/share/rhsm/product/RHEL-6/Workstation-DTS-i386-21fbbb933d16-179.pem
/usr/share/rhsm/product/RHEL-6/Workstation-DTS-x86_64-6307b5fe6b69-179.pem
[root@jsefler-6 rhnDefinitionsDir]# rpm -ql subscription-manager-migration-data | grep 180.pem
/usr/share/rhsm/product/RHEL-6/RHB-i386-ce28032e05c7-180.pem
/usr/share/rhsm/product/RHEL-6/RHB-x86_64-99c22e1e646f-180.pem


^^^ product cert 177.pem is still missing.
This requires help from rel-eng to create a product cert before the mappings can be generated in channel-cert-mapping.txt for product 177.
blocked by bug 884688

Comment 8 Dennis Gregorovic 2012-12-11 22:01:59 UTC
bug 884688 just moved to MODIFIED

Comment 9 RHEL Program Management 2012-12-15 06:49:13 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 11 Dennis Gregorovic 2013-09-20 20:11:58 UTC
After chatting with Alex, I believe all that's needed is to map the DTS 1 Beta channels to 180.pem.  I should be able to have that early next week.

Comment 12 Dennis Gregorovic 2013-09-20 20:20:23 UTC
*** Bug 966683 has been marked as a duplicate of this bug. ***

Comment 13 Dennis Gregorovic 2013-10-09 17:12:29 UTC
Fixed in latest product-certs.json
http://git.app.eng.bos.redhat.com/rcm/rcm-metadata.git/commit/?id=50dbc293f9669b0ec08cc9b80f3bf2681f11accc

Comment 15 John Sefler 2014-02-19 22:49:00 UTC
This bug is applicable to RHEL6, not RHEL7.  Re-assigning back to RHEL6.

Comment 18 Shwetha Kallesh 2014-07-03 15:35:38 UTC
[root@dhcp-0-177 ~]# rpm -qa | grep subscription-manager-migration-data
subscription-manager-migration-data-2.0.8-1.el6.noarch

[root@dhcp-0-177 ~]# rpm -ql subscription-manager-migration-data | grep 180.pem
/usr/share/rhsm/product/RHEL-6/RHB-i386-ce28032e05c7-180.pem
/usr/share/rhsm/product/RHEL-6/RHB-x86_64-99c22e1e646f-180.pem


[root@dhcp-0-177 ~]# rpm -ql subscription-manager-migration-data | grep 179.pem
/usr/share/rhsm/product/RHEL-6/Workstation-DTS-i386-91d4a6310e23-179.pem
/usr/share/rhsm/product/RHEL-6/Workstation-DTS-i386-f9fb9e8046b8-179.pem
/usr/share/rhsm/product/RHEL-6/Workstation-DTS-x86_64-0fccafa83f56-179.pem
/usr/share/rhsm/product/RHEL-6/Workstation-DTS-x86_64-b25cf7e5dba3-179.pem



[root@dhcp-0-177 ~]# rpm -ql subscription-manager-migration-data | grep 176.pem
/usr/share/rhsm/product/RHEL-6/Server-DTS-i386-4d6c7dd01366-176.pem
/usr/share/rhsm/product/RHEL-6/Server-DTS-i386-92bc1559583c-176.pem
/usr/share/rhsm/product/RHEL-6/Server-DTS-x86_64-0477094217bc-176.pem
/usr/share/rhsm/product/RHEL-6/Server-DTS-x86_64-d477154f5143-176.pem

[root@dhcp-0-177 ~]# rpm -ql subscription-manager-migration-data | grep 178.pem
[root@dhcp-0-177 ~]# rpm -ql subscription-manager-migration-data | grep 177.pem

Product cert 177.pem and 178.pem are still missing

Comment 19 errata-xmlrpc 2014-10-14 07:45:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.