Bug 852626 - aeolus-upgrade on f16 fails with err "Invalid HTTP Return Code: 500,was expecting one of 200"
aeolus-upgrade on f16 fails with err "Invalid HTTP Return Code: 500,was expec...
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Steve Linabery
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 03:21 EDT by Aziza Karol
Modified: 2012-12-12 10:15 EST (History)
4 users (show)

See Also:
Fixed In Version: aeolus-configure-2.8.8-1.el6cf
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 10:15:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade log (11.35 KB, application/octet-stream)
2012-08-29 03:22 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-08-29 03:21:27 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.On fresh f16 test machine do yum install aeolus-all.The below aeolus-version will be installed.
#rpm -qa | grep aeolus
aeolus-conductor-doc-0.10.6-1.fc16.noarch
aeolus-all-0.10.6-1.fc16.noarch
rubygem-aeolus-image-0.5.0-1.fc16.noarch
rubygem-aeolus-cli-0.5.0-1.fc16.noarch
aeolus-configure-2.6.1-1.fc16.noarch
aeolus-conductor-0.10.6-1.fc16.noarch
aeolus-conductor-daemons-0.10.6-1.fc16.noarch
2.aeolus-configure -p ec2,mock
3.copy aeolus and katello repos in yum dir
4.yum update
following aeolus version got installed.
rpm -qa | grep aeolus
aeolus-all-0.13.0-0.20120829030015git38176e2.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120828230036git4bffe3f.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120829030015git38176e2.fc16.noarch
aeolus-configure-2.8.0-0.20120828230031gitbdcd549.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120829030015git38176e2.fc16.noarch
aeolus-conductor-0.13.0-0.20120829030015git38176e2.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120828230033gitd64d64f.fc16.noarch

5. ./aeolus-upgrade -a
Service 'mongod' can not be running while aeolus-upgrade is in progress
Service 'iwhd' can not be running while aeolus-upgrade is in progress
Service 'postgresql' can not be running while aeolus-upgrade is in progress
Service 'httpd' can not be running while aeolus-upgrade is in progress
Service 'deltacloud-core' can not be running while aeolus-upgrade is in progress
Service 'libvirtd' can not be running while aeolus-upgrade is in progress
Service 'aeolus-conductor' can not be running while aeolus-upgrade is in progress
Service 'conductor-dbomatic' can not be running while aeolus-upgrade is in progress
Service 'imagefactory' can not be running while aeolus-upgrade is in progress
Service 'ntpd' can not be running while aeolus-upgrade is in progress
================================================================================
We will stop all aeolus services using aeolus-services stop.
PROCEED? (y/n): y
Redirecting to /bin/systemctl stop  aeolus-services.service
================================================================================
 Aeolus-conductor upgrade
================================================================================

1/3: Migrate aeolus-conductor rails database (0001_migrate_conductor_db.sh)
 Executes rake db:migrate for the aeolus-conductor database

Do you want to proceed? (y/n): y

Migrate aeolus-conductor rails database OK.

================================================================================

2/3: Execute aeolus-configure (0002_run_aeolus-configure.sh)
 Executes aeolus-configure. Note: this restarts aeolus services. Skip this step if you want to manually run aeolus-configure later.

Do you want to proceed? (y/n): y

Execute aeolus-configure FAILED.

================================================================================
Finished 1 of 3 upgrade steps

  

Actual results:
second upgrade steps fails with 
err: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Login[temporary-administrative-user-9969f21b29a6ae590413eabebf9ea7de62341bacbbb3145f]/Web_request[temporary-administrative-user-9969f21b29a6ae590413eabebf9ea7de62341bacbbb3145f-conductor-login]/post: change from  to https://localhost/conductor/user_session failed: An exception was raised when invoking web request: Invalid HTTP Return Code: 500,was expecting one of 200  in aeolus_upgrade.log

attaching full upgrade log.

Expected results:
upgrade should be successful

Additional info:
Comment 1 Aziza Karol 2012-08-29 03:22:10 EDT
Created attachment 607789 [details]
upgrade log
Comment 2 Steve Linabery 2012-09-04 17:53:18 EDT
this might be beside the point, but should you really be running aeolus services during yum update? I don't think we support that, i.e. all testing I've done to date presumes aeolus services stopped before yum update of aeolus-* packages.
Comment 3 Steve Linabery 2012-09-04 18:01:03 EDT
I think this might be due to the broken aeolus-upgrade script which attempts to use '/bin/systemctl stop  aeolus-services.service' to stop running aeolus (and related) services.

On f16, it silently fails. On RHEL, it complains 'unrecognized service', see https://bugzilla.redhat.com/show_bug.cgi?id=852866

I was unable to replicate the above failure, but I had stopped the running services by invoking 'aeolus-services stop'.

I suspect (but have yet to confirm) that the second step of the upgrade is failing because the upgrade is being done with running services. Working on replicating the error by following your exact steps above.
Comment 4 Steve Linabery 2012-09-06 10:21:45 EDT
With the fix to aeolus-upgrade on master as 4ccb08ead9eabb46b3a41cd2c1d9656f5ad010ad I am no longer able to replicate this bug. I believe this bug was caused by services running during aeolus-upgrade because the autostop silently failed. Please advise.
Comment 5 Giulio Fidente 2012-10-03 09:19:01 EDT
as per Dave's suggestion, this is not happening on RHEL using aeolus-configure-2.8.8-1.el6cf so I'm moving the bug to VERIFIED state.

if the problem is still happening on Fedora, it should be reported against the Fedora component aeolus-configure, not the Cloud Engine product from Red Hat
Comment 6 James Laska 2012-12-12 10:15:44 EST
CloudForms-1.1 shipped with aeolus-conductor-0.13.24-1.el6cf, aeolus-configure- 2.8.11-1.el6cf, imagefactory-1.0.2-1.el6cf, iwhd-1.5-2.el6, and oz-0.8.0-6.el6cf

Marking this bug CLOSED CURRENTRELEASE.  Please reopen if the problem has not   been addressed in the 1.1 product.  As pointed out in comment#5, if the problem remains for Fedora, please file a new bug against aeolus in Fedora.

Note You need to log in before you can comment on or make changes to this bug.