Bug 852698 - build error: <jemalloc>Compile-time page size does not divide the runtime one.
build error: <jemalloc>Compile-time page size does not divide the runtime one.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
18
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alphappc
  Show dependency treegraph
 
Reported: 2012-08-29 06:55 EDT by Karsten Hopp
Modified: 2012-09-10 11:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 11:15:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (121.54 KB, text/plain)
2012-08-29 06:55 EDT, Karsten Hopp
no flags Details
build.log (11.20 MB, text/plain)
2012-08-29 07:01 EDT, Karsten Hopp
no flags Details
Disable JEMALLOC_STATIC_SIZES on powerpc (568 bytes, patch)
2012-09-06 10:24 EDT, Gustavo Luiz Duarte
no flags Details | Diff
Do not decommit memory on PPC (568 bytes, patch)
2012-09-06 10:31 EDT, Gustavo Luiz Duarte
no flags Details | Diff
Disable JEMALLOC_STATIC_SIZES on powerpc (516 bytes, patch)
2012-09-06 12:11 EDT, Gustavo Luiz Duarte
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2012-08-29 06:55:37 EDT
Created attachment 607863 [details]
root.log

Description of problem:
The build of thunderbird-15.0-1.fc18 aborts on PPC:

  adding: hyphenation/hyph_la.dic (deflated 59%)
  adding: hyphenation/hyph_is.dic (deflated 50%)
<jemalloc>Compile-time page size does not divide the runtime one.
Redirecting call to abort() to mozalloc_abort
/bin/sh: line 1: 20611 Segmentation fault      (core dumped) /builddir/build/BUILD/thunderbird-15.0/comm-release/objdir/mail/installer/../../mozilla/dist/bin/run-mozilla.sh /builddir/build/BUILD/thunderbird-15.0/comm-release/objdir/mozilla/dist/bin/xpcshell -g "$PWD" -a "$PWD" -f /builddir/build/BUILD/thunderbird-15.0/comm-release/mozilla/toolkit/mozapps/installer/precompile_cache.js -e "populate_startupcache('GreD', 'omni.ja', 'startupCache.zip');"
make[1]: Leaving directory `/builddir/build/BUILD/thunderbird-15.0/comm-release/objdir/mail/installer'
make[1]: *** [install] Error 139
make: *** [install] Error 2

Version-Release number of selected component (if applicable):
thunderbird-15.0-1.fc18

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f18 thunderbird-15.0-1.fc18.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=688068
Comment 1 Karsten Hopp 2012-08-29 07:01:31 EDT
Created attachment 607865 [details]
build.log
Comment 2 Gustavo Luiz Duarte 2012-09-06 10:24:43 EDT
Created attachment 610347 [details]
Disable JEMALLOC_STATIC_SIZES on powerpc

Disables the use of JEMALLOC_STATIC_SIZES on powerpc since it assumes 4k page size. JEMALLOC_STATIC_SIZES was introduced after landing of: https://bugzilla.mozilla.org/show_bug.cgi?id=571209
Comment 3 Gustavo Luiz Duarte 2012-09-06 10:31:04 EDT
Created attachment 610354 [details]
Do not decommit memory on PPC

Do not decommit memory on PPC since decommit logic assumes PageSize == ArenaSize. On PPC we have 64K page size, which is not feasible for ArenaSize. Rework of Martin's patch from https://bugzilla.mozilla.org/show_bug.cgi?id=746112
Comment 4 Gustavo Luiz Duarte 2012-09-06 10:36:24 EDT
I've attached 2 patches. The first one is from bug 814879 and fixes the jemalloc build issue. The second patch fixes thunderbird freezes. I've reworked them from xulrunner to apply on thunderbird.
Comment 5 Gustavo Luiz Duarte 2012-09-06 12:11:59 EDT
Created attachment 610408 [details]
Disable JEMALLOC_STATIC_SIZES on powerpc

Sorry, I had uploaded the wrong patch before. Fixing it.
Comment 6 Jan Horak 2012-09-10 10:03:50 EDT
Thanks for patches, they've been added to latest trunk. We should get rid of this workaround later. How did ppc test builds end?
Comment 7 Gustavo Luiz Duarte 2012-09-10 11:15:24 EDT
Thanks Jan, closing this one since thunderbird-15.0-2.fc18 builds and launches fine on ppc.

Note You need to log in before you can comment on or make changes to this bug.