Bug 852709 - DOC: 9.1. Static Proxy Configuration and EAP5
DOC: 9.1. Static Proxy Configuration and EAP5
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 07:10 EDT by Michal Karm Babacek
Modified: 2012-11-08 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:10:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Karm Babacek 2012-08-29 07:10:16 EDT
9.1. Static Proxy Configuration
There is Tomcat and EAP5 configuration, whereas above there are many chapters about EAP6 subsystems...this is totally confusing.
Let alone there is no EAP5 in EWS2, only Tomcats.
Comment 2 Jean-frederic Clere 2012-08-30 03:42:02 EDT
EAP6 part should be there that is the case we EWS as front-end for EAP6.
Of course the doc is wrong as it is EAP5.
Comment 3 Jean-frederic Clere 2012-08-30 04:37:16 EDT
The part "Task: Configure Application Platform Worker Node with Static Proxy List"
needs the following changes:
+++
1 Disable dynamic proxy discovery:
Edit standalone/configuration/standalone-ha.xml and set the advertise property to false:

 <mod-cluster-config advertise='false" connector="ajp">


2 - Choose, and implement, one of the following static proxy options:

    Option 1: Create a static proxy server list:
     <mod-cluster-config advertise='false" connector="ajp" proxy-list="10.33.144.3:6666,10.33.144.1:6666">
    Option 2: Start the worker node with a static proxy list as a parameter
    mod-cluster-config advertise='false" connector="ajp" proxy-list="${jboss.modcluster.proxyList:}"
    Add a comma separated list of proxies in the form of IP_ADDRESS:PORT as the jboss.modcluster.proxyList parameter when starting the node.
Example 8.2. Example Static Proxy List Parameter

-Djboss.modcluster.proxyList=10.33.144.3:6666,10.33.144.1:6666
+++

The rest is OK.
Comment 4 Misha H. Ali 2012-09-02 06:32:02 EDT
Added information as listed. Replaces previous step 2("Define a mod_cluster listener") with the new static proxy configuration step. If this is incorrect, please let me know.
Comment 6 Jean-frederic Clere 2012-09-03 04:08:29 EDT
It is still wrong :-(
You changed the wrong part I said "The part "Task: Configure Application Platform Worker Node with Static Proxy List" needs the following changes:"
But you applied it to the Task: Configure Web Server Worker Node with Static Proxy List which was OK.

We need to replace the EAP5 explaination by EAP6 the Web Server part should have remain unchanged,
Comment 7 Misha H. Ali 2012-09-20 18:47:00 EDT
Reverted to remove incorrect changes. Will make the correct modifications and set this back ON_QA with a link to verify.
Comment 9 Jean-frederic Clere 2012-09-21 02:47:18 EDT
No hm I commented the following on 852705:
But the chap8 is still not ok: JBOSS_EAP_DIST/jboss-as/server/PROFILE/mod-cluster.sar/META-INF/mod-cluster-jboss-beans.xml is wrong. in EAP6 there is only one file to configure the whole thing standalone/configuration/standalone-ha.xml. Note that the <mod-cluster-config/> are all OK except the first one:
<mod-cluster-config advertise='false" connector="ajp">
because it needs a proxy-list=something which you describe later in the doc.

chap8 in fact it is in 8.1 which needs changes.
Comment 10 Jean-frederic Clere 2012-09-25 03:07:39 EDT
still not fixed (25/10/2012).
Comment 11 Misha H. Ali 2012-10-02 00:23:40 EDT
The following changes are now done to 8.1:

1. File location changed to "standalone/configuration/standalone-ha.xml"

2. Added a "proxy-list={placeholder}" entry to the <mod-cluster-config> sample.

This bug will be set to ON_QA with a link when the above changes appear on the stage.
Comment 13 Jean-frederic Clere 2012-10-02 02:23:16 EDT
There is still a mod-cluster-jboss-beans.xml in the page. That is not OK.
Comment 14 Misha H. Ali 2012-10-02 03:15:59 EDT
Apologies, fixed the remaining incorrect path. This bug will be updated when the new version appears on the stage.
Comment 16 Jean-frederic Clere 2012-10-03 04:08:37 EDT
Looks Ok now.
Comment 17 Radim Hatlapatka 2012-10-11 09:28:56 EDT
looks ok. Configuration for tomcat is wrong but it is in separate bug: https://bugzilla.redhat.com/show_bug.cgi?id=865450
Comment 18 Misha H. Ali 2012-11-08 17:10:36 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.