This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 852717 - libvirtd fails to start, libnl3 abort
libvirtd fails to start, libnl3 abort
Status: CLOSED DUPLICATE of bug 852549
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 07:42 EDT by Alon Levy
Modified: 2014-08-04 18:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 11:02:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alon Levy 2012-08-29 07:42:43 EDT
Description of problem:
x86_64 garlic:qemu root# libvirtd
BUG: route/tc.c:970
libvirtd: route/tc.c:970: rtnl_tc_register: Assertion `0' failed.
Caught abort signal dumping internal log buffer:


Version-Release number of selected component (if applicable):
libvirt-daemon-0.10.0-0rc0.2.fc18.x86_64

How reproducible:
always. With both libnl3-3.2.7-2.fc18.x86_64 and a locally build from latest libnl3 libnl3-3.2.11-1.fc19.x86_64 (fc19 is meaningless, just forgot to checkout fc18 branch before changing sources to 3.2.11)

Steps to Reproduce:
1. run libvirtd
  
Actual results:
BUG: route/tc.c:970
libvirtd: route/tc.c:970: rtnl_tc_register: Assertion `0' failed.
Caught abort signal dumping internal log buffer:

Expected results:
start normally.

Additional info:
couldn't figure out anything from the backtrace, here it is:

#3  0x000000383d62ea22 in __GI___assert_fail (assertion=0x7fffe9cd86ac "0", file=0x7fffe9cd7ee0 "route/tc.c", line=970, function=0x7fffe9cd7fc0 "rtnl_tc_register") at assert.c:101
#4  0x00007fffe9cc5e4d in rtnl_tc_register () from /lib64/libnl-route-3.so.200
#5  0x000000383ce0ef36 in call_init (l=l@entry=0x676e10, argc=argc@entry=1, argv=argv@entry=0x7fffffffddc8, env=env@entry=0x7fffffffddd8) at dl-init.c:82
#6  0x000000383ce0eff0 in call_init (env=<optimized out>, argv=<optimized out>, argc=<optimized out>, l=0x676e10) at dl-init.c:53
#7  _dl_init (main_map=main_map@entry=0x6756b0, argc=1, argv=0x7fffffffddc8, env=0x7fffffffddd8) at dl-init.c:131
#8  0x000000383ce1336d in dl_open_worker (a=a@entry=0x7fffffffd430) at dl-open.c:563
#9  0x000000383ce0edc6 in _dl_catch_error (objname=objname@entry=0x7fffffffd420, errstring=errstring@entry=0x7fffffffd428, mallocedp=mallocedp@entry=0x7fffffffd410, operate=operate@entry=0x383ce12fb0 <dl_open_wo
rker>, args=args@entry=0x7fffffffd430) at dl-error.c:177
#10 0x000000383ce12c0c in _dl_open (file=0x675660 "/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so", mode=-2147483390, caller_dlopen=<optimized out>, nsid=-2, argc=1, argv=0x7fffffffddc8, env=0x
7fffffffddd8) at dl-open.c:653
#11 0x000000383e201026 in dlopen_doit (a=a@entry=0x7fffffffd640) at dlopen.c:66
#12 0x000000383ce0edc6 in _dl_catch_error (objname=0x6633b0, errstring=0x6633b8, mallocedp=0x6633a8, operate=0x383e200fc0 <dlopen_doit>, args=0x7fffffffd640) at dl-error.c:177
#13 0x000000383e20163c in _dlerror_run (operate=operate@entry=0x383e200fc0 <dlopen_doit>, args=args@entry=0x7fffffffd640) at dlerror.c:163
#14 0x000000383e2010c1 in __dlopen (file=<optimized out>, mode=<optimized out>) at dlopen.c:87
#15 0x00007ffff79b9511 in virDriverLoadModule () from /lib64/libvirt.so.0
#16 0x000000000040ba9e in main ()
Comment 1 Alon Levy 2012-08-29 07:45:46 EDT
oops, should have been f18, fixing.
Comment 2 Eric Blake 2012-08-29 11:02:58 EDT

*** This bug has been marked as a duplicate of bug 852549 ***

Note You need to log in before you can comment on or make changes to this bug.