Bug 852741 - bringing a down network up does not result in self-heal-daemons' crawling
bringing a down network up does not result in self-heal-daemons' crawling
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Pranith Kumar K
: Triaged
Depends On:
Blocks: 853676 858493
  Show dependency treegraph
 
Reported: 2012-08-29 09:17 EDT by Raghavendra Bhat
Modified: 2013-07-24 13:34 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 853676 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:34:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-08-29 09:17:46 EDT
Description of problem:
2 replica volume. Each brick running on different peers. Now bring the network of one of the peers down (say peer1). Create some files on the mount point. Bring peer1's network up. Now peer1's glustershd thinks that peer2's brick came up and hence does not initiate a crawl since its not local brick. In the sameway from peer2's point of view peer1's brick came up which his remote. Hence it also does not initiate the crawl, thus self-heal not being triggered even though connection has been established. For self-heal to happen one has to wait till the glustershd starts crawling for every 10 minutes.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. create a 2 replica volume, start it and then mount it.
2. Bring the network of one of the peers down
3. Create some files on the mount point
4. bring the network up
  
Actual results:
self-heal does not happen when there is connection establishment with the brick after a down network is brought up.

Expected results:
glustershd should crawl whenever there is a connection establishment with a brick which is part of the replica set it also belongs to.

Additional info:
Comment 1 Jeff Darcy 2012-10-31 16:54:48 EDT
I was sure I remembered a commit for this, and I found it.

http://review.gluster.org/3972

Moving to MODIFIED accordingly.

Note You need to log in before you can comment on or make changes to this bug.