Bug 852819 - Possibility of GlusterFS port clashes with reserved ports
Possibility of GlusterFS port clashes with reserved ports
Status: CLOSED DUPLICATE of bug 868715
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
All Linux
high Severity low
: ---
: ---
Assigned To: Amar Tumballi
Sudhir D
: FutureFeature
Depends On: GLUSTER-1257
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 12:40 EDT by Vidya Sakar
Modified: 2013-12-18 19:08 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: GLUSTER-1257
Environment:
Last Closed: 2012-10-21 22:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-29 12:40:44 EDT
+++ This bug was initially created as a clone of Bug #762989 +++

If the number of servers increase then there is a chance of GlusterFS port clashing with reserved ports.

For example if the servers increase more than 28 a pop3 over ssl daemon,
which uses 995 port, cannot start after GlusterFS client.

--- Additional comment from amarts@redhat.com on 2011-04-25 05:33:21 EDT ---

Please update the status of this bug as its been more than 6months since its filed (bug id < 2000)

Please resolve it with proper resolution if its not valid anymore. If its still valid and not critical, move it to 'enhancement' severity.

--- Additional comment from amarts@redhat.com on 2011-09-27 01:50:11 EDT ---

Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.

--- Additional comment from sac@redhat.com on 2011-11-21 10:22:21 EST ---

Don't know if I can close this. Reported by Keisuke Takahashi... have to test this though.

--- Additional comment from amarts@redhat.com on 2012-03-25 05:11:14 EDT ---

*** Bug 806504 has been marked as a duplicate of this bug. ***

--- Additional comment from amarts@redhat.com on 2012-03-25 05:12:28 EDT ---

*** Bug 765228 has been marked as a duplicate of this bug. ***

--- Additional comment from rodrigo@fabricadeideias.com on 2012-06-04 11:33:04 EDT ---

Paraphasing David Coulson at Gluster Users mailing list:

Why does not use ports within the /proc/sys/net/ipv4/ip_local_port_range?

--- Additional comment from botsch@cnf.cornell.edu on 2012-07-11 15:44:50 EDT ---

With two servers, glusterfs (v3.3) started up listening on port 993, which kept dovecot from starting. Not good. Please fix.
Comment 2 Amar Tumballi 2012-10-11 14:50:44 EDT
Need some better security measures before fixing this behavior. As of now, port < 1024 is the only main secure way of telling 'root' is mounting the client.
Comment 3 Amar Tumballi 2012-10-21 22:38:55 EDT

*** This bug has been marked as a duplicate of bug 868715 ***

Note You need to log in before you can comment on or make changes to this bug.