Bug 852842 - ibmveth 30000003: eth0: h_register_logical_lan failed with -4
ibmveth 30000003: eth0: h_register_logical_lan failed with -4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
ppc64 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 850883 (view as bug list)
Depends On:
Blocks: F18Alphappc
  Show dependency treegraph
 
Reported: 2012-08-29 14:22 EDT by Mark Hamzy
Modified: 2012-09-23 01:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 01:03:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (2.03 KB, patch)
2012-08-29 14:22 EDT, Mark Hamzy
no flags Details | Diff
Patch submitted to netdev (2.79 KB, patch)
2012-09-04 22:38 EDT, Santiago Leon
no flags Details | Diff

  None (edit)
Description Mark Hamzy 2012-08-29 14:22:53 EDT
Created attachment 607974 [details]
Proposed patch

Running kernel-3.6.0-0.rc1.git6.1.fc18.ppc64 on the latest Fedora 18 alpha build located at http://ppc.koji.fedoraproject.org/stage/f18-20120823.1/ppc64/iso/Fedora-18-ppc64-DVD.iso

I see the following kernel message:

dracut-initqueue[621]: RTNETLINK answers: File exists
[   28.431598] ibmveth 30000003: eth0: h_register_logical_lan failed with -4
[   28.431616] ibmveth 30000003: eth0: buffer TCE:0x1000 filter TCE:0x10000 rxq desc:0x80006010000200a8 MAC:0x2a0f41b73f03
dracut-initqueue[621]: RTNETLINK answers: Machine is not on the network
dracut-initqueue[621]: RTNETLINK answers: Network is unreachable

Nish did some analysis at http://lkml.indiana.edu/hypermail/linux/kernel/1205.1/04509.html

There is a patch attached to this bugzilla.
Comment 1 Mark Hamzy 2012-08-29 14:26:19 EDT
I've tested this patch and it works.
Comment 2 Mark Hamzy 2012-08-29 14:30:11 EDT
*** Bug 850883 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2012-08-30 11:03:57 EDT
(In reply to comment #1)
> I've tested this patch and it works.

Where did it come from?  I don't see it posted to netdev or lkml at all, and it's missing a Signed-of-by, etc.
Comment 4 Josh Boyer 2012-08-30 11:08:30 EDT
(In reply to comment #3)
> (In reply to comment #1)
> > I've tested this patch and it works.
> 
> Where did it come from?  I don't see it posted to netdev or lkml at all, and
> it's missing a Signed-of-by, etc.

Oh, and as a general reminder, f18/rawhide is still using the 3.6-rcX kernels, so if the fix gets upstream we'll pick it up automatically.  I don't mind carrying it as a patch for a brief amount of time, but it really needs to be posted upstream.  When that's done, just throw a link to it here and I'll add it.
Comment 5 Brent Baude 2012-08-30 11:21:00 EDT
hey Josh, I will get Santi to update information here.
Comment 6 Santiago Leon 2012-08-31 15:31:55 EDT
I wrote this patch and I am the maintainer of the ibmveth driver.  I don't have a commit yet, but i will push it soon to mainline and to -stable.
Comment 7 Santiago Leon 2012-09-04 22:38:45 EDT
Created attachment 609839 [details]
Patch submitted to netdev

Here's the netdev submission: http://marc.info/?l=linux-netdev&m=134680776000744
Comment 8 Josh Boyer 2012-09-05 08:19:42 EDT
(In reply to comment #7)
> Created attachment 609839 [details]
> Patch submitted to netdev
> 
> Here's the netdev submission:
> http://marc.info/?l=linux-netdev&m=134680776000744

Thanks.
Comment 9 Josh Boyer 2012-09-05 08:25:18 EDT
Committed to Fedora git.
Comment 10 Fedora Update System 2012-09-07 20:53:13 EDT
kernel-3.6.0-0.rc4.git2.1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.0-0.rc4.git2.1.fc18
Comment 11 Fedora Update System 2012-09-08 15:25:01 EDT
Package kernel-3.6.0-0.rc4.git2.1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.0-0.rc4.git2.1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13608/kernel-3.6.0-0.rc4.git2.1.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-09-17 15:28:30 EDT
kernel-3.6.0-0.rc6.git0.2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.0-0.rc6.git0.2.fc18
Comment 13 Fedora Update System 2012-09-23 01:03:51 EDT
kernel-3.6.0-0.rc6.git0.2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.