This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 850883 - updates= does not work
updates= does not work
Status: CLOSED DUPLICATE of bug 852842
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
18
ppc64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alphappc
  Show dependency treegraph
 
Reported: 2012-08-22 11:58 EDT by Mark Hamzy
Modified: 2012-08-29 14:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 14:30:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rd.debug log file (1.44 MB, text/plain)
2012-08-22 12:01 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2012-08-22 11:58:13 EDT
Description of problem:

Booting with the following command line:

linux vnc ip=9.5.250.145::9.5.250.1:255.255.255.0:sharpie.rchland.ibm.com:eth0:none ip=9.5.252.203::9.5.252.1:255.255.255.0::eth1:none nameserver=9.10.244.100 bootdev=eth0 live.updates=http://chukar.rchland.ibm.com/updates-newui.img rd.debug

I am manually configuring both ethernet cards and trying to download an updates image.  Unfortunately, it fails with:
dracut-initqueue[630]: Warning: Could not boot.

Version-Release number of selected component (if applicable):
dracut-023-2.fc18.ppc64.rpm
kernel-3.6.0-0.rc1.git6.1.fc18.ppc64.rpm
systemd-188-3.fc18.ppc64.rpm

The log file is at http://hamzy.fedorapeople.org/F18-boot-08222012-1.log
Comment 1 Mark Hamzy 2012-08-22 12:01:15 EDT
Created attachment 606317 [details]
rd.debug log file
Comment 2 Harald Hoyer 2012-08-23 03:23:14 EDT
might be related to bug 849672 which should be resolved now
Comment 3 Mark Hamzy 2012-08-23 17:12:11 EDT
This is not fixed by anaconda-18.6.1-1 and dracut-023-20.git20120823.fc18 using the Fedora 18 ppc iso located at http://ppc.koji.fedoraproject.org/stage/f18-20120823.1/ppc64/iso/Fedora-18-ppc64-DVD.iso .
Comment 4 Mark Hamzy 2012-08-27 10:26:33 EDT
boot: linux vnc ip=9.5.250.145::9.5.250.1:255.255.255.0:sharpie.rchland.ibm.com:eth0:none nameserver=9.10.244.100 bootdev=eth0 live.updates=http://9.5.250.185/updates-newui.img
...
Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.

dracut:/# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 2a:0f:41:b7:3f:03 brd ff:ff:ff:ff:ff:ff
    inet 9.5.250.145/24 brd 9.5.250.255 scope global eth0
dracut:/# ip link set dev eth0 up
[  322.252489] ibmveth 30000003: eth0: h_register_logical_lan failed with -4
[  322.252504] ibmveth 30000003: eth0: buffer TCE:0x30000 filter TCE:0x40000 rxq desc:0x80006010000503d8 MAC:0x2a0f41b73f03
RTNETLINK answers: Machine is not on the network
Comment 5 Mark Hamzy 2012-08-29 14:30:11 EDT
This is fixed by a kernel patch found in 850883

*** This bug has been marked as a duplicate of bug 852842 ***

Note You need to log in before you can comment on or make changes to this bug.