Bug 852845 - (lightdm.preset) ship systemd preset for lightdm
ship systemd preset for lightdm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedNTH
: Reopened
: 857277 (view as bug list)
Depends On:
Blocks: F18Alpha-accepted/F18AlphaFreezeExcept 850775
  Show dependency treegraph
 
Reported: 2012-08-29 14:35 EDT by Rex Dieter
Modified: 2012-09-17 20:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 20:46:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-08-29 14:35:53 EDT
$Summary says it all: ship systemd preset for lightdm
Comment 1 Fedora Update System 2012-08-30 10:35:16 EDT
lightdm-1.3.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lightdm-1.3.3-1.fc18
Comment 2 Fedora Update System 2012-08-30 14:19:56 EDT
Package lightdm-1.3.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.3.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13001/lightdm-1.3.3-1.fc18
then log in and leave karma (feedback).
Comment 3 Tim Flink 2012-08-31 12:33:18 EDT
Proposing as NTH for Fedora 18 alpha due to violation of the following F18 alpha release criterion [1] for a non-primary DE:

Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention.

[1] http://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria
Comment 4 Adam Williamson 2012-09-05 14:24:27 EDT
Discussed at 2012-09-05 NTH review meeting. Accepted as NTH per rationale in comment #3.
Comment 5 Fedora Update System 2012-09-07 19:19:38 EDT
lightdm-1.3.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jens Petersen 2012-09-13 22:19:23 EDT
*** Bug 857277 has been marked as a duplicate of this bug. ***
Comment 7 Jens Petersen 2012-09-13 22:25:59 EDT
* Tue Sep 04 2012 Rex Dieter <rdieter@fedoraproject.org> 1.3.3-2
- lightdm.service: After=+livesys-late.service (#853985)

It is not working for me I am afraid, except for XFCE Live,
so I am reopening.  I think as Lennart said in bug 850775,
the preset should not be relative to livesys-late.
Comment 8 Adam Williamson 2012-09-17 20:46:52 EDT
As I wrote in the LXDM bug, both of those are separate issues. The yum case is different and may be intended, and we need to keep the livesys-late dep in the DM package because livesys-late is not a native systemd service, see https://bugzilla.redhat.com/show_bug.cgi?id=846384 . Re-closing.

Note You need to log in before you can comment on or make changes to this bug.