Bug 852875 - firstboot's service file needs updating for replacement of prefdm.service with per-dm services and systemd presets
firstboot's service file needs updating for replacement of prefdm.service wit...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 853048 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-29 16:08 EDT by Adam Williamson
Modified: 2012-09-07 19:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 19:18:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-08-29 16:08:18 EDT
So we have this whole mess going on where prefdm.service has been replaced with a service file for each DM, a display-manager.service alias, and these new systemd 'presets'.

I don't claim to totally understand what's going on, but I know for sure we need to change this line in firstboot-graphical.service:

Before=prefdm.service getty@tty1.service

somehow. I am not sure if just:

Before=display-manager.service getty@tty1.service

would work (as every *dm.service file is supposed to have Alias=display-manager.service), or if we'd need to do something bigger:

Before=display-manager.service gdm.service kdm.service lxdm.service lightdm.service (etc etc etc)

as I don't know how systemd handles Before/After when it comes to aliases, and the manpage doesn't seem to explain it.

CCing Lennart for info on this.

Marking as an Alpha blocker, because the consequence of this is that firstboot and gdm try to run at the same time on the first boot after install, which is an infringement of "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account".
Comment 1 Jaroslav Reznik 2012-08-30 16:52:46 EDT
CCing vpodzime as msivak is on vacation by the end of August.
Comment 2 Jan Sedlák 2012-08-31 03:17:32 EDT
*** Bug 853048 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2012-08-31 18:53:36 EDT
Well, in a quick test just 'Before=display-manager.service' seemed to be enough - I tested by hacking that into firstboot-graphical.service, enabling firstboot, and booting, on a freshly-installed system. firstboot ran and I was able to complete it, gdm didn't pop up over the top.
Comment 4 Fedora Update System 2012-08-31 20:40:57 EDT
firstboot-18.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firstboot-18.2-2.fc18
Comment 5 Fedora Update System 2012-09-01 12:57:45 EDT
Package firstboot-18.2-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-18.2-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13118/firstboot-18.2-2.fc18
then log in and leave karma (feedback).
Comment 6 Adam Williamson 2012-09-05 12:35:55 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion "In most cases, a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. The firstboot utility must be able to create a working user account".
Comment 7 Adam Williamson 2012-09-06 18:13:13 EDT
Two people reported it works in the Bodhi feedback, so setting VERIFIED.
Comment 8 Fedora Update System 2012-09-07 19:18:54 EDT
firstboot-18.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.