Bug 852960 - SSD luks ext4 filesystem corruption after resume from suspend
SSD luks ext4 filesystem corruption after resume from suspend
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 01:52 EDT by Bingo
Modified: 2013-07-31 20:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 20:10:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesgOut, fstab and smoltProfile (6.17 KB, application/x-compressed-tar)
2012-08-30 01:52 EDT, Bingo
no flags Details

  None (edit)
Description Bingo 2012-08-30 01:52:58 EDT
Created attachment 608049 [details]
dmesgOut, fstab and smoltProfile

Description of problem:
Freshly installed Fedora 17 x86_64. Updated to latest packages as of August 29, 2012. Kernel version 3.5.2-3.fc17.

After resume from suspend (not hibernate), I see the filesystem mounted read-only. Output of dmesg attached. Smolt profile attached. Fstab attached.

Tried workaround of kernel parameter i915.modeset=0 as suggested in bug 770443, but that hangs the boot i.e. screen goes black/blank, hard-disk activity LED stops responding. This is before even asking for the luks key to open the / partition.

Opening a fresh bug because previous bugs all point to resume from hibernate, and to dracut. This is resume from suspend, and I think dracut doesn't participate in that(may be wrong).

Version-Release number of selected component (if applicable):
3.5.2-3.fc17

How reproducible:
Every time (tried thrice, happened every time)

Steps to Reproduce:
1. Install Fedora 17 x86_64. My / partition is a luks encrypted ext4 partition on an SSD, but not sure if SSD is necessary.
2. Update to latest packages as of Aug 29, 2012, bringing kernel version to 3.5.2-3.fc17
3. Suspend (gnome top-right corner, click on username, click on "suspend" menu entry)
4. Resume from suspend 
5. Try writing any file on / filesystem

Actual results:
File write successful

Expected results:
/ partition found mounted read-only citing file system corruption. Dmesg output attached.

Additional info: Fixed filesystem corruption using fsck -y on another Fedora installation. Retried twice more, reproduced every time.

Related bugs : 822071 and 770443 . Not exactly the same issue.
Comment 1 Bingo 2012-08-30 01:54:32 EDT
Mount option "discard" was used for the / partition, as can be seen from fstab
Comment 2 Bingo 2012-08-31 00:47:18 EDT
Sorry I interchanged "Actual results" and "Expected results" above
Comment 3 Joost Ruijsch 2012-11-10 09:30:52 EST
There are know problems with Sandforce based SSD's on intel ICH sata controllers when resuming from standby. 

I had the same problem using an OCZ Vertex2 on windows and ICH7. When resuming from standby, the SSD did not respond.

The problem disappeared after I upgraded to a Samsung 830 SSD. I did a full binary copy from the old to the new disk, so it must have been a hardware problem.

You may try upgrading your SSD firmware, but that did not work for me. OCZ never released a proper fix.
Comment 4 Fedora End Of Life 2013-07-03 18:21:10 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2013-07-31 20:10:58 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.