Bug 853238 - Yum tries to size check the DVD when getting a local file
Yum tries to size check the DVD when getting a local file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 853405 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker F18Alphappc
  Show dependency treegraph
 
Reported: 2012-08-30 16:18 EDT by Jesse Keating
Modified: 2014-01-21 18:23 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 21:08:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2012-08-30 16:18:52 EDT
When the package is coming from the DVD, yum is still trying to do a size check of where the package is coming from (confused about where the package will be read from?).  This will fail, and prevent install from progressing.

This bug is already fixed upstream, but I'm filing it to get it into the F18Alpha blocker list and to fill in bodhi.
Comment 1 Fedora Update System 2012-08-30 16:26:39 EDT
yum-3.4.3-40.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-12900/yum-3.4.3-40.fc18
Comment 2 Adam Williamson 2012-08-30 16:47:32 EDT
+1 blocker, breaking DVD install is bad. criterion "When booting from a DVD ISO image, the installer must be able to use the DVD local package source options".
Comment 3 Fedora Update System 2012-08-31 02:45:24 EDT
yum-3.4.3-40.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Mark Hamzy 2012-08-31 11:48:44 EDT
This still fails for me on ppc64 and using a private iso build.

There is a difference between what I tested:

        if url and size and (self.copy_local or not (url.startswith("/") or
                                                     url.startswith("file:"))):

and what is in the -40 rpm:

        if size and (self.copy_local or not url or
                     not (url.startswith("/") or url.startswith("file:"))):

<hamzy2> geppetto, unfortunately yum-40 does not look like it fixes the install hang
<geppetto> install hang? … I thought it tracebacked due to the statvfs?
<hamzy2> well after they did a little debugging
<hamzy2> but the symptoms shown to the user is a hang
<hamzy2> with no traceback file
<geppetto> ok
<hamzy2> so why did you remove the first test for url?
<geppetto> But you said it worked, yesterday
<hamzy2>         if url and size and (self.copy_local or not (url.startswith("/") or
<hamzy2>                                                      url.startswith("file:"))):
<hamzy2> worked
<geppetto> I didn't … I moved it to
<geppetto> the right side.
<geppetto>         if size and (self.copy_local or not url or
<geppetto>                      not (url.startswith("/") or url.startswith("file:"))):
<hamzy2> ah yeah
<hamzy2> well something about that test versus the other is different
<geppetto> The only difference should be when url=None
<geppetto> At which point it'll go off of relative
<geppetto> Which is where yum has a problem, because it can't easily work out where relative is going to end up without copying a bunch more urlgrabber logic.
<geppetto> I'm also pretty sure we can't just ignore the size checks for all relative _getFile() calls.
<geppetto> …is it possible for you guys to pass in a "local" that points somewhere that the statvfs checks won't fail on? (given it's not going to be used anyway).
<hamzy2> I'll ask the anaconda team when they start showing up
* geppetto nods
Comment 5 Jesse Keating 2012-08-31 12:43:59 EDT
*** Bug 853405 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2012-08-31 15:42:19 EDT
This still seems to be valid in TC4, so re-opening.
Comment 7 Fedora Update System 2012-08-31 18:21:17 EDT
yum-3.4.3-41.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-41.fc18
Comment 8 Adam Williamson 2012-08-31 20:25:23 EDT
Jesse and I have confirmed that yum 3.4.3-42 ought to fix this. http://jkeating.fedorapeople.org/updates.img can be used with TC4 to confirm.
Comment 9 Fedora Update System 2012-09-01 12:56:05 EDT
Package yum-3.4.3-42.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-42.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13103/yum-3.4.3-42.fc18
then log in and leave karma (feedback).
Comment 10 Kamil Páral 2012-09-03 04:24:43 EDT
The DVD repo installation now works fine in F18 Alpha TC5.
Comment 11 Adam Williamson 2012-09-05 12:36:43 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion "When booting from a DVD ISO image, the installer must be able to use the DVD local package source options".
Comment 12 Fedora Update System 2012-09-05 21:08:21 EDT
yum-3.4.3-42.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.