Bug 853405 - Installation hangs when installing from DVD repo
Installation hangs when installing from DVD repo
Status: CLOSED DUPLICATE of bug 853238
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-31 08:36 EDT by Petr Schindler
Modified: 2013-01-10 01:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-31 12:43:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-08-31 08:36:43 EDT
Description of problem:
Installation stops during installation of filesystem package when installing from DVD repository. It takes 100% CPU, but nothing happens. It doesn't happen when installing from mirrors.



Version-Release number of selected component (if applicable):
Fedora-18-Alpha-TC4-x86_64-DVD.iso
anaconda-18.6.4

How reproducible:
always

Steps to Reproduce:
1. choose dvd as installation source
2. go through the partitioning and software selecting
3. continue to installation
  
Actual results:
installation stops on filesystem package

Expected results:
anaconda installs the system

Additional info:
I propose this as alpha blocker due to criteria:
'When booting from a DVD ISO image, the installer must be able to use the DVD local package source options'
'The installer must be able to complete package installation with the default package set for each supported installation method'
Comment 1 Kamil Páral 2012-08-31 08:45:55 EDT
This is what I get when attaching strace:

> futex(0x836f690, FUTEX_WAKE_PRIVATE, 1) = 1
> recv(29, 0x87213b8, 4096, 0)            = -1 EAGAIN (Resource temporarily unavailable)
> clock_gettime(CLOCK_MONOTONIC, {1383, 633100367}) = 0
> poll([{fd=28, events=POLLIN}, {fd=29, events=POLLIN}, {fd=26, events=POLLIN}, {fd=21, events=POLLIN}, {fd=33, events=POLLIN}, {fd=32, events=POLLIN}, {fd=30, events=0}], 7, 0) = 0 (Timeout)
> recv(29, 0x87213b8, 4096, 0)            = -1 EAGAIN (Resource temporarily unavailable)
> clock_gettime(CLOCK_MONOTONIC, {1383, 633547368}) = 0
> poll([{fd=28, events=POLLIN}, {fd=29, events=POLLIN}, {fd=26, events=POLLIN}, {fd=21, events=POLLIN}, {fd=33, events=POLLIN}, {fd=32, events=POLLIN}, {fd=30, events=0}], 7, 0) = 0 (Timeout)
> recv(29, 0x87213b8, 4096, 0)            = -1 EAGAIN (Resource temporarily unavailable)
> clock_gettime(CLOCK_MONOTONIC, {1383, 634077785}) = 0
> poll([{fd=28, events=POLLIN}, {fd=29, events=POLLIN}, {fd=26, events=POLLIN}, {fd=21, events=POLLIN}, {fd=33, events=POLLIN}, {fd=32, events=POLLIN}, {fd=30, events=0}], 7, 0) = 0 (Timeout)
> recv(29, 0x87213b8, 4096, 0)            = -1 EAGAIN (Resource temporarily unavailable)

$ ls -l /proc/573/fd/29
lrwx------. 1 root root 64 Aug 31 12:01 /proc/573/fd/29 -> socket:[14002]
Comment 2 Jesse Keating 2012-08-31 12:43:59 EDT

*** This bug has been marked as a duplicate of bug 853238 ***
Comment 3 Mukundan Ragavan 2012-08-31 15:10:33 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Reartes Guillermo 2012-08-31 17:30:05 EDT
f18 pretc4-5, it also stalls in "installing filesystem", tried kde, gnome, minimal. i am currently downloading tc4.
Comment 5 Mukundan Ragavan 2012-08-31 17:31:45 EDT
tc4 also has the same problem. What information can I provide to help wit this?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Jesse Keating 2012-08-31 17:43:36 EDT
(In reply to comment #5)
> tc4 also has the same problem. What information can I provide to help wit
> this?

Nothing.  It's a known problem, tracked in the bug I've marked this a duplicate of.

Note You need to log in before you can comment on or make changes to this bug.