Bug 853242 - [abrt] astromenace-1.2-15.fc17: operator new: Process /usr/bin/astromenace was killed by signal 6 (SIGABRT)
[abrt] astromenace-1.2-15.fc17: operator new: Process /usr/bin/astromenace wa...
Status: CLOSED DUPLICATE of bug 832142
Product: Fedora
Classification: Fedora
Component: astromenace (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
abrt_hash:13f442c9a1930353437ae0e4531...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 16:32 EDT by Alex
Modified: 2012-09-30 00:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-30 00:13:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.59 KB, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: environ (1.25 KB, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: event_log (1.38 KB, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: limits (1.29 KB, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: backtrace (17.17 KB, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: cgroup (127 bytes, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: maps (42.64 KB, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: dso_list (4.72 KB, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: var_log_messages (317 bytes, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details
File: open_fds (565 bytes, text/plain)
2012-08-30 16:32 EDT, Alex
no flags Details

  None (edit)
Description Alex 2012-08-30 16:32:00 EDT
Description of problem:
The program crashed right after loading the second level.

Version-Release number of selected component:
astromenace-1.2-15.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        astromenace --noAA
crash_function: operator new
kernel:         3.5.2-3.fc17.x86_64

truncated backtrace:
:Thread no. 1 (6 frames)
: #6 operator new at ../../../../libstdc++-v3/libsupc++/new_op.cc
: #7 operator new[] at ../../../../libstdc++-v3/libsupc++/new_opv.cc
: #8 vw_fopen at /usr/src/debug/AstroMenaceSourceCode/AstroMenaceSource/Core/VirtualFileSystem/VFS.cpp
: #9 vw_LoadTexture at /usr/src/debug/AstroMenaceSourceCode/AstroMenaceSource/Core/Texture/Texture.cpp
: #10 LoadGameData at /usr/src/debug/AstroMenaceSourceCode/AstroMenaceSource/Loading.cpp
: #11 Loop_Proc at /usr/src/debug/AstroMenaceSourceCode/AstroMenaceSource/Loop_proc.cpp
Comment 1 Alex 2012-08-30 16:32:03 EDT
Created attachment 608299 [details]
File: core_backtrace
Comment 2 Alex 2012-08-30 16:32:05 EDT
Created attachment 608300 [details]
File: environ
Comment 3 Alex 2012-08-30 16:32:07 EDT
Created attachment 608301 [details]
File: event_log
Comment 4 Alex 2012-08-30 16:32:09 EDT
Created attachment 608302 [details]
File: limits
Comment 5 Alex 2012-08-30 16:32:12 EDT
Created attachment 608303 [details]
File: backtrace
Comment 6 Alex 2012-08-30 16:32:14 EDT
Created attachment 608304 [details]
File: cgroup
Comment 7 Alex 2012-08-30 16:32:16 EDT
Created attachment 608305 [details]
File: maps
Comment 8 Alex 2012-08-30 16:32:18 EDT
Created attachment 608306 [details]
File: dso_list
Comment 9 Alex 2012-08-30 16:32:21 EDT
Created attachment 608307 [details]
File: var_log_messages
Comment 10 Alex 2012-08-30 16:32:23 EDT
Created attachment 608308 [details]
File: open_fds
Comment 11 Alex 2012-08-30 16:43:20 EDT
Crash before level 2 starts

backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Sergey 2012-09-21 15:01:25 EDT
start second mission

backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Ivan Romanov 2012-09-30 00:13:39 EDT

*** This bug has been marked as a duplicate of bug 832142 ***

Note You need to log in before you can comment on or make changes to this bug.