Bug 832142 - [abrt] astromenace-1.2-15.fc17: __GI_raise: Process /usr/bin/astromenace was killed by signal 6 (SIGABRT)
[abrt] astromenace-1.2-15.fc17: __GI_raise: Process /usr/bin/astromenace was ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: astromenace (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
abrt_hash:22be69d55911e626b1869628d5c...
:
: 834364 845780 853242 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 12:17 EDT by arturj
Modified: 2012-12-20 10:34 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:34:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (4.73 KB, text/plain)
2012-06-14 12:17 EDT, arturj
no flags Details
File: maps (40.49 KB, text/plain)
2012-06-14 12:17 EDT, arturj
no flags Details
File: backtrace (17.07 KB, text/plain)
2012-06-14 12:17 EDT, arturj
no flags Details
Patch to workaround this problem (420 bytes, patch)
2012-09-30 00:10 EDT, Ivan Romanov
no flags Details | Diff

  None (edit)
Description arturj 2012-06-14 12:17:30 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        astromenace
comment:        always crashing on loading level 2, though level 1 works fine
crash_function: __GI_raise
executable:     /usr/bin/astromenace
kernel:         3.4.0-1.fc17.x86_64
pid:            19153
pwd:            /home/artur
time:           Do 14 Jun 2012 17:58:16 CEST
uid:            1000
username:       artur

backtrace:      Text file, 17481 bytes
dso_list:       Text file, 4845 bytes
maps:           Text file, 41462 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/artur/1

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x35965 raise libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x37118 abort libc.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x60bed __gnu_cxx::__verbose_terminate_handler() libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5ecf6 - libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5ed23 std::terminate() libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5ef4e __cxa_throw libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5f42d operator libstdc++.so.6 -
:516204cfc31148538d56b21e2f1b945ed50127d4 0x5f4c9 operator libstdc++.so.6 -
:7c93f78f4becfc0eb7ea3cc6b4e1ec711cd6f960 0x501d4 vw_fopen(char [exe] -
:7c93f78f4becfc0eb7ea3cc6b4e1ec711cd6f960 0x39996 vw_LoadTexture(char [exe] -
:7c93f78f4becfc0eb7ea3cc6b4e1ec711cd6f960 0x3670a LoadGameData(int) [exe] -
:7c93f78f4becfc0eb7ea3cc6b4e1ec711cd6f960 0x95b1a Loop_Proc() [exe] -
:7c93f78f4becfc0eb7ea3cc6b4e1ec711cd6f960 0x1cea8 main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=usb
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/artur/keyring-FUWHok/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=b8fc4df4ab458c6b86f4958900000023-1339621544.569380-707297482
:GJS_DEBUG_OUTPUT=stderr
:WINDOWID=31457285
:GNOME_KEYRING_CONTROL=/run/user/artur/keyring-FUWHok
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=artur
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/run/user/artur/keyring-FUWHok/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1198,unix/unix:/tmp/.ICE-unix/1198
:USERNAME=artur
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/artur/.local/bin:/home/artur/bin
:MAIL=/var/spool/mail/artur
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/artur
:XMODIFIERS=@im=none
:LANG=de_DE.utf8
:GDM_LANG=de_DE.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/artur
:XDG_SEAT=seat0
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=artur
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-fVJNEP9FSJ,guid=253e22e76ee4a1b20a54a4810000003d
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/artur
:DISPLAY=:0
:CCACHE_HASHDIR=
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-artur-ASQTzS/database
:_=/usr/bin/astromenace

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29818                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29818                29818                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/1
:1:/dev/pts/1
:2:/dev/pts/1
:3:/usr/share/astromenace/gamedata.vfs
:4:/usr/share/astromenace/gamelang_en.vfs
:5:pipe:[288813]
:6:pipe:[288813]
:7:socket:[288816]
:8:socket:[288818]
:9:socket:[288819]
:10:/dev/dri/card0
:11:/usr/share/astromenace

var_log_messages:
:Jun 13 12:07:10 usb yum[18551]: Installed: astromenace-data-1.2-5.fc17.noarch
:Jun 13 12:07:53 usb yum[18551]: Installed: astromenace-1.2-15.fc17.x86_64
:Jun 13 15:04:48 usb abrt[1804]: Saved core dump of pid 1685 (/usr/bin/astromenace) to /var/spool/abrt/ccpp-2012-06-13-15:04:26-1685 (89460736 bytes)
:Jun 13 15:53:37 usb abrt[3282]: Saved core dump of pid 3178 (/usr/bin/astromenace) to /var/spool/abrt/ccpp-2012-06-13-15:53:11-3178 (92897280 bytes)
:Jun 13 15:57:36 usb abrt[3370]: Saved core dump of pid 3363 (/usr/bin/astromenace) to /var/spool/abrt/ccpp-2012-06-13-15:57:27-3363 (74502144 bytes)
:Jun 13 15:59:39 usb abrt[3422]: Saved core dump of pid 3416 (/usr/bin/astromenace) to /var/spool/abrt/ccpp-2012-06-13-15:59:27-3416 (73981952 bytes)
:Jun 14 17:58:37 usb abrt[19171]: Saved core dump of pid 19153 (/usr/bin/astromenace) to /var/spool/abrt/ccpp-2012-06-14-17:58:16-19153 (73330688 bytes)
Comment 1 arturj 2012-06-14 12:17:34 EDT
Created attachment 591864 [details]
File: dso_list
Comment 2 arturj 2012-06-14 12:17:37 EDT
Created attachment 591865 [details]
File: maps
Comment 3 arturj 2012-06-14 12:17:40 EDT
Created attachment 591866 [details]
File: backtrace
Comment 4 James Heather 2012-07-01 08:04:56 EDT
This is happening for me too. I asked abrt to report it, and it claimed to have added me to the cc list, but it seems not to have done, so I'm doing so manually.

I'm sure it's saved the report, so I can resubmit if the info would be useful.
Comment 5 Gwyn Ciesla 2012-07-04 18:24:27 EDT
Is it only level 2?  I can't repropuce because I can't pass level 1. :)
Comment 6 Tex Mitchell 2012-07-05 11:37:40 EDT
Starting second level and the game just spontaneously shutdown.  I might have hit the f5 (slow game speed) key as I was getting ready to hit it as soon as the level started.  Regardless, that shouldn't crash the game.

backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 arturj 2012-07-05 15:02:11 EDT
(In reply to comment #5)
> Is it only level 2?  I can't repropuce because I can't pass level 1. :)

Yes, Level 1 works very fine. It happens on loading the level 2.
Comment 8 VIKIMAUS 2012-07-09 18:25:06 EDT
i play game with full 

backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Gwyn Ciesla 2012-07-24 11:57:52 EDT
Looking at the code, despite my unfamiliarity with Russian, inspired a patch.  I've uploaded f17 i686 and x86_64 builds to:

http://fedorapeople.org/~limb/astromenace/

Can you test and let me know if this helps?
Comment 10 Xra 2012-07-26 06:08:28 EDT
1 launch astromenace
2 play level 1
3 start level 2
4 crash


backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Gwyn Ciesla 2012-07-26 08:20:13 EDT
Xra, can you try the version linked to in Comment 9, please?
Comment 12 arturj 2012-08-02 11:48:40 EDT
for me the 32-bit version does not start at all, throws memory access error.
tested today on up-to-date fedora 17 i386.
Comment 13 arturj 2012-08-02 11:51:14 EDT
sorr(In reply to comment #9)
> Looking at the code, despite my unfamiliarity with Russian, inspired a
> patch.  I've uploaded f17 i686 and x86_64 builds to:
> 
> http://fedorapeople.org/~limb/astromenace/
> 
> Can you test and let me know if this helps?


for me the 32-bit version does not start at all, throws memory access error.
tested today on up-to-date fedora 17 i386.
Comment 14 Jertel 2012-08-05 05:11:07 EDT
Quits on level 2 every time :(

backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 michal.wojtasiewicz 2012-08-11 10:51:23 EDT
(In reply to comment #9)
> Looking at the code, despite my unfamiliarity with Russian, inspired a
> patch.  I've uploaded f17 i686 and x86_64 builds to:
> 
> http://fedorapeople.org/~limb/astromenace/
> 
> Can you test and let me know if this helps?

For me it`s the same thing like in Comment 13
Now it crashes at the start.
Comment 16 Jeff DeLooze 2012-08-15 14:17:46 EDT
playing astromenace, completed the first mission a few times then decided to move on to second mission.  selected second mission from list of available missions and clicked the next button and received immediate sigabrt

backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 ARIKO 2012-08-20 13:37:57 EDT
- just clic start after first level to play the second level.

backtrace_rating: 4
Package: astromenace-1.2-15.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 18 erebis671 2012-08-24 02:55:50 EDT
(In reply to comment #9)
> Looking at the code, despite my unfamiliarity with Russian, inspired a
> patch.  I've uploaded f17 i686 and x86_64 builds to:
> 
> http://fedorapeople.org/~limb/astromenace/
> 
> Can you test and let me know if this helps?

I tested it out, I get the same as the others, it crashes right at the start, I cannot report it cause the backtrace is unusable.
Comment 19 Ivan Romanov 2012-09-30 00:10:05 EDT
Created attachment 619317 [details]
Patch to workaround this problem

I've tested this patch for myself. It's fully working. I don't found any problems. But I don't learned code in deep. So it's workaround. When you load 2 level the program trying to load a texture with noname file. So I just check for non-empty filename in my patch.
Comment 20 Ivan Romanov 2012-09-30 00:13:39 EDT
*** Bug 853242 has been marked as a duplicate of this bug. ***
Comment 21 Ivan Romanov 2012-09-30 00:14:01 EDT
*** Bug 845780 has been marked as a duplicate of this bug. ***
Comment 22 Ivan Romanov 2012-09-30 00:14:12 EDT
*** Bug 834364 has been marked as a duplicate of this bug. ***
Comment 23 Gwyn Ciesla 2012-09-30 09:20:02 EDT
Thank you!  I'll get this out ASAP.
Comment 24 Fedora Update System 2012-09-30 09:32:13 EDT
astromenace-1.2-17.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/astromenace-1.2-17.fc18
Comment 25 Fedora Update System 2012-09-30 09:32:24 EDT
astromenace-1.2-17.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/astromenace-1.2-17.fc17
Comment 26 Fedora Update System 2012-09-30 14:23:42 EDT
Package astromenace-1.2-17.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing astromenace-1.2-17.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15126/astromenace-1.2-17.fc18
then log in and leave karma (feedback).
Comment 27 Fedora Update System 2012-12-20 10:34:38 EST
astromenace-1.2-17.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.