Bug 853457 - jboss-as blank Administration Console and startup errors
jboss-as blank Administration Console and startup errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: jboss-as (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
: 915794 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 11:31 EDT by Rui Mota
Modified: 2013-02-26 14:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-31 11:40:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rui Mota 2012-08-31 11:31:19 EDT
Description of problem:
In a fresh instalation of jboss-as the application server gets errors on startup.
In /var/log/jboss-as/standalone/boot.log file I get:

13:50:03,996 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA
13:50:04,372 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA
13:50:04,471 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting
13:50:04,473 DEBUG [org.jboss.as.config] Configured system properties:
        [Standalone] = 
        awt.toolkit = sun.awt.X11.XToolkit
        file.encoding = UTF-8
        file.encoding.pkg = sun.io
        file.separator = /
        java.awt.graphicsenv = sun.awt.X11GraphicsEnvironment
        java.awt.headless = true
        java.awt.printerjob = sun.print.PSPrinterJob
        java.class.path = /usr/share/jboss-as/jboss-modules.jar
        java.class.version = 51.0
        java.endorsed.dirs = /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/endorsed
        java.ext.dirs = /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/ext:/usr/java/packages/lib/ext
        java.home = /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre
        java.io.tmpdir = /tmp
        java.library.path = /usr/java/packages/lib/i386:/lib:/usr/lib
        java.net.preferIPv4Stack = true
        java.runtime.name = OpenJDK Runtime Environment
        java.runtime.version = 1.7.0_06-icedtea-mockbuild_2012_08_22_16_35-b00
        java.specification.name = Java Platform API Specification
        java.specification.vendor = Oracle Corporation
        java.specification.version = 1.7
        java.util.logging.manager = org.jboss.logmanager.LogManager
        java.vendor = Oracle Corporation
        java.vendor.url = http://java.oracle.com/
        java.vendor.url.bug = http://bugreport.sun.com/bugreport/
        java.version = 1.7.0_06-icedtea
        java.vm.info = mixed mode
        java.vm.name = OpenJDK Server VM
        java.vm.specification.name = Java Virtual Machine Specification
        java.vm.specification.vendor = Oracle Corporation
        java.vm.specification.version = 1.7
        java.vm.vendor = Oracle Corporation
        java.vm.version = 23.2-b09
        javax.management.builder.initial = org.jboss.as.jmx.PluggableMBeanServerBuilder
        javax.xml.datatype.DatatypeFactory = __redirected.__DatatypeFactory
        javax.xml.parsers.DocumentBuilderFactory = __redirected.__DocumentBuilderFactory
        javax.xml.parsers.SAXParserFactory = __redirected.__SAXParserFactory
        javax.xml.stream.XMLEventFactory = __redirected.__XMLEventFactory
        javax.xml.stream.XMLInputFactory = __redirected.__XMLInputFactory
        javax.xml.stream.XMLOutputFactory = __redirected.__XMLOutputFactory
        javax.xml.transform.TransformerFactory = __redirected.__TransformerFactory
        javax.xml.validation.SchemaFactory:http://www.w3.org/2001/XMLSchema = __redirected.__SchemaFactory
        javax.xml.xpath.XPathFactory:http://java.sun.com/jaxp/xpath/dom = __redirected.__XPathFactory
        jboss.home.dir = /usr/share/jboss-as
        jboss.host.name = vivaldi
        jboss.modules.dir = /usr/share/jboss-as/modules
        jboss.modules.system.pkgs = org.jboss.byteman
        jboss.node.name = vivaldi
        jboss.qualified.host.name = vivaldi.lan
        jboss.server.base.dir = /usr/share/jboss-as/standalone
        jboss.server.config.dir = /usr/share/jboss-as/standalone/configuration
        jboss.server.data.dir = /usr/share/jboss-as/standalone/data
        jboss.server.default.config = standalone.xml
        jboss.server.deploy.dir = /usr/share/jboss-as/standalone/data/content
        jboss.server.log.dir = /usr/share/jboss-as/standalone/log
        jboss.server.name = vivaldi
        jboss.server.temp.dir = /usr/share/jboss-as/standalone/tmp
        line.separator = 

        logging.configuration = file:/usr/share/jboss-as/standalone/configuration/logging.properties
        module.path = /usr/share/jboss-as/modules
        org.jboss.boot.log.file = /usr/share/jboss-as/standalone/log/boot.log
        org.jboss.resolver.warning = true
        org.xml.sax.driver = __redirected.__XMLReaderFactory
        os.arch = i386
        os.name = Linux
        os.version = 3.5.2-3.fc17.i686
        path.separator = :
        sun.arch.data.model = 32
        sun.boot.class.path = /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/resources.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/rt.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/jsse.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/jce.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/charsets.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/netx.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/plugin.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/rhino.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/jfr.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/classes
        sun.boot.library.path = /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/jre/lib/i386
        sun.cpu.endian = little
        sun.cpu.isalist = 
        sun.io.unicode.encoding = UnicodeLittle
        sun.java.command = /usr/share/jboss-as/jboss-modules.jar -mp /usr/share/jboss-as/modules -jaxpmodule javax.xml.jaxp-provider org.jboss.as.standalone -Djboss.home.dir=/usr/share/jboss-as -Djboss.server.base.dir=/usr/share/jboss-as/standalone -c standalone-web.xml
        sun.java.launcher = SUN_STANDARD
        sun.jnu.encoding = UTF-8
        sun.management.compiler = HotSpot Tiered Compilers
        sun.os.patch.level = unknown
        sun.rmi.dgc.client.gcInterval = 3600000
        sun.rmi.dgc.server.gcInterval = 3600000
        user.country = US
        user.dir = /
        user.home = /usr/share/jboss-as
        user.language = en
        user.name = jboss-as
        user.timezone = Portugal
13:50:04,492 DEBUG [org.jboss.as.config] VM Arguments: -D[Standalone] -XX:+TieredCompilation -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.server.default.config=standalone.xml -Dorg.jboss.boot.log.file=/usr/share/jboss-as/standalone/log/boot.log -Dlogging.configuration=file:/usr/share/jboss-as/standalone/configuration/logging.properties 
13:50:05,523 ERROR [org.jboss.as.jpa] JBAS011405: Could not load default persistence provider module.  : org.jboss.modules.ModuleNotFoundException: Module org.hibernate:main is not found in local module loader @11eaf4e (roots: /usr/share/jboss-as/modules)
        at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:204) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.as.jpa.persistenceprovider.PersistenceProviderLoader.loadProviderModuleByName(PersistenceProviderLoader.java:59) [jboss-as-jpa-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.jpa.persistenceprovider.PersistenceProviderLoader.loadDefaultProvider(PersistenceProviderLoader.java:48) [jboss-as-jpa-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.jpa.subsystem.JPAExtension.initialize(JPAExtension.java:111) [jboss-as-jpa-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.extension.ExtensionAddHandler.initializeExtension(ExtensionAddHandler.java:88) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.extension.ParallelExtensionAddHandler$ExtensionInitializeTask.call(ParallelExtensionAddHandler.java:127) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.extension.ParallelExtensionAddHandler$ExtensionInitializeTask.call(ParallelExtensionAddHandler.java:113) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.7.0_06-icedtea]
        at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.7.0_06-icedtea]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_06-icedtea]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_06-icedtea]
        at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_06-icedtea]
        at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads.jar:2.0.0.GA]

13:50:05,641 ERROR [org.jboss.as.jpa] JBAS011404: Could not load default persistence provider adaptor module.  Management attributes will not be registered for the adaptor: org.jboss.modules.ModuleNotFoundException: Module org.jboss.as.jpa.hibernate:4 is not found in local module loader @11eaf4e (roots: /usr/share/jboss-as/modules)
        at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:204) [jboss-modules.jar:1.1.1.GA]
        at org.jboss.as.jpa.processor.PersistenceProviderAdaptorLoader.loadPersistenceAdapterModule(PersistenceProviderAdaptorLoader.java:100) [jboss-as-jpa-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.jpa.subsystem.JPAExtension.initialize(JPAExtension.java:118) [jboss-as-jpa-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.extension.ExtensionAddHandler.initializeExtension(ExtensionAddHandler.java:88) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.extension.ParallelExtensionAddHandler$ExtensionInitializeTask.call(ParallelExtensionAddHandler.java:127) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.extension.ParallelExtensionAddHandler$ExtensionInitializeTask.call(ParallelExtensionAddHandler.java:113) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.7.0_06-icedtea]
        at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.7.0_06-icedtea]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_06-icedtea]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_06-icedtea]
        at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_06-icedtea]
        at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads.jar:2.0.0.GA]

13:50:05,915 INFO  [org.xnio] XNIO Version 3.0.3.GA
13:50:05,940 INFO  [org.jboss.as.server] JBAS015888: Creating http management service using socket-binding (management-http)
13:50:05,954 INFO  [org.xnio.nio] XNIO NIO Implementation Version 3.0.3.GA
13:50:05,978 INFO  [org.jboss.remoting] JBoss Remoting version 3.2.4.GA
13:50:06,041 INFO  [org.jboss.as.logging] JBAS011502: Removing bootstrap log handlers


The server gets started and I was able to deploy and run some of the downloaded quickstart samples.
But the Administration Console shows a blank page.
I'm able to access
http://localhost:8080

but when I click on 'Administration Console' link to http://localhost:8080/console it redirects to http://localhost:9990/console and shows a blank page.


How reproducible:
Always


Steps to Reproduce:
1. Install jboss-as  : yum install jboss-as
2. start the service : systemctl start jboss-as.service
3. check the log file: cat /var/log/jboss-as/standalone/boot.log
4. open the browser to 'http://localhost:8080'
5. click 'Administrator Console' link.
  
Actual results:
Shows blank page


Expected results:
Should show some console
Comment 1 Marek Goldmann 2012-08-31 11:40:31 EDT
Messages in log are telling that there is no default persistence provider (Hibernate 4). We're working on adding this provider. This is not an issue and can be omitted.

The web administration console is not packaged and therefore you get the blank page. This is not an issue too, we just need some help on packaging jboss-as-console dependencies (gwt for example).

Instead of the console, please use jboss-cli (the JBoss AS command line interface).

As noted here on the feature page http://fedoraproject.org/wiki/Features/JBossAS7 the current version is not a full JBoss AS 7, although we have only a few bits left. One of these bits is the console. Other include jacorb (will be available in jboss-as-7.1.1-8) and xts.
Comment 2 Rui Mota 2012-09-07 10:51:26 EDT
Ok,
so it means that everything is working as expected in this latest Fedora release JBoss7.

Thank you.
Comment 3 Marek Goldmann 2013-02-26 09:48:47 EST
*** Bug 915794 has been marked as a duplicate of this bug. ***
Comment 4 Bill C. Riemers 2013-02-26 14:38:17 EST
It might be a good idea to change the default value to JBOSS_BIND to 127.0.0.1.  As anyone deploying to a production server will know to edit this value, but this is just one more thing for people doing a test installation on a laptop or such to find and change.

Note You need to log in before you can comment on or make changes to this bug.