Bug 853572 - typo in rhsmcertd --help message
typo in rhsmcertd --help message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.4
Assigned To: Bryan Kearney
Entitlement Bugs
:
: 860674 (view as bug list)
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-08-31 18:29 EDT by John Sefler
Modified: 2013-02-21 03:55 EST (History)
4 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:55:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-31 18:29:36 EDT
Description of problem:

[root@jsefler-59client ~]# rhsmcertd --help
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -?, --help                      Show help options

Application Options:
  -c, --cert-interval=MINUTES     Interval to run cert check (in minutes)
  -i, --heal-interval=MINUTES     Interval to run healing (in minutes)
  -n, --now                       Run the initial checks immediatly, with no delay.
  -d, --debug                     Show debug messages


TYPO IN THE WORD "immediatly". SHOULD BE "immediately"

Version-Release number of selected component (if applicable):
[root@jsefler-59client ~]# rpm -q subscription-manager
subscription-manager-1.0.17-1.el5
Comment 1 RHEL Product and Program Management 2012-08-31 18:48:11 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-09-17 14:58:40 EDT
We are past string freeze. Pushing this to RHEL 6.
Comment 3 John Sefler 2012-09-26 09:30:21 EDT
*** Bug 860674 has been marked as a duplicate of this bug. ***
Comment 4 Bryan Kearney 2012-10-04 09:20:35 EDT
fixed in master at dad433893e0171f691b819293f2f90b5736b2164
Comment 7 Shwetha Kallesh 2012-11-07 04:21:45 EST
Back to new... as it should be "immediately" and not "immediatley"

[root@rhel-64-server ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.7.18-1
subscription-manager: 1.1.5-1.el6
python-rhsm: 1.1.4-1.el6
[root@rhel-64-server ~]# rhsmcertd --help
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -h, --help                      Show help options

Application Options:
  -c, --cert-interval=MINUTES     Interval to run cert check (in minutes)
  -i, --heal-interval=MINUTES     Interval to run healing (in minutes)
  -n, --now                       Run the initial checks immediatley, with no delay.                                                   ^^ immediately 
  -d, --debug                     Show debug messages
Comment 8 Bryan Kearney 2012-11-09 15:53:01 EST
fixed in master at a4c3df229579dfb467425c4a9143ec6d48dac155.
Comment 10 John Sefler 2012-11-19 08:22:16 EST
[jsefler@jseflerT510 po]$ git log | head -1
commit 80e937c981145bcb9e469587248f864e40c025dd

#: ../src/rhsmcertd.c:64
msgid "run the initial checks immediately, with no delay."
               NO PERIODS AT END OF OPTION DESCRIPTIONS ^
               SEE BUG 876356 

Moving back to ASSIGNED
Comment 11 Bryan Kearney 2012-11-19 09:43:41 EST
commit da61b7f30c741ce84af576a178e77cd0d9335f04
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Mon Nov 19 09:45:08 2012 -0500

    853572: Remove the period at the end of the help message
Comment 12 John Sefler 2012-11-19 09:45:14 EST
  -h, --help                      Show help options
                  LOWERCASE THE S ^
                  SEE BUG 876356
Comment 13 Adrian Likins 2012-11-19 09:57:22 EST
-h, --help                      Show help options

That is from the glib options parser.

I'm not changing that.
Comment 15 John Sefler 2012-12-07 15:16:09 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.1.11-1.el6.x86_64
python-rhsm-1.1.6-1.el6.x86_64


[root@jsefler-6 ~]# rhsmcertd --help
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -h, --help                             Show help options

Application Options:
  -c, --cert-interval=MINUTES            interval to run cert check (in minutes)
  --heal-interval=MINUTES                deprecated, see auto-attach-interval
  -i, --auto-attach-interval=MINUTES     interval to run auto-attach (in minutes)
  -n, --now                              run the initial checks immediately, with no delay
  -d, --debug                            show debug messages


VERIFIED:
ending periods removed from descriptions
first char of descriptions is lowercase (exception is Show)
"immediately" typo was corrected
the split-line usage statement is an exception for rhsmcertd

Moving to VERIFIED
Comment 17 errata-xmlrpc 2013-02-21 03:55:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.