Bug 853584 - Minimum install not creating /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-<interface>
Minimum install not creating /etc/sysconfig/network and /etc/sysconfig/networ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
: 858962 877764 (view as bug list)
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2012-08-31 20:27 EDT by Scott Robbins
Modified: 2012-11-28 06:49 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 20:14:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Robbins 2012-08-31 20:27:15 EDT
Description of problem:
Installing from x86_64 netinstall F18 TC4.  After installation, no /etc/sysconfig/network is created.  In addition, /etc/sysconfig/network-scripts/ifcfg-eth0 (or pp1p1 for example) are not created, though ifcfg-lo is created. 


Version-Release number of selected component (if applicable):

Fedora-18 netinstall-TC4 is the only one I've tested.


How reproducible:
Download netinstall iso and choose minimum install


Steps to Reproduce: See above
1.
2.
3.
  
Actual results: There is no /etc/sysconfig/network file created. Nor is there an /etc/sysconfig/network-scripts/ifcfg-eth0 or other interface created. 


Expected results:
To have an /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-eth0 (or pp1p1,etc.).


Additional info: Despite these missing files,if one uses the default Network Manager, the interface will be started and get an address at boot.   Therefore, it may only affect people who prefer to avoid NetworkManager (and it now takes deliberate effort to do so.)
Comment 1 Scott Robbins 2012-09-01 06:31:42 EDT
Problem still exists in TC5
Comment 2 Radek Vykydal 2012-09-03 08:58:37 EDT
This should be fixed on master with
commit e2307897400700b10d60b0a80e7b15ef7d6f1772
Comment 3 Radek Vykydal 2012-09-03 09:04:04 EDT
(In reply to comment #2)
> This should be fixed on master with
> commit e2307897400700b10d60b0a80e7b15ef7d6f1772

Just a note - also next 6 (or et least 4) patches from master should be included.
Comment 4 Scott Robbins 2012-09-04 21:04:07 EDT
This is still happening with pretc6.  (I've not been keeping track of commit numbers, just giving TC's a quick install when they're out.)
Comment 5 Scott Robbins 2012-09-06 20:08:49 EDT
Not fixed in tcpre7-1
Comment 6 Scott Robbins 2012-09-10 15:26:57 EDT
Just tried pretc7-2 (the one labeled F17).  :)

Still not fixed.  When will the commit in comment #3 be applied?
Comment 7 Scott Robbins 2012-09-18 10:39:28 EDT
Not fixed in latest Gold Alpha. 

Is this expected to be fixed by Beta?
Comment 8 Radek Vykydal 2012-09-19 04:22:44 EDT
Yes.
Comment 9 Radek Vykydal 2012-09-21 03:13:40 EDT
*** Bug 858962 has been marked as a duplicate of this bug. ***
Comment 10 Scott Robbins 2012-10-03 11:28:00 EDT
This seems to be fixed in Beta TC1.  I wasn't able to boot into multi-user mode in this beta, but when I booted single user mode, the files existed.  Thank you.
Comment 11 Radek Vykydal 2012-11-20 04:42:33 EST
*** Bug 877764 has been marked as a duplicate of this bug. ***
Comment 12 Adam Williamson 2012-11-22 20:14:07 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(ref comment #10)

Note You need to log in before you can comment on or make changes to this bug.