Bug 853592 - SELinux is preventing /usr/libexec/colord from 'read' accesses on the file /home/Mykene/zic/.local/share/icc/edid-978c128ec1811e998a65d299335a899d.icc.
SELinux is preventing /usr/libexec/colord from 'read' accesses on the file /h...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ce9ecaa2a7dbe7c999eafbcc806...
:
: 853603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-01 02:14 EDT by zic
Modified: 2012-09-03 04:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 04:28:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-01 02:14 EDT, zic
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-01 02:14 EDT, zic
no flags Details

  None (edit)
Description zic 2012-09-01 02:14:11 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.5.2-3.fc17.x86_64

description:
:SELinux is preventing /usr/libexec/colord from 'read' accesses on the file /home/Mykene/zic/.local/share/icc/edid-978c128ec1811e998a65d299335a899d.icc.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that colord should be allowed read access on the edid-978c128ec1811e998a65d299335a899d.icc file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gdbus /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:colord_t:s0
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                /home/Mykene/zic/.local/share/icc/edid-
:                              978c128ec1811e998a65d299335a899d.icc [ file ]
:Source                        gdbus
:Source Path                   /usr/libexec/colord
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           colord-0.1.21-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-146.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.2-3.fc17.x86_64 #1 SMP Tue Aug
:                              21 19:06:52 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    2012-08-31 03:54:41 JST
:Last Seen                     2012-09-01 15:11:30 JST
:Local ID                      21c36645-9d88-40e9-b25a-e98f956dc6a0
:
:Raw Audit Messages
:type=AVC msg=audit(1346479890.735:115): avc:  denied  { read } for  pid=4568 comm="gdbus" path="/home/Mykene/zic/.local/share/icc/edid-978c128ec1811e998a65d299335a899d.icc" dev="md87" ino=1311346 scontext=system_u:system_r:colord_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1346479890.735:115): arch=x86_64 syscall=recvmsg success=yes exit=EBUSY a0=8 a1=7fd618d94b60 a2=40000000 a3=0 items=0 ppid=1 pid=4568 auid=4294967295 uid=996 gid=994 euid=996 suid=996 fsuid=996 egid=994 sgid=994 fsgid=994 tty=(none) ses=4294967295 comm=gdbus exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0 key=(null)
:
:Hash: gdbus,colord_t,user_home_t,file,read
:
:audit2allow
:
:#============= colord_t ==============
:allow colord_t user_home_t:file read;
:
:audit2allow -R
:
:#============= colord_t ==============
:allow colord_t user_home_t:file read;
:
Comment 1 zic 2012-09-01 02:14:15 EDT
Created attachment 608764 [details]
File: type
Comment 2 zic 2012-09-01 02:14:16 EDT
Created attachment 608765 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-03 04:28:46 EDT
You will need to tell SELinux how to label you homedir structure using

# semanage fcontext -a -e /home /home/Mykene
# restorecon -R -v /home/Mykene

Then you get the right labeling.
Comment 4 Miroslav Grepl 2012-09-03 04:29:00 EDT
*** Bug 853603 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.