This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 853603 - SELinux is preventing /usr/libexec/gdm-session-worker from 'setattr' accesses on the file /home/Mykene/zic/.xsession-errors.
SELinux is preventing /usr/libexec/gdm-session-worker from 'setattr' accesses...
Status: CLOSED DUPLICATE of bug 853592
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3329feb12e9408a51f9f75be350...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-01 03:01 EDT by zic
Modified: 2012-09-03 04:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 04:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-01 03:01 EDT, zic
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-01 03:01 EDT, zic
no flags Details

  None (edit)
Description zic 2012-09-01 03:01:44 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.5.2-3.fc17.x86_64

description:
:SELinux is preventing /usr/libexec/gdm-session-worker from 'setattr' accesses on the file /home/Mykene/zic/.xsession-errors.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gdm-session-worker should be allowed setattr access on the .xsession-errors file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gdm-session-wor /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:user_home_t:s0
:Target Objects                /home/Mykene/zic/.xsession-errors [ file ]
:Source                        gdm-session-wor
:Source Path                   /usr/libexec/gdm-session-worker
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gdm-3.4.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-146.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.2-3.fc17.x86_64 #1 SMP Tue Aug
:                              21 19:06:52 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    2012-08-31 03:54:38 JST
:Last Seen                     2012-09-01 15:11:26 JST
:Local ID                      132b72f1-ae81-4775-a956-39843fccf81a
:
:Raw Audit Messages
:type=AVC msg=audit(1346479886.459:113): avc:  denied  { setattr } for  pid=4616 comm="gdm-session-wor" name=".xsession-errors" dev="md87" ino=1310721 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1346479886.459:113): arch=x86_64 syscall=fchmod success=yes exit=0 a0=e a1=180 a2=e a3=726f7272652d6e6f items=0 ppid=4065 pid=4616 auid=1001 uid=1001 gid=1001 euid=1001 suid=1001 fsuid=1001 egid=1001 sgid=1001 fsgid=1001 tty=(none) ses=4 comm=gdm-session-wor exe=/usr/libexec/gdm-session-worker subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gdm-session-wor,xdm_t,user_home_t,file,setattr
:
:audit2allow
:
:#============= xdm_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_t user_home_t:file setattr;
:
:audit2allow -R
:
:#============= xdm_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_t user_home_t:file setattr;
:
Comment 1 zic 2012-09-01 03:01:47 EDT
Created attachment 608769 [details]
File: type
Comment 2 zic 2012-09-01 03:01:49 EDT
Created attachment 608770 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-03 04:29:00 EDT

*** This bug has been marked as a duplicate of bug 853592 ***

Note You need to log in before you can comment on or make changes to this bug.