This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 853617 - SELinux is preventing /usr/bin/systemd-tmpfiles from 'read' accesses on the file /etc/nsswitch.conf.
SELinux is preventing /usr/bin/systemd-tmpfiles from 'read' accesses on the f...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:338702a163fe63c490c27b4553b...
:
: 853618 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-01 06:49 EDT by Luya Tshimbalanga
Modified: 2012-09-03 04:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 04:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-01 06:49 EDT, Luya Tshimbalanga
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-01 06:49 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2012-09-01 06:49:39 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64

description:
:SELinux is preventing /usr/bin/systemd-tmpfiles from 'read' accesses on the file /etc/nsswitch.conf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-tmpfiles should be allowed read access on the nsswitch.conf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_tmpfiles_t:s0
:Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
:Target Objects                /etc/nsswitch.conf [ file ]
:Source                        systemd-tmpfile
:Source Path                   /usr/bin/systemd-tmpfiles
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-188-3.fc18.x86_64
:Target RPM Packages           glibc-2.16-8.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-14.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc2.git2.1.fc18.x86_64 #1
:                              SMP Wed Aug 22 11:54:04 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    2012-09-01 03:47:47 EDT
:Last Seen                     2012-09-01 03:47:47 EDT
:Local ID                      48f612d4-2f0f-4b58-941a-5fdcfc1fdee4
:
:Raw Audit Messages
:type=AVC msg=audit(1346485667.717:418): avc:  denied  { read } for  pid=3026 comm="systemd-tmpfile" name="nsswitch.conf" dev="dm-1" ino=2490725 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1346485667.717:418): arch=x86_64 syscall=open success=no exit=EACCES a0=7f495a17a3d2 a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=3026 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-tmpfile exe=/usr/bin/systemd-tmpfiles subj=system_u:system_r:systemd_tmpfiles_t:s0 key=(null)
:
:Hash: systemd-tmpfile,systemd_tmpfiles_t,system_dbusd_var_lib_t,file,read
:
:audit2allow
:
:#============= systemd_tmpfiles_t ==============
:allow systemd_tmpfiles_t system_dbusd_var_lib_t:file read;
:
:audit2allow -R
:
:#============= systemd_tmpfiles_t ==============
:allow systemd_tmpfiles_t system_dbusd_var_lib_t:file read;
:
Comment 1 Luya Tshimbalanga 2012-09-01 06:49:41 EDT
Created attachment 608806 [details]
File: type
Comment 2 Luya Tshimbalanga 2012-09-01 06:49:43 EDT
Created attachment 608807 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-03 04:35:58 EDT
/etc/nsswitch.conf is mislabeled. Is this a fresh install or did you upgrade from F17?

# restorecon -R -v /etc/nsswitch.conf

will fix this issue.

Maybe you could try to run

# fixfiles check

to see if another labels are bad.
Comment 4 Miroslav Grepl 2012-09-03 04:36:11 EDT
*** Bug 853618 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.