Bug 853618 - SELinux is preventing /usr/bin/dbus-daemon from 'read' accesses on the file /etc/nsswitch.conf.
SELinux is preventing /usr/bin/dbus-daemon from 'read' accesses on the file /...
Status: CLOSED DUPLICATE of bug 853617
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:712d552a5c2c05f5300a1102daa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-01 06:51 EDT by Luya Tshimbalanga
Modified: 2012-09-03 04:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 04:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-01 06:51 EDT, Luya Tshimbalanga
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-01 06:51 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2012-09-01 06:51:13 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64

description:
:SELinux is preventing /usr/bin/dbus-daemon from 'read' accesses on the file /etc/nsswitch.conf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that dbus-daemon should be allowed read access on the nsswitch.conf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:system_dbusd_var_lib_t:s0
:Target Objects                /etc/nsswitch.conf [ file ]
:Source                        dbus-daemon
:Source Path                   /usr/bin/dbus-daemon
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           dbus-1.6.0-2.fc18.x86_64
:Target RPM Packages           glibc-2.16-8.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-14.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc2.git2.1.fc18.x86_64 #1
:                              SMP Wed Aug 22 11:54:04 UTC 2012 x86_64 x86_64
:Alert Count                   5
:First Seen                    2012-09-01 03:33:50 EDT
:Last Seen                     2012-09-01 03:33:50 EDT
:Local ID                      e8fab414-b1cf-4604-834f-5467e0a9bff3
:
:Raw Audit Messages
:type=AVC msg=audit(1346484830.980:106): avc:  denied  { read } for  pid=705 comm="dbus-daemon" name="nsswitch.conf" dev="dm-1" ino=2490725 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1346484830.980:106): arch=x86_64 syscall=open success=no exit=EACCES a0=3dc8b783d2 a1=80000 a2=1b6 a3=238 items=0 ppid=704 pid=705 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm=dbus-daemon exe=/usr/bin/dbus-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: dbus-daemon,xdm_dbusd_t,system_dbusd_var_lib_t,file,read
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:allow xdm_dbusd_t system_dbusd_var_lib_t:file read;
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:allow xdm_dbusd_t system_dbusd_var_lib_t:file read;
:
Comment 1 Luya Tshimbalanga 2012-09-01 06:51:15 EDT
Created attachment 608808 [details]
File: type
Comment 2 Luya Tshimbalanga 2012-09-01 06:51:17 EDT
Created attachment 608809 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-03 04:36:11 EDT

*** This bug has been marked as a duplicate of bug 853617 ***

Note You need to log in before you can comment on or make changes to this bug.