Bug 853699 - Please update F17 to gcc-4.7.1 to fix firefox
Please update F17 to gcc-4.7.1 to fix firefox
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 830017
  Show dependency treegraph
 
Reported: 2012-09-02 04:44 EDT by drago01
Modified: 2012-09-26 05:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 05:09:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2012-09-02 04:44:44 EDT
Webgl in firefox is currently broken because it got built with gcc 4.7.0 (See: 
https://bugzilla.redhat.com/show_bug.cgi?id=830017 and https://bugzilla.mozilla.org/show_bug.cgi?id=736477)
According to https://bugzilla.redhat.com/show_bug.cgi?id=830017#c8 building firefox with gcc 4.7.1 does fix the issue. Currently F17 still ships 4.7.0 in updates (and thus in the buildroot) even though 4.7.1 has been already build in koji (http://koji.fedoraproject.org/koji/buildinfo?buildID=328320).

Please push this to F17 (updates-testing and if there are no issues updates) so that a fixed firefox can be built.
Comment 1 drago01 2012-09-02 05:22:16 EDT
I can confirm that rebuilding xulrunner with gcc-4.7.1-1.fc17.x86_64 fixes the issue.
Comment 2 Martin Stransky 2012-09-20 10:12:44 EDT
Jakub, any update here? This bug breaks Firefox WebGl support.
Comment 3 Fedora Update System 2012-09-24 11:30:43 EDT
gcc-4.7.2-2.fc17,libtool-2.4.2-3.1.fc17,gcc-python-plugin-0.9-4.1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gcc-4.7.2-2.fc17,libtool-2.4.2-3.1.fc17,gcc-python-plugin-0.9-4.1.fc17
Comment 4 Fedora Update System 2012-09-25 00:24:34 EDT
Package gcc-4.7.2-2.fc17, libtool-2.4.2-3.1.fc17, gcc-python-plugin-0.9-4.1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcc-4.7.2-2.fc17 libtool-2.4.2-3.1.fc17 gcc-python-plugin-0.9-4.1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14724/gcc-4.7.2-2.fc17,libtool-2.4.2-3.1.fc17,gcc-python-plugin-0.9-4.1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-26 05:09:54 EDT
gcc-4.7.2-2.fc17, libtool-2.4.2-3.1.fc17, gcc-python-plugin-0.9-4.1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Martin Stransky 2012-09-26 05:47:01 EDT
To take effect the gcc has to be submitted for build root override, right?
Comment 7 drago01 2012-09-26 05:58:19 EDT
(In reply to comment #6)
> To take effect the gcc has to be submitted for build root override, right?

No, if it is stable it is in the build root.

Note You need to log in before you can comment on or make changes to this bug.