Bug 830017 - webGL not working firefox 12, 13, 14, 15
webGL not working firefox 12, 13, 14, 15
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On: 853699
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 22:21 EDT by Piruthiviraj Natarajan
Modified: 2012-10-30 07:59 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 07:59:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piruthiviraj Natarajan 2012-06-07 22:21:28 EDT
Description of problem:

WebGL not working properly in Firefox 12.0 (blank screen, artifacts, ecc...).
Works very well in official Mozilla build.
(ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/12.0/linux-x86_64/)
Version-Release number of selected component (if applicable):

Test:
http://helloracer.com/webgl/
http://chrome.angrybirds.com/
How reproducible:
everytime
Comment 1 Piruthiviraj Natarajan 2012-06-07 22:25:03 EDT
(In reply to comment #0)
> Description of problem:
> 
> WebGL not working properly in Firefox 12.0 (blank screen, artifacts, ecc...).
> Works very well in official Mozilla build.
> (ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/12.0/linux-x86_64/)
> Version-Release number of selected component (if applicable):
> 
> Test:
> http://helloracer.com/webgl/
> http://chrome.angrybirds.com/
> How reproducible:
> everytime

Firefox 13 has the same results too.
Comment 2 Martin Stransky 2012-06-08 02:12:16 EDT
It works as expeced on F15, seems to be F17 regression.
Comment 3 Piruthiviraj Natarajan 2012-06-08 02:29:51 EDT
If you build with GCC 4.6.3  everything works alright.
Comment 4 Terry Wallwork 2012-06-20 11:47:21 EDT
I also cannot get webgl sites such:

www.sketchfab.com
www.p3d.in

etc

To display 3D webgl content when using Fedora 17 with Firefox 13 that is shipped with Fedora.

Fedora 16 worked fine, just not F17.

Not sure what information I need to supply, so if you know let me know and I will supply it.

I am on a Toshiba C670D laptop and it has an HD3000 INTEL graphics chip set.
Comment 5 Piruthiviraj Natarajan 2012-06-20 12:37:55 EDT
It is something to do with GCC 4.7.
Comment 6 Yajo 2012-06-27 15:25:46 EDT
Same problems here. Interestingly I found that running FF in safe mode makes WebGL magically work. However, doing it with an empty profile does not work.

Relevant info from about:support:


  Configuración básica de la aplicación

        Nombre
        Firefox

        Versión
        13.0.1

        Agente de usuario
        Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1

  Gráficos

        Descripción del adaptador
        NVIDIA Corporation -- GeForce 8400M GS/PCIe/SSE2

        ID del fabricante
        NVIDIA Corporation

        ID del dispositivo
        GeForce 8400M GS/PCIe/SSE2

        Versión del controlador
        3.3.0 NVIDIA 295.59

        Renderizador WebGL
        NVIDIA Corporation -- GeForce 8400M GS/PCIe/SSE2 -- 3.3.0 NVIDIA 295.59

        Ventanas aceleradas mediante GPU
        0

        AzureBackend
        skia

  JavaScript

        Recogida de basura incremental
        1

  Versiones de bibliotecas

        Versión mínima esperada

        Versión en uso

        NSPR
        4.9
        4.9

        NSS
        3.13.4.0
        3.13.4.0

        NSS Util
        3.13.4.0
        3.13.4.0

        NSS SSL
        3.13.4.0
        3.13.4.0

        NSS S/MIME
        3.13.4.0
        3.13.4.0
Comment 7 Yajo 2012-06-27 15:27:25 EDT
Oh, and also this:

about:buildconfig
Build Machine

x86-06
Build platform
target
x86_64-unknown-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.7.0 20120507 (Red Hat 4.7.0-5) (GCC) 	-pedantic -Wall -W -Wno-unused -Wpointer-arith -Wdeclaration-after-statement -Wcast-align -W -Wno-long-long -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fno-exceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fpermissive -gdwarf-2 -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer
c++ 	gcc version 4.7.0 20120507 (Red Hat 4.7.0-5) (GCC) 	-fno-rtti -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fno-exceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fpermissive -gdwarf-2 -fno-exceptions -fno-strict-aliasing -std=gnu++0x -ffunction-sections -fdata-sections -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer
Configure arguments

--enable-application=xulrunner --prefix=/usr --libdir=/usr/lib64 --with-system-jpeg --with-system-zlib --with-system-bz2 --with-system-libvpx --enable-system-hunspell --with-pthreads --disable-strip --disable-tests --disable-mochitest --disable-installer --enable-xinerama --enable-default-toolkit=cairo-gtk2 --enable-pango --enable-svg --enable-canvas --disable-javaxpcom --disable-crashreporter --enable-safe-browsing --enable-extensions=default --enable-libnotify --disable-necko-wifi --enable-startup-notification --disable-cpp-exceptions --enable-shared-js --enable-url-classifier --enable-gio --disable-gnomevfs --disable-updater --enable-chrome-format=omni --enable-crashreporter --with-system-nspr --with-system-nss --disable-system-sqlite --disable-system-cairo --disable-debug --enable-optimize
Comment 8 TheDuke 2012-07-16 05:08:32 EDT
Firefox bug 736477 https://bugzilla.mozilla.org/show_bug.cgi?id=736477
It seems to be a problem with GCC 4.7.0 and fixed when firefox is compiled with GCC 4.7.1
Comment 9 Piruthiviraj Natarajan 2012-08-01 11:08:55 EDT
I use arch linux too, had similar issue but then building with GCC 4.6.3 solved the issue. But building with 4.7.1 in arch linux partially solved the issue. Anyone using rawhide to test whether firefox built with GCC 4.7.1-5 resolves the issue?
Comment 10 Piruthiviraj Natarajan 2012-08-30 13:34:42 EDT
Firefox 15 doesn't resolve the issue too.
Comment 11 drago01 2012-09-02 05:22:21 EDT
I can confirm that rebuilding xulrunner with gcc-4.7.1-1.fc17.x86_64 fixes the issue.
Comment 12 drago01 2012-09-02 05:29:26 EDT
Here is the xulrunner build for others to try: http://94.247.144.115/files/xulrunner-15.0-2.fc17.x86_64.rpm

(install with rpm -Uhv --force xulrunner-15.0-2.fc17.x86_64.rpm)
Comment 13 Piruthiviraj Natarajan 2012-09-02 06:27:50 EDT
Thanks for the build. I was hoping for a official build. But it doesn't look like they care.
Comment 14 drago01 2012-09-02 06:32:46 EDT
(In reply to comment #13)
> Thanks for the build. I was hoping for a official build. But it doesn't look
> like they care.

I have opened bug 853699 (which this bug now depends on) asking for the gcc update to get pushed. Once this is done getting firefox fixed is a matter of rebuilding xulrunner.

The bug has just been filed today so saying "they don't care" isn't really fair nor appropriate.
Comment 15 Piruthiviraj Natarajan 2012-09-02 06:47:14 EDT
This bug report I did, is sitting here for 2 months. Everyone knew that if you built firefox with a newer GCC fixes the issue. I was expecting that some of the firefox maintainers would care and do a firefox build on the 4.7.1 GCC. They never did build nor did they care to explain why they didn't. Atleast if they said they didn't have the time, I would be been satisfied, becoz not everyone at fedora works on a salary, I understand that.
Comment 16 Piruthiviraj Natarajan 2012-09-02 06:51:35 EDT
I was not asking for me, expecting someone to build it for me. I knew all along how to get this thing work. I was expecting If I file the bug report, some of the maintainers would notice and work on it to fix the issue, so that the community could benefit.
Comment 17 drago01 2012-09-02 07:12:11 EDT
(In reply to comment #15)
> This bug report I did, is sitting here for 2 months. Everyone knew that if
> you built firefox with a newer GCC fixes the issue. I was expecting that
> some of the firefox maintainers would care and do a firefox build on the
> 4.7.1 GCC. They never did build nor did they care to explain why they
> didn't. Atleast if they said they didn't have the time, I would be been
> satisfied, becoz not everyone at fedora works on a salary, I understand that.

I understand your frustration but that's not how the fedora infrastructure work, sorry. You can't just submit builds to the system but you have build them on the fedora buildsystem with the packages currently in the build root (which pretty much is what currently ships in that release + updates). So in order to get a firefox build with GCC 4.7.1 the new gcc has to be build and pushed first. Hence why I filed a bug against gcc to get this done.

So the firefox maintainers could not do more other then asking the gcc maintainers for a fixed / updated gcc or you (or anyone else) could have done that. Anyway lets just stop the blame game and try to get things fixed.
Comment 18 Martin Stransky 2012-09-03 09:06:26 EDT
Sorry for the delay here. I haven't seen many people to complain about it so it's the reason the bug has been left behind a bit.
Comment 19 Taryn Fox 2012-09-25 07:23:13 EDT
Please fix this bug.
Comment 20 Piruthiviraj Natarajan 2012-09-25 10:57:43 EDT
It most probably would be fixed by next firefox release. drago01 and myself added karma to the next GCC update, so that gcc could move to updates, so that firefox could be built with gcc 4.7.2-2.
Comment 21 drago01 2012-10-07 04:34:12 EDT
There is a fixed build: http://koji.fedoraproject.org/koji/buildinfo?buildID=356740 

But no update has been filed in bodhi ... Martin any reason for that?
Comment 22 Jan Horak 2012-10-08 05:29:25 EDT
We're expecting security update to Firefox 16 tomorrow. Update  and karma process takes some time so we decided to have this fix as part of tomorrow's update to avoid concurrency problems with bodhi which we suffered once. Expect fixed version tomorrow.
Comment 23 drago01 2012-10-12 16:57:02 EDT
(In reply to comment #22)
> We're expecting security update to Firefox 16 tomorrow. Update  and karma
> process takes some time so we decided to have this fix as part of tomorrow's
> update to avoid concurrency problems with bodhi which we suffered once.
> Expect fixed version tomorrow.

This one got pushed, so we can close this bug now.
Comment 24 Piruthiviraj Natarajan 2012-10-13 02:11:24 EDT
The new update FF 16.0.1-1 fixes the bug.
Comment 25 Yajo 2012-10-26 15:30:30 EDT
I tested it. Fixed in firefox-16.0.1-1.fc17.x86_64.
Comment 26 Martin Stransky 2012-10-30 07:59:46 EDT
Thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.