Bug 854380 - "Have no overlap with existing subscriptions" Filter Functionality Change for Stacking/Partially Subscribed
"Have no overlap with existing subscriptions" Filter Functionality Change for...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carter Kozak
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2012-09-04 16:22 EDT by Matt Reid
Modified: 2014-09-14 20:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 18:49:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-09-04 16:22:18 EDT
Description of problem:
If you partially subscribe, but need additional subscriptions to fully cover your socket count, when you go back to the All Available Subscriptions tab to attach more, you have to remove a filter option to get any of them to show. I don't think we should consider those subscriptions as overlapping if their system is currently in a partially subscribed state. Once they are green and fully subscribed, I'd consider them overlapping, but not before.

Version-Release number of selected component (if applicable):
1.0.17-1

How reproducible:
Always

Steps to Reproduce:
1. Register to stage
2. Override socket count
3. Partially subscribe
4. Close Sub-man-gui
5. Re-open sub-man-gui and go to All Available Subscriptions tab, click update
  
Actual results:
Table shows "No subscriptions match current filters."

Expected results:
Table should show subscriptions that could stack with your attached subscription(s) so that they can easily become green.

Currently, they must have the "Have no overlap with existing subscriptions" option (which defaults to being enabled) unchecked before they will see these subscriptions.

Additional info:
Comment 1 RHEL Product and Program Management 2013-05-08 10:38:59 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Carter Kozak 2013-06-10 10:33:46 EDT
commit 14d829957f2f4fe579a72cb9b4f2b8325a513435
Author: ckozak <ckozak@redhat.com>
Date:   Fri Jun 7 11:53:33 2013 -0400

    854380: fix overlap filter
Comment 4 John Sefler 2013-07-02 18:33:04 EDT
Verifying Version...
[root@jsefler-5 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.8.11-1.el5

The fix appears to be working for me, but would like a second opinion.
Comment 5 J.C. Molet 2013-07-03 12:09:38 EDT
I could not test this in stage due to stage issues, but against stand alone i was able to get this working with the test product "Multi-Attribute Limited Product".  With 8 sockets, I attached to the socket subscription for this until I was completely covered.  Only then did the filter not show that subscription.

I was using subscription-manager-gui-1.8.11-1.el5 , the latest package in brew.
Comment 7 errata-xmlrpc 2013-09-30 18:49:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.