Bug 854490 - ovirt-engine-cli : RFE : Add option to see the current VM snapshot when when using list snapshot command
ovirt-engine-cli : RFE : Add option to see the current VM snapshot when when ...
Status: CLOSED DUPLICATE of bug 854047
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Michael Pasternak
Oded Ramraz
storage
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 03:29 EDT by Oded Ramraz
Modified: 2016-02-10 15:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 05:46:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-09-05 03:29:50 EDT
Description of problem:

Please add option to see the current VM snapshot when using list snapshot command .
We had this option in the past as well , and Rest also show it by default ( see Additional Information ) 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

## Rest API

snapshots>
<snapshot href="/api/vms/050b6b91-771c-4674-b994-029380a03f1c/snapshots/008eb853-d908-413c-9401-38f7b5ad22df" id="008eb853-d908-413c-9401-38f7b5ad22df"><actions><link href="/api/vms/050b6b91-771c-4674-b994-029380a03f1c/snapshots/008eb853-d908-413c-9401-38f7b5ad22df/restore" rel="restore"/></actions><description>Active VM</description><type>active</type><date>2012-09-02T10:10:01.947+03:00</date><snapshot_status>ok</snapshot_status></snapshot>
</snapshots>


## Trying to retrieve same VM snapshots using CLI

[RHEVM shell (connected)]# list snapshots --vm-identifier fire-rh1 
[RHEVM shell (connected)]#
Comment 2 Michael Pasternak 2012-09-05 05:10:41 EDT
cli shows all properties api resources has, please see 'list' command 
documentation, the default mode of shown items is 'reduced', use --show-all
flag to see items in 'expended' mode (all properties will be displayed)
Comment 3 Oded Ramraz 2012-09-05 05:17:09 EDT
Thanks for the tip , I tried to use --show-all parameter and it still not working:

## Here I'm trying to use list --show-all parameter 

[RHEVM shell (connected)]# list snapshots --vm-identifier fire-rh1 --show-all

[RHEVM shell (connected)]# 


## using show command does not work as well: 

## here the error is about missing snapshot , while it should be about the VM

[RHEVM shell (connected)]# show snapshot --vm-identifier fire-rh1


error: snapshot "['fire-rh1']" does not exist.


[RHEVM shell (connected)]# show snapshot --vm-identifier 050b6b91-771c-4674-b994-029380a03f1c
error: syntax error


Please note that snapshots are not independent , they should be retrieved in VM context
Comment 4 Oded Ramraz 2012-09-05 05:46:13 EDT

*** This bug has been marked as a duplicate of bug 854047 ***

Note You need to log in before you can comment on or make changes to this bug.