Bug 854047 - [ovirt-shell] subcollection are not listed not shown
[ovirt-shell] subcollection are not listed not shown
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.1.0
Assigned To: Michael Pasternak
Ilia Meerovich
infra
: Regression
: 854490 854495 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 14:32 EDT by Simon Grinberg
Modified: 2016-02-10 14:00 EST (History)
9 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:57:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Grinberg 2012-09-03 14:32:34 EDT
Description of problem:

All subcollection can't be listed nor retrieved from the shell.

The below storage domains can be listed: 
[RHEVM shell (connected)]# list storagedomains

id         : ec03d391-6ca9-4415-bf3c-79bf475a56fe
name       : ISO_DOMAIN

id         : 47a3add2-cecd-444a-9be1-58c9fec40f63
name       : myImageStore

Those are attached to the default DC (seen both from GUI and /api

However they can't be retrieved from the datacenter scope

[RHEVM shell (connected)]# list storagedomains --datacenter-identifier Default 
Returns nothing 

And 

[RHEVM shell (connected)]# show storagedomain myImageStore --datacenter-identifier Default

Returns:
error: storagedomain "myImageStore" does not exist.



Same goes for any other subcollection like nics, statistics, etc. 


Version:
SI16 - rhevm-cli-3.1.0.10-1.el6ev.noarch
Comment 4 Oded Ramraz 2012-09-05 05:46:13 EDT
*** Bug 854490 has been marked as a duplicate of this bug. ***
Comment 5 Oded Ramraz 2012-09-05 06:03:55 EDT
*** Bug 854495 has been marked as a duplicate of this bug. ***
Comment 6 Ilia Meerovich 2012-09-05 08:07:46 EDT
[imeerovi@imeerovi ART]$ rhevm-shell -l "https://aqua-rhel.qa.lab.tlv.redhat.com:443/api/" -u "vdcadmin@qa.lab.tlv.redhat.com" -p "123456" -I 








 ==========================================
 >>> connected to RHEVM manager 3.1.0.0 <<<
 ==========================================


        
 ++++++++++++++++++++++++++++++++++++++++++
 
           Welcome to RHEVM shell
 
 ++++++++++++++++++++++++++++++++++++++++++
        
    
[RHEVM shell (connected)]# list storagedomains --datacenter-identifier DefaultRest

id         : 6a8e18d6-b3ef-417a-acee-6164c8c389d2
name       : test

[RHEVM shell (connected)]# show storagedomain --name test

id             : 6a8e18d6-b3ef-417a-acee-6164c8c389d2
name           : test
available      : 887984488448
committed      : 0
master         : True
storage-address: multipass.eng.lab.tlv.redhat.com
storage-path   : /export/images/qa/aqua_rest/nas2
storage-type   : nfs
storage_format : v3
type           : data
used           : 431644213248

[RHEVM shell (connected)]# show storagedomain test --datacenter-identifier DefaultRest

id             : 6a8e18d6-b3ef-417a-acee-6164c8c389d2
name           : test
available      : 887984488448
committed      : 0
data_center-id : 894c498c-40cb-48da-8b42-c087e45fe0f7
master         : True
status-state   : active
storage-address: multipass.eng.lab.tlv.redhat.com
storage-path   : /export/images/qa/aqua_rest/nas2
storage-type   : nfs
storage_format : v3
type           : data
used           : 431644213248

[RHEVM shell (connected)]#

Note You need to log in before you can comment on or make changes to this bug.