Bug 854495 - ovirt-engine-cli : Problem to retrieve objects statistics
ovirt-engine-cli : Problem to retrieve objects statistics
Status: CLOSED DUPLICATE of bug 854047
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michael Pasternak
Oded Ramraz
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 03:48 EDT by Oded Ramraz
Modified: 2016-02-10 14:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 06:02:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-09-05 03:48:57 EDT
Description of problem:

When trying to retrieve hosts statistics , I'm getting empty results . 
Trying to do the same using Rest API succeed . 




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

## CLI

[RHEVM shell (connected)]# list statistics --host-identifier Puma32

[RHEVM shell (connected)]# list statistics --host-identifier puma31


list statistics --host-identifier d3560912-f2ad-11e1-8f5f-001a4a169798

## Rest 

statistics><statistic href="/api/hosts/d3560912-f2ad-11e1-8f5f-001a4a169798/statistics/7816602b-c05c-3db7-a4da-3769f7ad8896" id="7816602b-c05c-3db7-a4da-3769f7ad8896"><name>memory.total</name><description>Total memory</description><values type="INTEGER"><value><datum>33658241024</datum></value></values><type>GAUGE</type><unit>BYTES</unit><host href="/api/hosts/d3560912-f2ad-11e1-8f5f-001a4a169798" id="d3560912-f2ad-11e1-8f5f-001a4a169798"/></statistic><statistic href="/api/hosts/d3560912-f2ad-11e1-8f5f-001a4a169798/statistics/b7499508-c1c3-32f0-8174-c1783e57bb08" id="b7499508-c1c3-32f0-8174-c1783e57bb08"><name>memory.used</name><description>Used memory</description><values type="INTEGER"><value><datum>1682912051</datum></value></values><type>GAUGE</type><unit>BYTES</unit><host href="/api/hosts/d3560912-f2ad-11e1-8f5f-001a4a169798" id="d3560912-f2ad-11e1-8f5f-001a4a169798"/></statistic><statistic href="/api/hosts/d3560912-f2ad-11e1-8f5f-001a4a169798/statistics/5a0fba9d-33d7-3cbf-addd-ba462040c946" id="5a0fba9d-33d7-3cbf-addd-ba462040c946"><name>memory.free</name><description>Free memory</description><values type="INTEGER"><value><datum>31975328973</datum></value></values><type>GAUGE</type><unit>BYTES</unit><host href="/api/hosts/d3560912-f2ad-11e1-8f5f-001a4a169798" id="d3560912-f2ad-11e1-8f5f-001a4a169798"/></statistic><statistic href="/api/hosts/d3560912-f2ad-11e1-8f5f-001a4a169798/statistics/ffc0e1fd-fa34-3f85-9862-8a841c1658bc" id="ffc0e1fd-fa34-3f85-9862-8a841c1658bc"><name>memory.shared</name><description>Shared memory</description><values type="INTEGER"><value><datum>0</datum>
Comment 1 Oded Ramraz 2012-09-05 04:03:46 EDT
[RHEVM shell (connected)]# list hosts

id         : 398b1cbc-f5b6-11e1-85c7-001a4a169798
name       : puma31

id         : d3560912-f2ad-11e1-8f5f-001a4a169798
name       : Puma32

[RHEVM shell (connected)]# show statistic --host-identifier puma31


error: statistic "['puma31']" does not exist.


[RHEVM shell (connected)]# show statistic --host-identifier 398b1cbc-f5b6-11e1-85c7-001a4a169798
error: syntax error
Comment 2 Michael Pasternak 2012-09-05 06:02:44 EDT
[oVirt shell (connected)]# list statistics --host-identifier grey-vds
id         : c81c86f0-bc61-3c78-a543-898b8339d03f
name       : memory.buffers
description: IO buffers

id         : 1b6244ee-8dbd-365d-8762-482ddc05ee11
name       : memory.cached
description: OS caches

id         : c43847d7-3bc1-3aaf-b92c-902e64bbdb5b
name       : swap.total
description: Total swap

id         : 1a4c1c9b-f3cc-301e-82ce-47d4b9fb5a46
name       : swap.free
description: Free swap

you could not see subcollections cause you used 3.1.0.10 cli
with https://bugzilla.redhat.com/show_bug.cgi?id=854047
Comment 3 Michael Pasternak 2012-09-05 06:03:35 EDT
tested on cli 3.1.0.12 from si16.2
Comment 4 Oded Ramraz 2012-09-05 06:03:55 EDT

*** This bug has been marked as a duplicate of bug 854047 ***

Note You need to log in before you can comment on or make changes to this bug.