Bug 854620 - AVCs when running lvmetad test with disabled unconfined and unlabelednet
AVCs when running lvmetad test with disabled unconfined and unlabelednet
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.4
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Michal Trunecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 08:59 EDT by Michal Trunecka
Modified: 2014-09-30 19:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-162.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:28:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Trunecka 2012-09-05 08:59:02 EDT
Description of problem:
When unconfined and unlabelednet modules are disabled, running automated test of lvmetad FAILes and causes AVCs. AVCs caused by test in permissive mode is listed below. The test PASSed with no AVCs with both mentioned modules enabled.

----
time->Wed Sep  5 14:53:17 2012
type=SYSCALL msg=audit(1346849597.163:29955): arch=c000003e syscall=49 success=yes exit=0 a0=4 a1=7fff2d04f090 a2=6e a3=ffffffff items=0 ppid=2827 pid=2828 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=6 comm="lvmetad" exe="/sbin/lvmetad" subj=system_u:system_r:lvm_t:s0 key=(null)
type=AVC msg=audit(1346849597.163:29955): avc:  denied  { create } for  pid=2828 comm="lvmetad" name="lvmetad.socket" scontext=system_u:system_r:lvm_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file
----
time->Wed Sep  5 14:53:19 2012
type=SYSCALL msg=audit(1346849599.297:29960): arch=c000003e syscall=87 success=yes exit=0 a0=406269 a1=7fff2d04ef80 a2=0 a3=0 items=0 ppid=1 pid=2828 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=6 comm="lvmetad" exe="/sbin/lvmetad" subj=system_u:system_r:lvm_t:s0 key=(null)
type=AVC msg=audit(1346849599.297:29960): avc:  denied  { unlink } for  pid=2828 comm="lvmetad" name="lvmetad.socket" dev=sda3 ino=25177 scontext=system_u:system_r:lvm_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file
----
time->Wed Sep  5 14:53:19 2012
type=SYSCALL msg=audit(1346849599.561:29961): arch=c000003e syscall=49 success=yes exit=0 a0=4 a1=7fffa25c8b20 a2=6e a3=ffffffff items=0 ppid=2879 pid=2880 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=6 comm="lvmetad" exe="/sbin/lvmetad" subj=system_u:system_r:lvm_t:s0 key=(null)
type=AVC msg=audit(1346849599.561:29961): avc:  denied  { create } for  pid=2880 comm="lvmetad" name="lvmetad.socket" scontext=system_u:system_r:lvm_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file


Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-155.el6_3.noarch
selinux-policy-targeted-3.7.19-155.el6_3.noarch
lvm2-2.02.97-2.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. semodule -d unconfined; semodule -d unlabelednet
2. Run following automated test 
/CoreOS/selinux-policy/Regression/bz810273-lvmetad-and-similar
  
Actual results:
Test FAILed and AVC showed up

Expected results:
Test PASSes with no AVC
Comment 2 Miroslav Grepl 2012-09-06 01:17:09 EDT
Michal,
where is the socket located? 


We are missing

/var/run/lvm(/.*)?     gen_context(system_u:object_r:lvm_var_run_t,s0)

on RHEL6.
Comment 3 Michal Trunecka 2012-09-06 03:18:18 EDT
The socket is in its default location /var/run/lvm/lvmetad.socket. The location can be changed by environment variable LVM_LVMETAD_SOCKET, though.
Comment 4 Daniel Walsh 2012-09-06 16:57:13 EDT
Yes we need that.  We want the default labeling correct, if admin change the locations, they are responsible to change the labels.
Comment 8 errata-xmlrpc 2013-02-21 03:28:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.