Bug 854645 - Reports Portal Link doesn't work (Remote DB Setup)
Reports Portal Link doesn't work (Remote DB Setup)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Juan Hernández
David Botzer
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 09:41 EDT by David Botzer
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Portal-Link (48.57 KB, application/x-gzip)
2012-09-05 09:41 EDT, David Botzer
no flags Details
report-link (238.53 KB, application/x-gzip)
2012-09-16 04:46 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-09-05 09:41:37 EDT
Created attachment 610056 [details]
Portal-Link

Description of problem:
The Link to the Reports Portal doesnt work, in remote db setup

Version-Release number of selected component (if applicable):
3.1/si17

How reproducible:
always

Steps to Reproduce:
1.install rhevm+dwh+reports
2.configure some entities (1 of a kind)
3.Stop postgresql service on remote DB
4.Wait till u get more than 10 files logrotated for engine & server logs
5.Start the postgresql
  
Actual results:
Cannot connect to Reports portal not via Welcome page, nor from Direct link
Restarting ovirt-engine solves the issue

Expected results:
Should work

Additional info:
Restarting ovirt-engine solves the issue
Comment 1 Stephen Gordon 2012-09-13 16:53:28 EDT
I don't really see what this has to do with rhevm-doc, this package does not and has never owned the welcome page.
Comment 2 Einav Cohen 2012-09-16 01:59:16 EDT
David, what do you mean by "Cannot connect to Reports portal"? what happens when you click on the link via the Welcome page or attempt to browse to the reports application via the Direct link?
Comment 3 David Botzer 2012-09-16 04:46:13 EDT
Reproduced on SI18 / Local ((See Logs)
Version 3.1.0-16.el6ev 
--------------------------------------
Its quite a specific scenario: (Also happens on Local setup)
1. Stop postgresql service
2. Restart ovirt-engine service
3. Start postgresql service

What I see is that I quickly return to the portal page (Welcome Page)
Comment 4 David Botzer 2012-09-16 04:46:51 EDT
Created attachment 613384 [details]
report-link
Comment 5 Einav Cohen 2012-09-16 05:51:26 EDT
BTW, what do you mean by "direct link"?  you mean "attempting to browse directly to http(s)://[server-name]/rhevm-reports"?
Comment 6 David Botzer 2012-09-18 23:48:18 EDT
yes,
The URL to the Reports Portal,
Comment 7 Einav Cohen 2012-09-19 02:21:41 EDT
(In reply to comment #6)
> yes,
> The URL to the Reports Portal,

then it has nothing to do with the welcome page -> changing subject accordingly.
this problem is somewhere between the reports application and the engine -> moving to infra for further investigation.
Comment 8 Itamar Heim 2012-09-20 17:52:57 EDT
I'm guessing the reports installer doesn't set the config with the url properly if db is on a remote machine
Comment 9 Ohad Basan 2012-09-25 06:39:50 EDT
I experience the same problem on SI19 using a local DB (not remote)
Comment 10 Juan Hernández 2012-10-02 13:50:29 EDT
The problem in si19 is that the rhevm-reports.war application doesn't start correctly. That has been fixed in si19.1, see bug 861077 for more information.

If I understand the description correctly the problem here is that the reports application doesn't work correctly if you start the ovirt-engine service before the database. Is that correct David? I would then link this to bug 857684 that was created to investigate why the engine can't reconnect to the database, both things look the same to me.
Comment 11 David Botzer 2012-10-07 03:04:06 EDT
The reports application doesn't work correctly if you start the ovirt-engine service before the database. Is that correct David?

I dont interfere with the Engine startup, meaning, I only check that all services are up, and I than I see that i cannot connect,

I have this also when upgrading si19.1 to si20

David,
Comment 12 Juan Hernández 2012-10-09 04:54:25 EDT
A side note: it is the first time in many years that I see this (in console.log):

OpenJDK 64-Bit Server VM warning: CodeCache is full. Compiler has been disabled.
OpenJDK 64-Bit Server VM warning: Try increasing the code cache size using -XX:ReservedCodeCacheSize=
Code Cache  [0x00007fe7517b0000, 0x00007fe757740000, 0x00007fe7577b0000)
 total_blobs=28231 nmethods=27054 adapters=1094 free_code_cache=1363Kb largest_free_block=460992

This is not really related to this bug, but clearly indicates that engine+reports load an abnormally huge amount of classes, probably due to the 231 .jar files that JasperServer includes in the WEB-INF/lib directory.
Comment 13 Juan Hernández 2012-10-09 07:57:52 EDT
The problem in the machine where this was happening is that rhevm-reports has not been deployed correctly (the directory /usr/share/ovirt-engine/rhevm-reports.war doesn't exist). This was probably caused by bug 861149. David, can we close this one as duplicated?
Comment 14 David Botzer 2012-10-09 08:33:36 EDT
Fixed, 3.1/si20 for local & upgraded setup.
in upgrade - Just need to workaround the rhevmreports db thats needs to be dropped

I will wait for a build that works for remnote db as well and close-as-verify
Comment 15 David Botzer 2012-10-10 06:35:20 EDT
Fixed, 3.1/si20
works for Remote DB setup as well,
Dashboards & Reports Portal Works fine
Fixed, 3.1/si20

Note You need to log in before you can comment on or make changes to this bug.