Bug 854686 - The rhn_command.command_class database column default is wrong when upgrading from Satellite 5.0
The rhn_command.command_class database column default is wrong when upgrading...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pazdziora
Martin Minar
:
Depends On:
Blocks: 819027 856133
  Show dependency treegraph
 
Reported: 2012-09-05 10:43 EDT by Jan Pazdziora
Modified: 2012-10-22 07:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: satellite-schema-5.5.0.14-1-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 856133 (view as bug list)
Environment:
Last Closed: 2012-10-22 07:24:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2012-09-05 10:43:57 EDT
Description of problem:

The rhn_command.command_class database column default on Satellite upgraded from version < 5.2 is set to '/var/lib/nocpulse/libexec' rather than to '/var/lib/nocpulse/libexec/plugin' like the freshly installed Satellite 5.5 is.

Version-Release number of selected component (if applicable):

spacewalk-schema-1.7.55-31.el6sat.noarch
satellite-schema-5.5.0.13-1.el6sat.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have Satellite upgraded from 5.0 to 5.5.
2. Connect to its Oracle database with sqlplus.
3. Run SQL> select data_default from user_tab_columns where table_name = 'RHN_COMMAND' and column_name = 'COMMAND_CLASS' ;

Actual results:

DATA_DEFAULT
--------------------------------------------------------------------------------
('/var/lib/nocpulse/libexec')

Expected results:

DATA_DEFAULT
--------------------------------------------------------------------------------
('/var/lib/nocpulse/libexec/plugin')

Additional info:

This issue should have no ill effect on Satellite operation, it's a sanity issue.

The freshly installed Satellite 5.5 will have the default value set to '/var/lib/nocpulse/libexec/plugin' which should also be worth checking upon QA.
Comment 1 Jan Pazdziora 2012-09-05 10:46:26 EDT
Fixed in Spacewalk master, 46ff247497a6b0a13498c8df6f4c9bb80167ff33.
Comment 2 Jan Pazdziora 2012-09-06 09:39:49 EDT
The problem is also present when upgrading from 5.2 to 5.5. So 5.2 can be used isntead of 5.0.
Comment 7 errata-xmlrpc 2012-10-22 07:24:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1394.html

Note You need to log in before you can comment on or make changes to this bug.