Bug 854688 - Live installation hangs with some languages
Live installation hangs with some languages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 853609 854988 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-05 10:48 EDT by Kamil Páral
Modified: 2012-09-17 19:57 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 854959 (view as bug list)
Environment:
Last Closed: 2012-09-17 18:53:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (2.39 KB, text/plain)
2012-09-05 10:50 EDT, Kamil Páral
no flags Details
program.log (74.65 KB, text/plain)
2012-09-05 10:50 EDT, Kamil Páral
no flags Details
storage.log (164.70 KB, text/plain)
2012-09-05 10:50 EDT, Kamil Páral
no flags Details
terminal output (3.98 KB, text/plain)
2012-09-05 12:06 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-09-05 10:48:58 EDT
Description of problem:
If you try to do Live installation (DVD not tested) using Czech language, installer hangs at "preparing to install". I don't see a traceback in logs, but Vratislav Podzimek says there is some storage traceback caused by wrong locale. Instead of using locale cs_CZ.utf8, anaconda incorrectly sets 'cs' locale and then something crashes (gettext?).

It probably also influences other languages, but with a quick search I haven't found them. But some languages crash sooner due to bug 853609. It could have the same cause - wrongly set locale.

Version-Release number of selected component (if applicable):
F18 Alpha TC5 Live GNOME

How reproducible:
always

Steps to Reproduce:
1. boot TC5 Live GNOME
2. select czech language
3. proceed with installation
Comment 1 Kamil Páral 2012-09-05 10:50:14 EDT
Created attachment 610078 [details]
anaconda.log
Comment 2 Kamil Páral 2012-09-05 10:50:18 EDT
Created attachment 610079 [details]
program.log
Comment 3 Kamil Páral 2012-09-05 10:50:22 EDT
Created attachment 610080 [details]
storage.log
Comment 4 Kamil Páral 2012-09-05 10:51:16 EDT
Let's discuss at blocker bug meeting.
Comment 5 Chris Lumens 2012-09-05 11:21:58 EDT
Can you run liveinst from a terminal and see what the error messages look like?
Comment 6 Kamil Páral 2012-09-05 12:05:34 EDT
Great call. I kinda assumed it would be somewhere in the logs (why it isn't?). Three tracebacks in the process!

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/exception.py", line 59, in run_handleException_on_idle
    obj)
  File "/usr/lib/python2.7/site-packages/meh/handler.py", line 101, in handleException
    fd.write(self.exnText)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfd' in position 1059: ordinal not in range(128)


Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 175, in on_selection_changed
    self.retranslate()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 256, in retranslate
    NormalSpoke.retranslate(self)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 364, in retranslate
    xlated = _(before)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 28, in <lambda>
    _ = lambda x: gettext.ldgettext("anaconda", x)
  File "/usr/lib/python2.7/gettext.py", line 543, in ldgettext
    return t.lgettext(message)
  File "/usr/lib/python2.7/gettext.py", line 368, in lgettext
    return tmsg.encode(locale.getpreferredencoding())
UnicodeEncodeError: 'latin-1' codec can't encode character u'\u017e' in position 22: ordinal not in range(256)


Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/install.py", line 62, in doInstall
    turnOnFilesystems(storage)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 196, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 359, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 323, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 419, in execute
    msg = _("Creating %(type)s on %(device)s") % {"type": self.device.format.type, "device": self.device.path}
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 35, in <lambda>
    _ = lambda x: gettext.ldgettext("anaconda", x)
  File "/usr/lib/python2.7/gettext.py", line 543, in ldgettext
    return t.lgettext(message)
  File "/usr/lib/python2.7/gettext.py", line 368, in lgettext
    return tmsg.encode(locale.getpreferredencoding())
UnicodeEncodeError: 'latin-1' codec can't encode character u'\u0159' in position 5: ordinal not in range(256)
Comment 7 Kamil Páral 2012-09-05 12:06:13 EDT
Created attachment 610089 [details]
terminal output
Comment 8 Kamil Páral 2012-09-05 12:07:55 EDT
So it is as Vratislav said - locale is set to incorrect value and because of that gettext uses latin1 to decode translations. That makes some characters appear incorrect and apparently it probably also causes the installation hang.
Comment 9 Chris Lumens 2012-09-05 12:10:57 EDT
A traceback in exception handling (that's the first one you're seeing there) means exception handling itself is going to be all screwed up.  So, that's why you're not getting logs or a dialog.
Comment 10 Adam Williamson 2012-09-05 13:08:40 EDT
Discussed at 2012-09-05 blocker review meeting. We noted this is likely to be considered a dupe of 853609, but for now we'll leave them separate just in case things turn out to be more complex, and this is accepted as a blocker per criterion "The installer must boot and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods" in the case of selecting certain languages.
Comment 11 Chris Lumens 2012-09-06 10:09:32 EDT
*** Bug 854988 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2012-09-06 10:09:42 EDT
*** Bug 853609 has been marked as a duplicate of this bug. ***
Comment 13 Vratislav Podzimek 2012-09-07 05:38:28 EDT
Patch for this issue pushed to the anaconda git repository.
Comment 14 Fedora Update System 2012-09-07 16:16:53 EDT
anaconda-18.6.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.6-1.fc18
Comment 15 Fedora Update System 2012-09-08 15:25:22 EDT
Package anaconda-18.6.6-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.6-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13611/anaconda-18.6.6-1.fc18
then log in and leave karma (feedback).
Comment 16 Kamil Páral 2012-09-11 08:03:08 EDT
This is fixed in F18 Alpha RC2, installation proceeds as normal even with Czech language.
Comment 17 Adam Williamson 2012-09-17 18:53:39 EDT
18.6.7 went stable, so closing this.
Comment 18 Fedora Update System 2012-09-17 19:57:20 EDT
anaconda-18.6.6-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.