Bug 853609 - liveinstaller crashes when selecting german language
liveinstaller crashes when selecting german language
Status: CLOSED DUPLICATE of bug 854688
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 853889 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-01 04:04 EDT by drago01
Modified: 2012-09-06 10:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 10:09:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drago01 2012-09-01 04:04:19 EDT
Description of problem:
When I start the live installier (F18 Alpha TC5), select German as language and press next the installer dies.

Leaving the default selection (english) works (i.e I can press next without having the installer crash).

I do not have any logfiles as my VM crashes when I try to copy the text, but it is 100% reproduceable.
Comment 1 drago01 2012-09-01 04:12:31 EDT
NOTE: I can only reproduce the crash when selecting the language at the first screen, the one in the installation summary works.
Comment 2 Kamil Páral 2012-09-03 08:55:36 EDT
With Czech language Anaconda enters hub screen OK. The problem with German is probably related to bug 853913. The dialog is too wide, it is not rendered properly (just gray box) and after few seconds anaconda quits as a whole.
Comment 3 Chris Lumens 2012-09-04 10:08:43 EDT
*** Bug 853889 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2012-09-04 10:50:19 EDT
It only appears on the welcome language screen because the problem is a result of trying to draw the beta warning.  And you're not getting any log files because it's some sort of pango error that then results in a segfault.  If you run liveinst from a terminal, you'll see.

Note that there doesn't appear to be anything in the alpha criteria specific to translations.
Comment 5 drago01 2012-09-04 11:01:04 EDT
(In reply to comment #4)
> Note that there doesn't appear to be anything in the alpha criteria specific
> to translations.

That doesn't matter the installer shouldn't outright crash just because the user has selected a different option on the first screen.
Comment 6 Chris Lumens 2012-09-04 14:29:46 EDT
Do you have any idea what package or font provides the characters that are currently being displayed as Xs?  I'm seeing that before getting any crashes, and this does not appear to be an issue on regular installs.
Comment 7 drago01 2012-09-04 14:48:04 EDT
(In reply to comment #6)
> Do you have any idea what package or font provides the characters that are
> currently being displayed as Xs?  I'm seeing that before getting any
> crashes, and this does not appear to be an issue on regular installs.

From the pango messages printed out in the terminal it looks like the characters are not valid UTF-8 (there are supposed to be umlauts). The font used is Cantarell so the font package would be abattis-cantarell-fonts. Perhaps the german translations contain non UTF-8 strings?
Comment 8 Kamil Páral 2012-09-05 12:30:01 EDT
Please see bug 854688 - it seems that locale is incorrectly set and therefore the characters are not rendered properly.
Comment 9 Adam Williamson 2012-09-05 12:31:37 EDT
Discussed at 2012-09-05 blocker review meeting. Accepted as a blocker per criterion "The installer must boot and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods", in the case of picking certain languages for the installation process. We consider the languages that cause the crash to be sufficiently commonly used for this to be a blocker.
Comment 10 Chris Lumens 2012-09-06 10:09:42 EDT

*** This bug has been marked as a duplicate of bug 854688 ***

Note You need to log in before you can comment on or make changes to this bug.