Bug 854802 - Typos in rhc sshkey --help
Typos in rhc sshkey --help
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
: 854803 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 22:35 EDT by Jianwei Hou
Modified: 2015-05-14 22:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: fork_ami_US2600_90
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:28:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-09-05 22:35:02 EDT
Description of problem:
run 'rhc sshkey --help', there are typos in the displayed help infomation

Version-Release number of selected component (if applicable):
fork_ami_US2600_76

How reproducible:
always

Steps to Reproduce:
1. run 'rhc sshkey --help'
  
Actual results:
There are typos for the 'show' and 'update' actions

Usage: rhc sshkey <action>

Manage multiple keys for the registered rhcloud user.

List of Actions
  update             Deprecated. "remove" and "addd" instead.
  remove             Remove SSH key from the user account
  list               Display all the SSH keys for the user account
  show               List the SSH key with the givne name
  add                Add SSH key to the user account

Global Options
  -l, --rhlogin login       OpenShift login
  -p, --password password   OpenShift password
  -d, --debug               Turn on debugging
  --noprompt                Do not ask for input
  --config FILE             Path of a different config file
  -h, --help                Display help documentation
  -v, --version             Display version information
  -t, --trace               Display backtrace when an error occurs


Expected results:
  update             Deprecated. "remove" and "add" instead.
  show               List the SSH key with the given name

Additional info:
Comment 1 Jianwei Hou 2012-09-05 22:47:40 EDT
*** Bug 854803 has been marked as a duplicate of this bug. ***
Comment 3 Xiaoli Tian 2012-09-09 22:06:13 EDT
Should be fixed in fork_ami_US2600_90
Comment 4 Jianwei Hou 2012-09-09 22:14:27 EDT
Verifed on fork_ami_US2600_90

Steps:
1. run 'rhc sshkey --help'

Result:

Usage: rhc sshkey <action>

Manage multiple keys for the registered rhcloud user.

List of Actions
  list               Display all the SSH keys for the user account
  update             Deprecated. "remove" and "add" instead.
  remove             Remove SSH key from the user account
  add                Add SSH key to the user account
  show               List the SSH key with the given name

Global Options
  -l, --rhlogin login       OpenShift login
  -p, --password password   OpenShift password
  -d, --debug               Turn on debugging
  --noprompt                Do not ask for input
  --config FILE             Path of a different config file
  -h, --help                Display help documentation
  -v, --version             Display version information
  -t, --trace               Display backtrace when an error occurs

Note You need to log in before you can comment on or make changes to this bug.