This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 854962 - Installed system messed up with live stuff
Installed system messed up with live stuff
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-06 07:58 EDT by Jaroslav Reznik
Modified: 2012-09-17 19:57 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-18.6.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:54:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2012-09-06 07:58:13 EDT
Description of problem: after installation from Live (Fedora 18 Alpha TC6), the installed system contains live stuff - the liveuser is created, in KDE the user is automatically logged to the system with liveuser, installer is present (but properly behaves, does not allow the installation) etc.

Steps to Reproduce:
1. install system from Live image
  
Actual results:
Live stuff available in installed system.

Expected results:
Live stuff should not be available in installed system.
Comment 1 Jaroslav Reznik 2012-09-06 08:41:07 EDT
I'm not sure about correct release blocking criteria for this, neither milestone but seems to be very confusing. Proposing as Alpha blocker, let's talk about it.
Comment 2 Vratislav Podzimek 2012-09-06 08:43:06 EDT
anaconda uses something like 'rsync -a / $NEW_ROOT' to copy the system
Comment 3 Bill Nottingham 2012-09-06 09:45:46 EDT
If I understand that, anaconda is copying the live system image *after* the livecd init script has run, instead of dd'ing the underlying live image device that doesn't have the at-boot changes done?
Comment 4 Bill Nottingham 2012-09-06 09:46:33 EDT
If so, that's a behavior change from prior releases, and would cause the symptoms seen here.
Comment 5 Chris Lumens 2012-09-06 10:53:14 EDT
Well, I believe we always kept anaconda in the installed system.  It was in the on-media environment, so it got copied to the system.  There's likely an old old bug around about that somewhere.  I wouldn't be too optimistic about us dealing with that particular portion any time soon.
Comment 6 Bill Nottingham 2012-09-06 11:02:05 EDT
Right, but IIRC, all the basic live customization (enabling the 'install to hard disk' option, adding the live user, setting up autologin) was done in the ram-based overlay to the system, and therefore didn't make it to the installed system when copying the underlying image.

If we're just copying over the running image, then we get extra stuff we didn't before.
Comment 7 Chris Lumens 2012-09-06 11:21:10 EDT
Yeah, Brian is already looking into this.
Comment 8 Jóhann B. Guðmundsson 2012-09-07 15:30:15 EDT
+1 NTH
Comment 9 Fedora Update System 2012-09-07 16:17:10 EDT
anaconda-18.6.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.6-1.fc18
Comment 10 Adam Williamson 2012-09-07 19:23:06 EDT
Tested an install with 18.6.6-1. There's no liveuser after install, so this has been improved. However, I noticed at least one thing still wrong, that's possibly a part of this. I did not complete the 'root password' spoke in liveinst. I'd expect that to result in a locked root account, but it doesn't - the installed system has a root user with empty password, just like the live environment.
Comment 11 Adam Williamson 2012-09-07 19:45:20 EDT
bcl says the thing I noted in comment #10 is a separate bug, so filed as https://bugzilla.redhat.com/show_bug.cgi?id=855481 .
Comment 12 Adam Williamson 2012-09-07 20:57:39 EDT
we're not great on 'negative criteria', really ('thing X definitely shouldn't happen'), so this isn't terribly well covered. You could argue that auto-logging in as 'liveuser' is a violation of "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied", though it's a bit of a stretch. I guess I'll vote +1 blocker on that basis. Definitely NTH. We have enough votes to accept this as at least NTH at this point (me, Johann, Jaroslav), so accepting as NTH at least.
Comment 13 Adam Williamson 2012-09-07 21:06:42 EDT
As comment #10 is a separate bug, marking VERIFIED, I've confirmed the update fixes this.
Comment 14 Fedora Update System 2012-09-08 15:25:41 EDT
Package anaconda-18.6.6-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.6-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13611/anaconda-18.6.6-1.fc18
then log in and leave karma (feedback).
Comment 15 Jaroslav Reznik 2012-09-10 05:17:07 EDT
Confirmed. Live user stuff is not installed anymore. Root password problem has a separate bug.
Comment 16 Adam Williamson 2012-09-10 11:59:54 EDT
Discussed at 2012-09-10 QA meeting acting as a blocker review meeting. Accepted as a blocker per criterion cited in comment #12.
Comment 17 Kamil Páral 2012-09-11 14:48:54 EDT
Setting to verified per comment 10 and comment 15.
Comment 18 Adam Williamson 2012-09-17 18:54:11 EDT
18.6.7 went stable, so closing this.
Comment 19 Fedora Update System 2012-09-17 19:57:38 EDT
anaconda-18.6.6-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.