Bug 8550 - Crashed INND will not be detected...
Summary: Crashed INND will not be detected...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 8791 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-17 21:02 UTC by Enrico Scholz
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-24 17:18:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-01-17 21:02:06 UTC
The behavior of /etc/rc.d/rc.sysinit to delete all files in /var/run/*
(including /var/run/news/*)[1] leads to a possible loss of news articles.

/etc/rc.d/rc.news tries to detect a crashed innd by looking for
/var/run/news/innd.pid and recovers $ACTIVE then by using the "-r"
option[2]. But because rc.sysinit is deleting innd.pid _before_ $ACTIVE
will be renumbered, inconsistencies will be created.





[1]
# Clean up /var
# I'd use find, but /usr may not be mounted.
for afile in /var/lock/* /var/run/*; do
   if [ -d $afile ]; then
      rm -f $afile/*
   else


[2]
##  Clean shutdown or already running?
if [ -f ${SERVERPID} ] ; then
    if kill -0 `cat ${SERVERPID}` 2>/dev/null; then
        echo 'INND is running'
        exit 0
    fi
    echo 'INND:  PID file exists -- unclean shutdown!'
    RFLAG="-r"
fi

Comment 1 Bill Nottingham 2000-01-24 17:18:59 UTC
*** Bug 8791 has been marked as a duplicate of this bug. ***Will be fixed in initscripts-4.85 when it is released.


Note You need to log in before you can comment on or make changes to this bug.