Bug 8791 - /etc/rc.d/rc.sysinit majorly screws up inn crash recovery!
/etc/rc.d/rc.sysinit majorly screws up inn crash recovery!
Status: CLOSED DUPLICATE of bug 8550
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-24 00:52 EST by Jonathan Kamens
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-24 12:18:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-01-24 00:52:51 EST
The crash recovery code in /etc/rc.d/rc.news in the inn package depends on
being able to determine that inn crashed because /var/run/news/innd.pid
exists before innd is running.  But /etc/rc.d/rc.sysinit blows away
/var/run/news/*!

This means that whenever the system crashes and comes back up, News ends up
in an inconsistent state, with article numbers being reused, bogus overview
data for the reused article numbers, etc.  Yuck.
Comment 1 Bill Nottingham 2000-01-24 12:18:59 EST
*** This bug has been marked as a duplicate of 8550 ***

Note You need to log in before you can comment on or make changes to this bug.