Bug 855156 - update wordpress for EPEL5 with php53
update wordpress for EPEL5 with php53
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: wordpress (Show other bugs)
el5
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matěj Cepl
Fedora Extras Quality Assurance
:
Depends On: 857722 857724
Blocks: 815401
  Show dependency treegraph
 
Reported: 2012-09-06 16:15 EDT by Bill McGonigle
Modified: 2013-02-09 14:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 720429
Environment:
Last Closed: 2012-12-29 14:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill McGonigle 2012-09-06 16:15:13 EDT
Cloning bug 720429 as it's related....

I find myself using the php53 packages on EL5 machines in the field, and to make wordpress work easily there I've created packages locally:

  php53-IDNA_Convert
  php53-simplepie
  wordpress53

so the requires work out.  Being that EPEL5 has another 5 years or so in it, probably staying with WP 3.1.x for the length of it is going to be tricky.  I assume from the below that keeping the 'wordpress' package on this branch is for the purposes of maintaining compatibility with the default php package, but since we have 5.3 shipping as well, does it now make sense to also ship a wordpress53 package in EPEL5 and track their releases, at least until such a point as Wordpress requires a PHP > 5.3? (seems like that would be a while, perhaps 5 years).

I can package up 3.4.1 for EL5 and post the SPEC patches for the above (minimal) if somebody tells me it's an acceptable approach for EPEL5.


+++ This bug was initially created as a clone of Bug #720429 +++

Description of problem:
https://codex.wordpress.org/Version_3.2
 PHP 5.2.4 or greater (old requirement - since WordPress 2.5 was PHP 4.3 or greater) 

Version-Release number of selected component (if applicable):
wordpress-3.2

--- Additional comment from mcepl@redhat.com on 2012-04-23 07:51:12 EDT ---

Wordpress will stay on 3.1 line in EPEL-5.
Comment 1 Matěj Cepl 2012-09-16 11:02:43 EDT
Test src.rpm is at http://mcepl.fedorapeople.org/tmp/wordpress-3.4.2-3.el5.src.rpm, but it requires packages not yet present in EPEL-5.
Comment 2 Fedora Update System 2012-12-12 10:41:52 EST
wordpress-3.5-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/wordpress-3.5-1.el5
Comment 3 Fedora Update System 2012-12-12 17:53:25 EST
Package wordpress-3.5-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing wordpress-3.5-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-13761/wordpress-3.5-1.el5
then log in and leave karma (feedback).
Comment 4 Bill McGonigle 2012-12-13 01:26:21 EST
The el5 machine I have my own 'wordpress53' build on is on a code freeze until after the holidays, so I can't test at the moment, but just a couple notes based on perusing the spec:

1) are we 'forcing' existing el5 'wordpress' package users to pull in php53 packages when this update comes in?  I can see some potential compatibility issues if that happens.
2) I notice the IDNA dependency is gone.  Grepped the wordpress tree for 'IDNA' and came up blank.  Seems like a good development.
Comment 5 Fedora Update System 2012-12-29 14:30:45 EST
wordpress-3.5-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 David Summers 2013-01-04 14:43:35 EST
I started getting YUM updates on EPEL with the wordpress 3.1 -> 3.5.1 upgrade.

It was yelling about php53-simplepie which is apparently not yet in the repo?

wordpress-3.5-1.el5.noarch from epel has depsolving problems
  --> Missing Dependency: php53-simplepie is needed by package wordpress-3.5-1.el5.noarch (epel)
Error: Missing Dependency: php53-simplepie is needed by package wordpress-3.5-1.el5.noarch (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Now I'm trying to either find php53-simplepie or figure out how to get back to wordpress-3.1 and tell YUM not to update that yet.

Please advise.

Thanks
Comment 7 David Summers 2013-01-04 14:44:46 EST
Can php and php53 co-exist?
Comment 8 Matěj Cepl 2013-01-06 14:41:42 EST
(In reply to comment #7)
> Can php and php53 co-exist?

Yes, see bug 857724

Note You need to log in before you can comment on or make changes to this bug.