Bug 855179 - virtual thinpool origin volume mirror conversion attempt fails
Summary: virtual thinpool origin volume mirror conversion attempt fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Zdenek Kabelac
QA Contact: Cluster QE
URL:
Whiteboard:
: 843338 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-06 22:25 UTC by Corey Marthaler
Modified: 2013-02-21 08:13 UTC (History)
10 users (show)

Fixed In Version: lvm2-2.02.98-1.el6
Doc Type: Bug Fix
Doc Text:
Unsupported conversion of thin pools or thin volumes to mirrors has generated unintuitive error messages. Problem has been fixed by explicit error message and immediate exit before the actual conversion is started.
Clone Of:
Environment:
Last Closed: 2013-02-21 08:13:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0501 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2013-02-20 21:30:45 UTC

Description Corey Marthaler 2012-09-06 22:25:47 UTC
Description of problem:
This is similar to bug 855171, however it's the virt origin volume here where the convert is attempted.

[root@taft-01 ~]# lvs -a -o +devices
  LV           VG            Attr     LSize  Pool Origin Data%  Devices
  POOL         snapper_thinp twi-a-tz  1.00g               0.00 POOL_tdata(0)
  [POOL_tdata] snapper_thinp Twi-aot-  1.00g                    /dev/sdc1(0)
  [POOL_tmeta] snapper_thinp ewi-aot-  4.00m                    /dev/sde1(0)
  display_snap snapper_thinp Vwi-a-tz  1.00g POOL origin   0.00
  origin       snapper_thinp Vwi-a-tz  1.00g POOL          0.00

[root@taft-01 ~]# lvconvert -m 1 snapper_thinp/origin
  LV origin is thin volume without first thin volume segment
  Internal error: LV segments corrupted in origin.
  LV origin_mimage_0 is missing thin volume flag for segment 1
  Internal error: LV segments corrupted in origin_mimage_0.

[root@taft-01 ~]# lvs -a -o +devices
  LV           VG            Attr     LSize  Pool Origin Data%  Devices
  POOL         snapper_thinp twi-a-tz  1.00g               0.00 POOL_tdata(0)
  [POOL_tdata] snapper_thinp Twi-aot-  1.00g                    /dev/sdc1(0)
  [POOL_tmeta] snapper_thinp ewi-aot-  4.00m                    /dev/sde1(0)
  display_snap snapper_thinp Vwi-a-tz  1.00g POOL origin   0.00
  origin       snapper_thinp Vwi-a-tz  1.00g POOL          0.00
  origin_mlog  snapper_thinp -wi-----  4.00m                    /dev/sde1(1)



Version-Release number of selected component (if applicable):
2.6.32-279.el6.x86_64

lvm2-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-libs-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-cluster-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
cmirror-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012

Comment 1 Zdenek Kabelac 2012-10-08 12:21:13 UTC
Currently fixed by prohibiting such conversion as not yet supported.

https://www.redhat.com/archives/lvm-devel/2012-October/msg00025.html

Comment 2 Zdenek Kabelac 2012-10-08 12:24:02 UTC
*** Bug 843338 has been marked as a duplicate of this bug. ***

Comment 4 Corey Marthaler 2013-01-04 22:50:28 UTC
Fix verified in the lastest rpms.

2.6.32-348.el6.x86_64
lvm2-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
lvm2-libs-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
lvm2-cluster-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
udev-147-2.43.el6    BUILT: Thu Oct 11 05:59:38 CDT 2012
device-mapper-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-libs-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-event-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-event-libs-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
cmirror-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012


[root@taft-01 ~]# lvconvert -m 1 snapper_thinp/origin
  Converting segment type for snapper_thinp/origin to mirror is not yet supported.

Comment 5 errata-xmlrpc 2013-02-21 08:13:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html


Note You need to log in before you can comment on or make changes to this bug.