Bug 855285 - "AttributeError: 'module' object has no attribute 'addMacros'
"AttributeError: 'module' object has no attribute 'addMacros'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 855897 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-07 04:31 EDT by Jóhann B. Guðmundsson
Modified: 2012-09-17 20:21 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.6.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 20:21:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2012-09-07 04:31:46 EDT
Description of problem:

Chris has already fixed his spelling error "s/addMacros/addMacro" in packaging/yumpayload.py I just need to file this and put this on the blocker bug list so we actually pull the fix in for alpha and fix livecd-to-iso alpha network usb thumbdrives installs......


Version-Release number of selected component (if applicable):

Whatever is on tc6 

How reproducible:

Always

Steps to Reproduce:
1. "livecd-iso-to-disk --format --msdos --reset-mbr Fedora-18-Alpha-TC6-x86_64-netinst.iso /dev/sdb" 

2. Try to install
3.
  
Actual results:

The above error

Expected results:

Network install being performed without a hitch

Additional info:
Comment 1 Jóhann B. Guðmundsson 2012-09-07 04:36:39 EDT
"The installer must be able to complete package installation with the default package set for each supported installation method"
Comment 2 Chris Lumens 2012-09-07 10:33:08 EDT
pow, cherry-picked.
Comment 3 Jóhann B. Guðmundsson 2012-09-07 15:37:02 EDT
+1 Blocker
Comment 4 Adam Williamson 2012-09-07 20:46:43 EDT
+1 blocker if this breaks network install from netinst.iso written to USB with any method...if it only breaks litd and dd is okay then I guess it's technically NTH (per the criterion Johann cited combined with "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods".
Comment 5 Chris Lumens 2012-09-10 10:49:53 EDT
*** Bug 855897 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2012-09-10 11:57:41 EDT
Discussed at 2012-09-10 QA meeting acting as a blocker review meeting. clumens says it should hit any non-live install, so we accept it as a blocker per criterion cited in comment #1.
Comment 7 Adam Williamson 2012-09-10 13:30:50 EDT
This is fixed in 18.6.6, though the update was not marked as fixing this bug, so setting ON_QA.
Comment 8 Kamil Páral 2012-09-11 08:55:55 EDT
I used the reproducer in description with F18 Alpha RC2, the installation went fine.
Comment 9 Adam Williamson 2012-09-17 20:21:19 EDT
18.6.7 went stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.