Bug 855289 - Dri files are missing in lorax ( /usr/lib64/dri/foo-dri.so: cannot open shared object file: No such file or directory )
Dri files are missing in lorax ( /usr/lib64/dri/foo-dri.so: cannot open share...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 04:51 EDT by Jóhann B. Guðmundsson
Modified: 2012-09-19 11:04 EDT (History)
11 users (show)

See Also:
Fixed In Version: lorax-18.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 15:43:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X.log (25.70 KB, text/plain)
2012-09-11 15:05 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2012-09-07 04:51:30 EDT
Description of problem:

After creating installation usb key ( either via dd or livecd ) and booting it the user is left with black screen and a mouse pointer which is a result of  metacity catching a SIGHCHLD when trying to start the X server which is a result of /usr/lib64/dri/ being is empty.

Peter mentioned on irc that he had a patch for that "856984ac4d1fca0011c4eab85aa4ea4f7d5c0062" 

I just need to file this and put this on the blocker bug list so we actually pull the fix in for alpha and fix livecd-to-iso alpha usb thumbdrives installs......


Version-Release number of selected component (if applicable):

With whatever lorax version the tc6 got create with I suppose

How reproducible:

Always

Steps to Reproduce:
1. "livecd-iso-to-disk --format --msdos --reset-mbr Fedora-18-Alpha-TC6-x86_64-DVD.iso /dev/sdb"
2. Boot the stick
3.
  
Actual results:



Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2012-09-07 04:52:45 EDT
"The installer must be able to complete package installation with the default package set for each supported installation method"
Comment 2 Brian Lane 2012-09-07 12:24:00 EDT
Fixed in commit 74e58adfd2958c3520e4830675705c1df35471c6

Note that I have seen this happen intermittently on the same hardware (x200 laptop). I am not 100% sure it is caused by the missing dri files (which were not there in F17 either). But this will be fixed in the next lorax build.
Comment 3 Jóhann B. Guðmundsson 2012-09-07 15:23:12 EDT
+1 Blocker
Comment 4 Fedora Update System 2012-09-07 20:21:55 EDT
lorax-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.18-1.fc18
Comment 5 Adam Williamson 2012-09-07 21:06:00 EDT
Not really sure about this one. No-one else has reported the bug, and bcl isn't convinced the cause is as johann thinks. I'm inclined to -1, but willing to be persuaded :) I have not seen this bug in any of my testing.
Comment 6 Jóhann B. Guðmundsson 2012-09-07 23:23:00 EDT
Well Matthew say this cannot have this affect since the lack of the presence of those .so do not matter but at the same time he says introducing this update which include these .so might cause destabilization. wtf? really hello!!!

Peter has says they always "forget" dri which indicates this indeed matters.

Lots of mixed signals floating around thus I say let's include this stuff in tc7/rc1 and either eliminate this or establish that this actually matters and we can either remove or include based on my testing that the lack of those files are the underlying problem or not and move from there...
Comment 7 Fedora Update System 2012-09-08 15:24:45 EDT
Package lorax-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13600/lorax-18.18-1.fc18
then log in and leave karma (feedback).
Comment 8 Marcos Mello 2012-09-08 21:51:33 EDT
This can be the cause of blank screens I'm getting in Bug 854988

X.log has "/usr/lib64/dri/i965_dri.so: cannot open shared object file: No such file or directory" and Anaconda dies with "SIGCHLD caught when trying to start the X server.". But I'm not sure, because if I use English it doesn't happen...
Comment 9 Adam Williamson 2012-09-10 11:25:24 EDT
Discussed at 2012-09-10 blocker review meeting. Agreed that we'll build a test image with the updated lorax to see if it does in fact address this bug before voting on the issue.
Comment 10 Jeff Bastian 2012-09-11 15:05:48 EDT
Created attachment 611891 [details]
X.log

I ran into this while trying to reproduce bug 855046.  I ran /usr/bin/restart-anaconda a few times and finally got the data I needed for the above bug.

Attached is my /tmp/X.log.old from the first attempt when I got a blank black screen with a mouse cursor.
Comment 11 Kamil Páral 2012-09-11 15:15:43 EDT
Jeff, what TC/RC have you used?

Johann, can you please try to reproduce with F18 Alpha RC2?

Thanks.
Comment 12 Jóhann B. Guðmundsson 2012-09-11 15:27:26 EDT
I'm downloading the rc2 dvd at the moment and it will takes 4 hours and 43 minutes until it completes ( at current download speed ) which makes me able to test this at first around 01:00 in the morning thus I wont be able test this until after work tomorrow which should be around 17:00 - 19:00 depending on if we upgrade our Jira and confluence instances or not ( have to wait until the majority of the corporation has clocked out )....
Comment 13 Jóhann B. Guðmundsson 2012-09-11 15:38:45 EDT
Looking at Jeff's submitted log it contains... 

[    48.560] (EE) AIGLX error: dlopen of /usr/lib64/dri/i915_dri.so failed (/usr/lib64/dri/i915_dri.so: cannot open shared object file: No such file or directory)
[    48.560] (EE) AIGLX: reverting to software rendering
[    48.561] (II) AIGLX: Screen 0 is not DRI capable
[    48.561] (EE) AIGLX error: dlopen of /usr/lib64/dri/swrast_dri.so failed (/usr/lib64/dri/swrast_dri.so: cannot open shared object file: No such file or directory)

So this bug seems to still be present on at least the build he's using...
Comment 14 Jeff Bastian 2012-09-11 15:48:44 EDT
(In reply to comment #11)
> Jeff, what TC/RC have you used?


I ran preupgrade on my Fedora 17 test system.  I ran this on September 7, so whatever was current on that day.  The anaconda.log says it's anaconda version 18.6.5; there are more logs in bug 855046 comment 3.
Comment 15 Jóhann B. Guðmundsson 2012-09-11 15:53:54 EDT
Kparal if you got the rc2 handy you can speed things up by creating a bootable usb stick of the dvd via the livecd method and simply boot it and check if the /usr/lib64/dri/ directory contains 

/usr/lib64/dri/i915_dri.so	
/usr/lib64/dri/i965_dri.so	
/usr/lib64/dri/nouveau_dri.so
/usr/lib64/dri/nouveau_vieux_dri.so	
/usr/lib64/dri/r200_dri.so	
/usr/lib64/dri/r300_dri.so	
/usr/lib64/dri/r600_dri.so	
/usr/lib64/dri/radeon_dri.so	
/usr/lib64/dri/radeonsi_dri.so	
/usr/lib64/dri/swrast_dri.so	
/usr/lib64/dri/vmwgfx_dri.so


If it is still empty the contents of the mesa-dri-drivers package are still missing...
Comment 16 Marcos Mello 2012-09-11 15:58:05 EDT
I was having these error messages with TC6 as reported in Bug 854988

Same with RC2 (x86-64 DVD):

[    61.746] (EE) AIGLX error: dlopen of /usr/lib64/dri/i965_dri.so failed (/usr/lib64/dri/i965_dri.so: cannot open shared object file: No such file or directory)
[    61.746] (EE) AIGLX: reverting to software rendering
[    61.746] (II) AIGLX: Screen 0 is not DRI capable
[    61.746] (EE) AIGLX error: dlopen of /usr/lib64/dri/swrast_dri.so failed (/usr/lib64/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
[    61.746] (EE) GLX: could not load software renderer

The crashes didn't happen anymore though. Probably Bug 854688 now fixed.

Jóhann, /usr/lib64/dri/ is empty here (RC2).
Comment 17 Tim Flink 2012-09-11 16:02:24 EDT
I built a boot.iso with the new lorax so that the fix can be tested.

http://imagebuilder.fedoraproject.org/testimage/18/pretc7-2/Fedora-17-x86_64-netinst.iso
Comment 18 Tim Flink 2012-09-11 16:06:35 EDT
(In reply to comment #17)
> I built a boot.iso with the new lorax so that the fix can be tested.
> 
> http://imagebuilder.fedoraproject.org/testimage/18/pretc7-2/Fedora-17-x86_64-
> netinst.iso

Note that RC2 was not built using the new lorax. We were waiting to see if the dri changes fixed the bug before pulling it in for alpha.
Comment 19 Jóhann B. Guðmundsson 2012-09-11 16:39:37 EDT
I did test both tflinks special netinstall iso image he build for me which contains those dri modules and that netinstall iso work then I wen to confirm that the lack of these driver had any effect ( As Matthew said they should not ) so I did test this again with tc6 netinstall image which lacks those drivers for comparisons and that worked as well thus Matthew was right and we are back to the drawing board on what's actually causing this and it seems it is limited to the livecd + DVD image + an usb stick :|

Once I have finished downloading the rc2 dvd image I can either confirm or deny if it will work.

For the record this is an HP Pavilion DM-1 with 2GB ram and the ATI RS880 ( Mobility Radeon HD 4200 Series )
Comment 20 Brian Lane 2012-09-11 16:56:47 EDT
Same results here with RC2 on my x200 that sometimes doesn't start X. It is unrelated to the presence of the dri files. I have anaconda running from RC2, X.log has the dri errors in it, but things are working fine.

I'll revert the dri change in lorax.
Comment 21 Adam Williamson 2012-09-12 12:30:38 EDT
Discussed at 2012-09-12 blocker review meeting. As the bug here isn't what we thought it was, and we don't seem to have any other reports of it, it's rejected as a blocker for now. If the true cause of the problem is discovered and it seems to be something that would affect a lot of people, the bug can be re-proposed as a blocker.
Comment 22 Jóhann B. Guðmundsson 2012-09-13 15:06:46 EDT
livecd-iso-to-disk --format --msdos --reset-mbr Fedora-18-Alpha-x86_64-DVD.iso /dev/sdb gets me to the "Welcome to Anaconda" thus this seems to be fixed in rc3 and can be closed
Comment 23 Brian Lane 2012-09-17 15:43:33 EDT
Reverted to normal behavior (remove dri files) in lorax-18.19-1
Comment 24 Fedora Update System 2012-09-17 15:43:43 EDT
lorax-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.19-1.fc18
Comment 25 Fedora Update System 2012-09-19 11:04:07 EDT
lorax-18.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.20-1.fc18

Note You need to log in before you can comment on or make changes to this bug.