Bug 855310 - anaconda doesn't install whole package groups I chose when installing from dvd
anaconda doesn't install whole package groups I chose when installing from dvd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-07 07:13 EDT by Petr Schindler
Modified: 2014-03-16 23:32 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 04:37:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kick start from gnome installation (874 bytes, text/plain)
2012-09-07 07:26 EDT, Petr Schindler
no flags Details
anaconda.log from gnome installation (4.22 KB, text/plain)
2012-09-07 07:26 EDT, Petr Schindler
no flags Details
packaging.log from gnome install (111.96 KB, text/plain)
2012-09-07 07:27 EDT, Petr Schindler
no flags Details
anaconda kickstart (762 bytes, text/plain)
2012-09-11 15:27 EDT, Kamil Páral
no flags Details
anaconda package log (187.08 KB, text/plain)
2012-09-11 15:28 EDT, Kamil Páral
no flags Details
F18 Beta TC2 Live vs DVD packages diff (2.74 KB, text/plain)
2012-10-08 11:26 EDT, Kamil Páral
no flags Details

  None (edit)
Description Petr Schindler 2012-09-07 07:13:24 EDT
Description of problem:
I get uncomplete package set, when I'm installing from DVD. When I chose Gnome desktop in package selection (with or without Gnome desktop environment add-on), anaconda installs only about 650 packages (normally it's about 1100) and after reboot I get only terminal after boot. There are missing some packages like gnome-shell and lot of others.

With KDE and LXDE it is the same.

When I install from a mirror it looks that there is more packages installed, but probably another bug prevents to start system, so I'm not sure if the installed system has all needed packages.

Version-Release number of selected component (if applicable):
Fedora-18-Alpha-TC6-x86_64-DVD.iso
anaconda-18.6.5

How reproducible:
always

Steps to Reproduce:
1. Run installer from DVD
2. Choose some desktop to install
3. Perform installation
  
Actual results:
Lot of packages is missing

Expected results:
All packages from groups should be installed

Additional info:
I propose this as a blocker. It could match to the criterion: 'The installer must be able to complete package installation with the default package set for each supported installation method'
Comment 1 Petr Schindler 2012-09-07 07:26:08 EDT
Created attachment 610688 [details]
kick start from gnome installation
Comment 2 Petr Schindler 2012-09-07 07:26:40 EDT
Created attachment 610689 [details]
anaconda.log from gnome installation
Comment 3 Petr Schindler 2012-09-07 07:27:10 EDT
Created attachment 610690 [details]
packaging.log from gnome install
Comment 4 Jesse Keating 2012-09-07 14:09:00 EDT
06:55:40,676 DEBUG packaging: select group core
06:55:40,684 DEBUG packaging: select group multimedia
06:55:40,736 DEBUG packaging: select group input-methods
06:55:40,748 DEBUG packaging: select group gnome
06:55:40,825 DEBUG packaging: select group base-x
06:55:40,860 DEBUG packaging: select group fonts
06:55:41,009 DEBUG packaging: select group hardware-support
06:55:41,023 DEBUG packaging: select group dial-up
06:55:41,037 DEBUG packaging: select group printing
06:55:41,062 DEBUG packaging: select group firefox
06:55:41,071 DEBUG packaging: select group standard
06:55:41,141 DEBUG packaging: select group gnome-desktop

Looks like all the right groups were selected.  If the result isn't right, this is a comps bug, not Anaconda.
Comment 5 Jesse Keating 2012-09-07 14:14:13 EDT
I take it back.  The problem isn't necessarily comps, although that's where the issue was introduced.

It appears that a number of groups have changed their names, and the kickstart input for composing the DVD was not updated to reflect those changes, so the packages winding up on the DVD is not the right package set.  Re-assigning.
Comment 6 Bill Nottingham 2012-09-07 14:15:35 EDT
Taking this, the spin-kickstarts need to be modified, but they need some sanity checking first. Currently doing so.
Comment 7 Jóhann B. Guðmundsson 2012-09-07 15:43:17 EDT
+1 Blocker 

"There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install "
Comment 8 Adam Williamson 2012-09-07 17:17:01 EDT
+1 blocker - I'd suggest rather "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied" as the criterion. You do what ought to be a graphical install, and get "only terminal after boot". That's three +1s, setting ACCEPTED. Also setting MODIFIED, as Bill has fixed up spin-kickstarts and comps.
Comment 9 Kamil Páral 2012-09-11 14:34:19 EDT
I installed F18 Alpha RC2 DVD. I'm not sure this is fixed. I have a lots of stuff installed, but some notable software is missing, e.g. Evolution (although "Graphical Internet" group is marked as installed and Evolution is a default package). Also I don't have LibreOffice, Totem, Rhythmbox, Empathy, Transmission and others that used to be there.
Comment 10 Jesse Keating 2012-09-11 15:04:05 EDT
(In reply to comment #9)
> I installed F18 Alpha RC2 DVD. I'm not sure this is fixed. I have a lots of
> stuff installed, but some notable software is missing, e.g. Evolution
> (although "Graphical Internet" group is marked as installed and Evolution is
> a default package). Also I don't have LibreOffice, Totem, Rhythmbox,
> Empathy, Transmission and others that used to be there.

Check your packages.log.  It should list which groups were actually selected.  There are still some packages that are in multiple groups, or deps of packages in one group that wind up being packages in another.  This makes the "selection" a bit odd, because it could seem like a group is installed even though only parts of that group got installed, and they got installed because of a different group.
Comment 11 Kamil Páral 2012-09-11 15:27:51 EDT
Created attachment 611896 [details]
anaconda kickstart
Comment 12 Kamil Páral 2012-09-11 15:28:10 EDT
Created attachment 611897 [details]
anaconda package log
Comment 13 Jesse Keating 2012-09-11 17:07:09 EDT
13:52:50,768 DEBUG packaging: select group core
13:52:51,431 DEBUG packaging: select package grub2
13:52:51,438 DEBUG packaging: select package e2fsprogs
13:52:51,444 DEBUG packaging: select package authconfig
13:52:51,446 DEBUG packaging: select package system-config-firewall-base
13:52:51,478 DEBUG packaging: select group core
13:52:51,480 DEBUG packaging: select group gnome-desktop
13:52:51,556 DEBUG packaging: select group multimedia
13:52:51,587 DEBUG packaging: select group input-methods
13:52:51,599 DEBUG packaging: select group base-x
13:52:51,622 DEBUG packaging: select group fonts
13:52:51,701 DEBUG packaging: select group hardware-support
13:52:51,725 DEBUG packaging: select group dial-up
13:52:51,734 DEBUG packaging: select group printing
13:52:51,867 DEBUG packaging: select group firefox
13:52:51,870 DEBUG packaging: select group standard

I don't see the graphical internet group selected here.  With the gnome-desktop environment, the optional group that has evolution in it is the "gnome-apps" group, or "Applications for the GNOME Desktop".

If you just pick gnome-desktop environment you aren't going to get evolution.
Comment 14 Adam Williamson 2012-09-11 17:08:48 EDT
okay, so afaict, this is what's happening. It's all down to the Brave New Comps.

The things on the left in the package selection dialog are the groups in comps with 'display_order' 5. The 'GNOME Desktop' option is the group 'gnome-desktop' in comps.

This really is just a fairly core set of GNOME packages, and notably is missing a lot of apps as described above.

The 'major' groups on the left are apparently supposed to have this 'optionlist' mechanism. So, the gnome-desktop group looks like this:

  <environment>
    <id>gnome-desktop</id>
    <_name>GNOME Desktop</_name>
    <_description>GNOME is a highly intuitive and user friendly desktop environment.</_description>
    <display_order>5</display_order>
    <grouplist>
      <groupid>base-x</groupid>
...
      <groupid>gnome-desktop</groupid>
    </grouplist>
    <optionlist>
      <groupid>gnome-apps</groupid>
      <groupid>gnome-media</groupid>
      <groupid>epiphany</groupid>
      <groupid>libreoffice</groupid>
    </optionlist>
  </environment>

According to notting, what this should mean is that all the groups in 'grouplist' get picked when you pick gnome-desktop, and all the groups in 'optionlist' should show up as options in the right-hand pane of newUI's package selection spoke.

This doesn't seem to be working in Alpha RC2. When you select 'GNOME Desktop' on the left, none of the groups in 'optionlist' actually seem to appear on the right. So you have no possibility to select all those subsidiary groups that you probably want.

Even if we fix that...is it really our desired behaviour that people should know to pick GNOME Desktop and then *also* pick several groups in the right-hand pane to get the package loadout they would have got with no manual intervention at all in previous releases? It seems a bit of a stretch.
Comment 15 Jóhann B. Guðmundsson 2012-09-11 17:23:41 EDT
The reason why I use the releng dvd to install was because that install gave me much more *complete* desktop install ( as opposed to the live ) if we are moving away from that we could just as well ditch the dvd completely and move into improving the desktop experience on live images from my point of view. 

The argue can be made that the *DE install should contain at least the same bits as are present on their live counterpart so the end user will at least get the same experience as he might have had, had he tested it on various events etc...
Comment 16 Jóhann B. Guðmundsson 2012-09-11 17:24:50 EDT
As in "the default the *DE install should contain"
Comment 17 Adam Williamson 2012-09-11 17:32:40 EDT
I think the way I'd expect it to work is that the groups under optionlist would be *selected* - not just displayed - by default when the main group was picked, but the user could de-select them if desired. If that's how it's meant to work, then that seems fine, we just need to fix it.
Comment 18 Adam Williamson 2012-09-11 17:42:32 EDT
Well, since this is clearly two different issues, let's split them out.

The bug as reported was clearly to do with the spin-kickstarts/comps mismatch that affected TC6 and RC1. This has definitely been fixed in RC2, the packages we intend to have on the DVD are on there. The problem described in comment #9 on is really a different bug, so let's open a new bug for it and close this one.
Comment 19 Jóhann B. Guðmundsson 2012-09-11 17:46:26 EDT
Well usually you would link to that newly created bug in any case deselecting will never work since what the user has deselected might just get pulled in as a dep which just leads to a broader question of what the purpose is with the releng dvd and which direction it's supposed to take. 

Arguably the users should *learn* to use the application installer that comes with the *DE to install added application or ( try to ) remove applications they dont want.

From my point of view that additional software selection ( other than the DE ) should be removed. That spoke needs to be rework anyway since they currently from my pov don't go so well together and probably is the only thing preventing the removal of the back button and have users automatically dropped back to the main hub once he has selected something.
      
Just my 2 cents
Comment 20 Adam Williamson 2012-09-11 18:17:39 EDT
New bug filed: https://bugzilla.redhat.com/show_bug.cgi?id=856372

Johann, I'm trying to keep the new bug focused on the actual *bug* we're sure exists here, the failure to handle optionlist. It'd be best to post your ideas as separate bugs or for discussion on the anaconda list, I guess.
Comment 21 Jóhann B. Guðmundsson 2012-09-11 18:23:27 EDT
You mean releng right they are responsible for the what's on their dvd and if the dvd releng is supposed to represent the whole community the installer should replace the additional software selection in the software spoke with the option to install the most common server installs ( lamp, dns,dhcp freeipa,apache.jboss etc ) or whatever high profile software stack the community has been working on.
Comment 22 Bill Nottingham 2012-09-11 23:15:52 EDT
Johann - if you'd like to discuss how things work, how they're intended to work, and what we should produce, I suggest you show up to where the installer is developed, the features where the package set are changed, and similar places with patches, or at least concrete ideas.

If, instead, you continue to merely lob random e-mails and bug comments after the fact from the sidelines, based on incorrect assumptions (such as what software is included on the install DVD and what's intended to be offered... did you even bother to look at the kickstart for what's included, or *ask* instead of declaring How It Should Be), then those that actually do the work of designing, coding, and assembling things like this, are going to see the behavior of a troll, and treat your suggestions accordingly.
Comment 23 Jóhann B. Guðmundsson 2012-09-12 04:28:27 EDT
(In reply to comment #22)
> Johann - if you'd like to discuss how things work, how they're intended to
> work, and what we should produce, I suggest you show up to where the
> installer is developed, the features where the package set are changed, and
> similar places with patches, or at least concrete ideas.

You mean like this [1] sorry tried that. Lot of good that did bring not a single reply. Not an even this is absurd or we are trying to move into this direction, etc. Which only to me came off as an proof that other individuals from within the community has said all along that Anaconda is an RHEL only land.

> If, instead, you continue to merely lob random e-mails and bug comments
> after the fact from the sidelines, based on incorrect assumptions (such as
> what software is included on the install DVD and what's intended to be
> offered... did you even bother to look at the kickstart for what's included,
> or *ask* instead of declaring How It Should Be), then those that actually do
> the work of designing, coding, and assembling things like this, are going to
> see the behavior of a troll, and treat your suggestions accordingly.

I'm truly sorry that you ( Bill ) dont like seeing the behavior of people which you yourself is more or less sole responsible for bringing fourth in them with your bullyism arrogance and discouragement which you have shown me on more then one occasion through several release cycles and amongst other things have lead to the disablement of the systemd migration team ( yes we where a team to begin with and yes I dissembled it so they would not have to deal with you). I suggest in the future that you seek guidance with for example Toshio in how to become a guiding force and treat other community members with respect that they deserve for being willing to sacrifice and contribute their own time for the project. Certainly something a man in your position within the community should know how to do.

Even thou on many occasion I come off as demanding it is certainly not without ill intention ( or for a good reason like the how to debug pages that I created and started and fesco/fpc decided to make optional instead of mandatory for packagers you can see the result from that decision now 6000 components later and how much that has help improving reporting. ) nor am I not in individual that is not willing to get his hands dirty even if all it brings is little to no gratitude instead. I have proven that on one and more occasion with actual work in the community ( And probably would be doing more if fesco had approved what Toshio and Stephen requested of them even thou I would have very much liked them to have consulted that with me before submitting that request to fesco since I'm a man that don like surprises especially those that involve me personally ).  

1. https://www.redhat.com/archives/anaconda-devel-list/2010-November/msg00154.html
Comment 24 Jóhann B. Guðmundsson 2012-09-12 04:30:28 EDT
Sorry meant to say not with ill intention
Comment 25 Adam Williamson 2012-09-12 16:00:46 EDT
Johann: well, removing/reworking the spoke would be an anaconda thing. But yeah, this is kind of a complex situation, where the newUI and package selection rework features are intersecting, so to get a sane design, we need to keep anaconda team and Bill (who's doing the package selection rework) pointed in the right direction, and a significant proposal like yours needs to be in some forum where all the right people are reading it. I'm not sure where anaconda team / Bill would best like to have that discussion, Bill could you suggest somewhere? But it's not in this bug report at least.

Aside from that, I guess it's my turn to play the 'be excellent to each other' card - Bill, Johann really is trying to be constructive, though he comes off a bit abrasively at times (don't we all :>), like he acknowledged. I think it'd be best if we just decide on where would be an appropriate venue to discuss exactly how this should work, both in terms of what the package groups should be and how anaconda should present them, and go ahead with the discussion there. I think all parties agree that the design as it stands is not exactly what we want, so obviously the next step is to decide on what we do want and implement it.
Comment 26 Bill Nottingham 2012-09-12 16:05:46 EDT
Sounds good. My intention is not to bully, although I'm guessing it probably comes off that way due to the frustration involved. My intention is to try and redirect that enthusiasm to where it's most likely to get results, rather than in adjunct comments to bugs, etc.

As to redesigning how anaconda displays what it's going to install, that does need to be done on anaconda-devel/anaconda-patches ; it needs worked in conjunction with upstream anaconda and the designers there.

For what goes on the DVD, and what should be offered to be installed, that's a devel@ list thread. (Or simple bugs against comps for simple requests.)
Comment 27 Christoph Wickert 2012-10-07 18:43:32 EDT
This is still not working correctly in F18 Beta TC2:

1. Install e.g. the lxde-desktop group
2. Reboot. No firstboot but lxdm.

firstboot package is not installed, although it is in the group.
Comment 28 Kamil Páral 2012-10-08 11:24:02 EDT
Yes, I also think it's still broken (or is it a different bug?). The DVD install misses a lot of important packages. I have made a diff between Live install and DVD install of F18 Beta TC2 (I'll attach the files), the most important missing files from DVD install are:

evolution
gnome-boxes
gnome-games
rhythmbox
shotwell
simple-scan
sound-juicer
vinagre
vino

I think the reason is that if you open up package selection in Anaconda and select GNOME, all the "add-ons" are unchecked, even those that should probably be checked, like "Applications for the GNOME desktop", "LibreOffice" and "Multimedia support for GNOME".
Comment 29 Kamil Páral 2012-10-08 11:26:08 EDT
Created attachment 623518 [details]
F18 Beta TC2 Live vs DVD packages diff

Please note that this is just a diff between Live and DVD. Both media also miss some important packages when compared to F17 installations, like 'vim'.
Comment 30 Kamil Páral 2012-10-08 11:27:39 EDT
I'm changing F18Alpha blocker to F18Beta, but erasing AcceptedBlocker because I'm not sure this is still the same bug with the same importance.
Comment 31 Bill Nottingham 2012-10-08 16:25:44 EDT
Christoph - I think what you're seeing is bug 863886. See https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-October/001485.html

Kamil, that's sort of expected that if the groups with those packages aren't selected, the packages aren't installed. We can quibble about what should be in default-selected groups, but from a behavior standpoint, what you see is what should happen given the data presented to anaconda.
Comment 32 Christoph Wickert 2012-10-08 16:32:13 EDT
(In reply to comment #31)
> Christoph - I think what you're seeing is bug 863886.

Yes, I filed that bug after I wrote my comment here.
Comment 33 Jesse Keating 2012-10-08 17:47:06 EDT
The DVD missing packages sounds like a compose issue, perhaps pungi and the compose kickstarts need some more tweaking for how the new comps works?

As for this bug, I believe that this bug is indeed fixed, just has the wrinkle of the other bug that Christoph filed.

Does anybody see any reason why this bug needs to remain open?
Comment 34 Kamil Páral 2012-10-09 04:37:13 EDT
Thanks for an explanation. I reported bug 864353 wrt the unchecked add-ons and I'm closing this bug again.

Note You need to log in before you can comment on or make changes to this bug.