Bug 856372 - Package selection spoke is not respecting 'optionlist' from comps in F18 Alpha RC2
Package selection spoke is not respecting 'optionlist' from comps in F18 Alph...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
All All
unspecified Severity high
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-11 18:14 EDT by Adam Williamson
Modified: 2014-01-21 18:23 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 16:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-09-11 18:14:46 EDT
As discussed in comment #9 through comment #16 of https://bugzilla.redhat.com/show_bug.cgi?id=855310 , anaconda in F18 Alpha RC2 does not seem to be respecting the 'optionlist' directive in comps.

As described in https://lists.fedoraproject.org/pipermail/devel/2012-August/170620.html by Bill:

"Each environment has a grouplist that lists the groups that make up this
enviroment - these are the required groups that will be installed if you
select this environment. It also has a list of options for that environment,
which are also groups in comps...Whenever an environment is selected in anaconda in the left pane, the right pane will be populated with:
- the list of options for that environment in comps"

i.e., when you pick a group in the left-hand pane of the package spoke, the groups listed in its 'optionlist' directive (if it has any) should show up in the right-hand pane of the package spoke (regardless of what <uservisible> is set to). This definitely isn't working in Alpha RC2, though. The list of groups in the right hand pane consists only of all groups with <uservisible>true</uservisible>, and never changes, whatever you pick in the left-hand pane.

I don't think this strictly violates the Alpha criteria, as the desktop groups themselves do at least contain enough packages to start the desktops and run a browser and a terminal and the software update app, which is all we require for Alpha. But proposing as NTH, as obviously we want people to be able to install a fully-featured desktop.
Comment 1 Jóhann B. Guðmundsson 2012-09-11 18:25:22 EDT
-1 blocker +1 nth
Comment 2 satellitgo 2012-09-11 18:32:28 EDT
I am able to select left gnome and right sugar-desktop in anaconda and they both install using both RC2 DVD and netinstall x86_64. A 2 DE install. And they both install to HD sucessfuly.
Comment 3 Jesse Keating 2012-09-11 19:02:15 EDT
Root cause is that createrepo, when writing out the group metadata, is translating the <groupid> element in the input comps to <optionid> in the output comps.  Nothing is actually looking for a <optionid>, so we never actually find these optional groups.

Patch sent upstream to yum.
Comment 4 Fedora Update System 2012-09-12 09:53:34 EDT
yum-3.4.3-44.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-44.fc18
Comment 5 Fedora Update System 2012-09-12 15:12:12 EDT
Package yum-3.4.3-44.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-44.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13862/yum-3.4.3-44.fc18
then log in and leave karma (feedback).
Comment 6 Adam Williamson 2012-09-12 15:15:24 EDT
Discussed at 2012-09-12 NTH review meeting. Accepted as NTH with the proviso that we'll only pull a yum build that *only* changes this (and other NTH/blocker fixes), nothing else, for safety reasons.
Comment 7 Fedora Update System 2012-09-20 16:38:10 EDT
yum-3.4.3-44.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.