This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 855391 - rhev-hypervisor6-tools and rhev-hypervisor-tools obselete each other
rhev-hypervisor6-tools and rhev-hypervisor-tools obselete each other
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: Reopened, ZStream
Depends On: 842454
Blocks: 865773
  Show dependency treegraph
 
Reported: 2012-09-07 11:09 EDT by Chris Pelland
Modified: 2016-04-26 11:35 EDT (History)
18 users (show)

See Also:
Fixed In Version: rhev-hypervisor6-6.3-20121012.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 865773 (view as bug list)
Environment:
Last Closed: 2012-10-18 12:47:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-09-07 11:09:16 EDT
This bug has been copied from bug #842454 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 6 Mike Burns 2012-10-04 09:24:22 EDT
To fix this, I would have to have a new rhev-hypervisor6-tools package with corrected obsoletes and that's not easily done.  

In 6.4, this will be solved by the removal of both of these packages, so probably not worth fixing at this point.
Comment 16 Mike Burns 2012-10-12 07:19:49 EDT
Respinning iso and rpms.  

Only ISO change is version number

rpms:

rhev-hypervisor6-6.3-20121012.0.fc17.noarch.rpm:
/usr/share/rhev-hypervisor
/usr/share/rhev-hypervisor/rhevh-6.3-20121012.0.fc17.iso
/usr/share/rhev-hypervisor/vdsm-compatibility-6.3-20121012.0.fc17.txt
/usr/share/rhev-hypervisor/version-6.3-20121012.0.fc17.txt
--------------------------
rhev-hypervisor6-tools-6.3-20121012.0.fc17.noarch.rpm:
/usr/share/rhev-hypervisor-tools
/usr/share/rhev-hypervisor-tools/rhev-hypervisor-tools.txt

This removes the circular obsoletes, but leaves one additional issue to be solved. 

currently rhev-hypervisor-tools obsoletes rhev-hypervisor6-tools < 6.3.  The new rhev-hypervisor6-tools is > 6.3, so obsolete doesn't work.  I will clone this bz and fix that in the next update.  The original problem here is fixed though.
Comment 20 errata-xmlrpc 2012-10-18 12:47:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2012-1375.html

Note You need to log in before you can comment on or make changes to this bug.