Bug 842454 - rhev-hypervisor6-tools and rhev-hypervisor-tools obselete each other
rhev-hypervisor6-tools and rhev-hypervisor-tools obselete each other
Status: CLOSED DUPLICATE of bug 827713
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: ZStream
: 865773 (view as bug list)
Depends On:
Blocks: 855391 865773
  Show dependency treegraph
 
Reported: 2012-07-23 17:57 EDT by Bryan Yount
Modified: 2016-04-26 11:11 EDT (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 09:26:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Yount 2012-07-23 17:57:02 EDT
Description of problem:
When running yum update on RHEV-M, the rhev-hypervisor6-tools package was obseleted in favor of the rhev-hypervisor-tools package. Then, yum update was run again and the same thing happened in reverse. And so on...

Version-Release number of selected component (if applicable):
rhev-hypervisor6-tools.noarch                  6.2-20120510.0.el6_2
rhev-hypervisor-tools.noarch                   2.3.0-15.el6_3.2

How reproducible:
Very

Steps to Reproduce:
1. Install rhev-hypervisor6-tools
2. Run 'yum update'
3. rhev-hypervisor-tools will obselete rhev-hypervisor6-tools
4. Run 'yum update' again
5. rhev-hypervisor6-tools will obselete rhev-hypervisor-tools
6. Repeat
  
Actual results:
The 2 packages keep obseleting each other

Expected results:
This should only happen once

Additional info:
[root@rhev3test2 ~]# yum update
Loaded plugins: product-id, rhnplugin, security, subscription-manager, versionlock
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rhev-hypervisor-tools.noarch 0:2.3.0-15.el6_3.2 will be obsoleting
---> Package rhev-hypervisor6-tools.noarch 0:6.2-20120510.0.el6_2 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================
 Package                       Arch           Version                     Repository                          Size
===================================================================================================================
Installing:
 rhev-hypervisor-tools         noarch         2.3.0-15.el6_3.2            rhel-x86_64-server-6-rhevh          39 k
     replacing  rhev-hypervisor6-tools.noarch 6.2-20120510.0.el6_2

Transaction Summary
===================================================================================================================
Install       1 Package(s)

Total download size: 39 k
Is this ok [y/N]: n
Exiting on user Command

...

[root@rhev3test2 ~]# yum update
Loaded plugins: product-id, rhnplugin, security, subscription-manager, versionlock
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rhev-hypervisor-tools.noarch 0:2.3.0-15.el6_3.2 will be obsoleting
---> Package rhev-hypervisor6-tools.noarch 0:6.2-20120510.0.el6_2 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================
 Package                       Arch           Version                     Repository                          Size
===================================================================================================================
Installing:
 rhev-hypervisor-tools         noarch         2.3.0-15.el6_3.2            rhel-x86_64-server-6-rhevh          39 k
     replacing  rhev-hypervisor6-tools.noarch 6.2-20120510.0.el6_2

Transaction Summary
===================================================================================================================
Install       1 Package(s)

Total download size: 39 k
Is this ok [y/N]: n
Exiting on user Command
Comment 3 Bryan Yount 2012-07-23 18:26:10 EDT
Oops, I accidentally posted the same output twice in my initial comment. Sorry about that. I wish you could edit comments in bugzilla. Here's the proper output:



[root@rhev3test2 ~]# yum update
Loaded plugins: product-id, rhnplugin, security, subscription-manager, versionlock
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rhev-hypervisor-tools.noarch 0:2.3.0-15.el6_3.2 will be obsoleting
---> Package rhev-hypervisor6-tools.noarch 0:6.2-20120510.0.el6_2 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================
 Package                       Arch           Version                     Repository                          Size
===================================================================================================================
Installing:
 rhev-hypervisor-tools         noarch         2.3.0-15.el6_3.2            rhel-x86_64-server-6-rhevh          39 k
     replacing  rhev-hypervisor6-tools.noarch 6.2-20120510.0.el6_2

Transaction Summary
===================================================================================================================
Install       1 Package(s)


...



[root@rhev3test2 ~]# yum update
Loaded plugins: product-id, rhnplugin, security, subscription-manager, versionlock
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rhev-hypervisor-tools.noarch 0:2.3.0-15.el6_3.2 will be obsoleted
---> Package rhev-hypervisor6-tools.noarch 0:6.2-20120510.0.el6_2 will be obsoleting
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================
 Package                       Arch          Version                       Repository                         Size
===================================================================================================================
Installing:
 rhev-hypervisor6-tools        noarch        6.2-20120510.0.el6_2          rhel-x86_64-server-6-rhevh         14 k
     replacing  rhev-hypervisor-tools.noarch 2.3.0-15.el6_3.2

Transaction Summary
===================================================================================================================
Install       1 Package(s)
Comment 8 Mike Burns 2012-10-04 09:26:24 EDT

*** This bug has been marked as a duplicate of bug 827713 ***
Comment 9 Mike Burns 2012-10-15 17:25:43 EDT
*** Bug 865773 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.